Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет рабочего времени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет рабочего времени (Формулы/Formulas)
Расчет рабочего времени
feksel Дата: Пятница, 28.10.2016, 12:22 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Привет знатоки! :)

На первом листе есть рабочий график сотрудников, на втором листе указывается расшифровка графика - в столбце А указывается номер местности где они должны будут находиться, а в строке В – время которое они должны будут там провести.
Возможно ли задать расчет времени которое они отработают за месяц. Но с одним НО… Общее время должно считаться только в тех строках графика (в первом листе) где над числами стоит надпись СЧЕТ, а если нет этой надписи, то время за эту дату не считается.

Допустим у Есенина должно получиться – 76 часов, а если стереть надпись СЧЕТ над датами 20.10 и 26.10, то должно получиться 62.
К сообщению приложен файл: _Microsoft_Exce.xlsx(12Kb)
 
Ответить
СообщениеПривет знатоки! :)

На первом листе есть рабочий график сотрудников, на втором листе указывается расшифровка графика - в столбце А указывается номер местности где они должны будут находиться, а в строке В – время которое они должны будут там провести.
Возможно ли задать расчет времени которое они отработают за месяц. Но с одним НО… Общее время должно считаться только в тех строках графика (в первом листе) где над числами стоит надпись СЧЕТ, а если нет этой надписи, то время за эту дату не считается.

Допустим у Есенина должно получиться – 76 часов, а если стереть надпись СЧЕТ над датами 20.10 и 26.10, то должно получиться 62.

Автор - feksel
Дата добавления - 28.10.2016 в 12:22
китин Дата: Пятница, 28.10.2016, 12:31 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
можно так
Код
=СУММЕСЛИ($B$1:$AF$1;"СЧЕТ";$B3:$AF3)
или так( массивная)
Код
=СУММПРОИЗВ(ЕСЛИ(ЕЧИСЛО($B$3:$AF$6);$B$3:$AF$6)*($B$1:$AF$1="СЧЕТ")*($A$3:$A$6=$A12))
или так тоже масивная
Код
=СУММ(ЕСЛИ(($B$1:$AF$1="СЧЕТ")*($A$3:$A$6=$A12);$B$3:$AF$6))

[p.s.]посчитали неправильно :p
К сообщению приложен файл: 555111.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 28.10.2016, 12:37
 
Ответить
Сообщениеможно так
Код
=СУММЕСЛИ($B$1:$AF$1;"СЧЕТ";$B3:$AF3)
или так( массивная)
Код
=СУММПРОИЗВ(ЕСЛИ(ЕЧИСЛО($B$3:$AF$6);$B$3:$AF$6)*($B$1:$AF$1="СЧЕТ")*($A$3:$A$6=$A12))
или так тоже масивная
Код
=СУММ(ЕСЛИ(($B$1:$AF$1="СЧЕТ")*($A$3:$A$6=$A12);$B$3:$AF$6))

[p.s.]посчитали неправильно :p

Автор - китин
Дата добавления - 28.10.2016 в 12:31
feksel Дата: Пятница, 28.10.2016, 12:44 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Расчет рабочего времени идет не верно, я стираю над первым числом надпись СЧЕТ в Вашем файле и показывает время у Есенина 77 часов, то есть убавляется 1 час, а должно вычитаться 8 часов, и так с любым числом. Часы какие должны рассчитываться указаны на ВТОРОМ ЛИСТЕ


Сообщение отредактировал feksel - Пятница, 28.10.2016, 12:47
 
Ответить
СообщениеРасчет рабочего времени идет не верно, я стираю над первым числом надпись СЧЕТ в Вашем файле и показывает время у Есенина 77 часов, то есть убавляется 1 час, а должно вычитаться 8 часов, и так с любым числом. Часы какие должны рассчитываться указаны на ВТОРОМ ЛИСТЕ

Автор - feksel
Дата добавления - 28.10.2016 в 12:44
китин Дата: Пятница, 28.10.2016, 12:48 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
то есть убавляется 1 час, а должно вычитаться 8 часов, и так с любым числом

ну и хде это прописано в вашем первом посте?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
то есть убавляется 1 час, а должно вычитаться 8 часов, и так с любым числом

ну и хде это прописано в вашем первом посте?

Автор - китин
Дата добавления - 28.10.2016 в 12:48
feksel Дата: Пятница, 28.10.2016, 12:52 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
на втором листе указывается расшифровка графика - в столбце А указывается номер местности где они должны будут находиться, а в строке В – время которое они должны будут там провести.
Возможно ли задать расчет времени которое они отработают за месяц.


Вот это прописано, может Вы не так поняли или может я не понятно пояснил не знаю


Сообщение отредактировал feksel - Пятница, 28.10.2016, 12:53
 
Ответить
Сообщение
на втором листе указывается расшифровка графика - в столбце А указывается номер местности где они должны будут находиться, а в строке В – время которое они должны будут там провести.
Возможно ли задать расчет времени которое они отработают за месяц.


Вот это прописано, может Вы не так поняли или может я не понятно пояснил не знаю

Автор - feksel
Дата добавления - 28.10.2016 в 12:52
китин Дата: Пятница, 28.10.2016, 13:07 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
объясните откуда у вас получается у Есенина 76 часов? в вашем файле я насчитал 109


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеобъясните откуда у вас получается у Есенина 76 часов? в вашем файле я насчитал 109

Автор - китин
Дата добавления - 28.10.2016 в 13:07
китин Дата: Пятница, 28.10.2016, 13:13 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну может пятница и я тупой. смотрите вот так . массивная . строки 19 и 20 для самопроверки. можете удалить
Код
=СУММ(ЕСЛИ(($B3:$AF3=Лист2!$A$1:$A$18)*($B$1:$AF$1="СЧЕТ");Лист2!$B$1:$B$18))
К сообщению приложен файл: 555111_2.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену может пятница и я тупой. смотрите вот так . массивная . строки 19 и 20 для самопроверки. можете удалить
Код
=СУММ(ЕСЛИ(($B3:$AF3=Лист2!$A$1:$A$18)*($B$1:$AF$1="СЧЕТ");Лист2!$B$1:$B$18))

Автор - китин
Дата добавления - 28.10.2016 в 13:13
feksel Дата: Пятница, 28.10.2016, 13:16 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
объясните откуда у вас получается у Есенина 76 часов? в вашем файле я насчитал 109


Извиняюсь, мой косяк, О - это просто отпуск и я привык не считать его на работе. У Вас правильно 109, а я вот без отпуска посчитал 76.

Там должно быть 109, а если минус 2 дня про какие писал, то 95.

Извиняюсь еще раз((( %)
 
Ответить
Сообщение
объясните откуда у вас получается у Есенина 76 часов? в вашем файле я насчитал 109


Извиняюсь, мой косяк, О - это просто отпуск и я привык не считать его на работе. У Вас правильно 109, а я вот без отпуска посчитал 76.

Там должно быть 109, а если минус 2 дня про какие писал, то 95.

Извиняюсь еще раз((( %)

Автор - feksel
Дата добавления - 28.10.2016 в 13:16
feksel Дата: Пятница, 28.10.2016, 13:24 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Все верно, большое спасибо
 
Ответить
СообщениеВсе верно, большое спасибо

Автор - feksel
Дата добавления - 28.10.2016 в 13:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет рабочего времени (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!