Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет потребности в сырье исходя из рецепта и плана пр-ва, - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет потребности в сырье исходя из рецепта и плана пр-ва, (Формулы/Formulas)
Расчет потребности в сырье исходя из рецепта и плана пр-ва,
chalayarv Дата: Пятница, 28.10.2016, 16:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Помогите пожалуйста решить задачу, необходимо рассчитать потребность в сырье по-месячно, исходя из таблицы рецептов и плана производства на каждый месяц. Т.Е. ищем компонент, смотрим в каком изделии (по рецепту) он участвует в текущем месяце и считаем сумму произведения кол-ва сырья на кол-во изделия поставленного в производство. У меня формула работает только в том случае, когда по всем изделиям из книги рецептов выставлен план производства. А вот когда в книге рецептов есть новое изделие а в плане его нет, выдает ошибку НД. Помогите разобраться, большое спасибо.
 
Ответить
СообщениеДобрый день. Помогите пожалуйста решить задачу, необходимо рассчитать потребность в сырье по-месячно, исходя из таблицы рецептов и плана производства на каждый месяц. Т.Е. ищем компонент, смотрим в каком изделии (по рецепту) он участвует в текущем месяце и считаем сумму произведения кол-ва сырья на кол-во изделия поставленного в производство. У меня формула работает только в том случае, когда по всем изделиям из книги рецептов выставлен план производства. А вот когда в книге рецептов есть новое изделие а в плане его нет, выдает ошибку НД. Помогите разобраться, большое спасибо.

Автор - chalayarv
Дата добавления - 28.10.2016 в 16:06
chalayarv Дата: Пятница, 28.10.2016, 16:08 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Прошу прощения, вот файл
К сообщению приложен файл: 6661769.xlsx(14Kb)
 
Ответить
СообщениеПрошу прощения, вот файл

Автор - chalayarv
Дата добавления - 28.10.2016 в 16:08
chalayarv Дата: Пятница, 28.10.2016, 16:10 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Главная проблема в том в формуле, что если в книге рецептов у меня добавляется новая продукция, а в плане ее нет, то формула выдает ошибку НД. А добавлять в план изделие с 0 выпуском мне не нужно. Помогите....
 
Ответить
СообщениеГлавная проблема в том в формуле, что если в книге рецептов у меня добавляется новая продукция, а в плане ее нет, то формула выдает ошибку НД. А добавлять в план изделие с 0 выпуском мне не нужно. Помогите....

Автор - chalayarv
Дата добавления - 28.10.2016 в 16:10
Michael_S Дата: Пятница, 28.10.2016, 18:03 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
Ну так вы считаете по рецептам, а надо по плану.
Поменяйте местами в формуле план и рецепты.


ЯД: 41001136675053
WM: R389613894253
 
Ответить
СообщениеНу так вы считаете по рецептам, а надо по плану.
Поменяйте местами в формуле план и рецепты.

Автор - Michael_S
Дата добавления - 28.10.2016 в 18:03
buchlotnik Дата: Пятница, 28.10.2016, 19:25 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
не вдаваясь в оптимизацию (массивка):
Код
=СУММ(ИНДЕКС(Рецепты!$E$3:$H$7;ПОИСКПОЗ($C6;Рецепты!$D$3:$D$7;);)*ЕСЛИОШИБКА(ПРОСМОТР(ПОИСКПОЗ(Рецепты!$E$2:$H$2;ПЛАН!$E$2:$G$2;0);ПОИСКПОЗ(ПЛАН!$E$2:$G$2;ПЛАН!$E$2:$G$2;);ИНДЕКС(ПЛАН!$E$3:$G$6;ПОИСКПОЗ(E$5;ПЛАН!$D$3:$D$6;);));0))
К сообщению приложен файл: 8411328.xlsx(15Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 28.10.2016, 19:26
 
Ответить
Сообщениене вдаваясь в оптимизацию (массивка):
Код
=СУММ(ИНДЕКС(Рецепты!$E$3:$H$7;ПОИСКПОЗ($C6;Рецепты!$D$3:$D$7;);)*ЕСЛИОШИБКА(ПРОСМОТР(ПОИСКПОЗ(Рецепты!$E$2:$H$2;ПЛАН!$E$2:$G$2;0);ПОИСКПОЗ(ПЛАН!$E$2:$G$2;ПЛАН!$E$2:$G$2;);ИНДЕКС(ПЛАН!$E$3:$G$6;ПОИСКПОЗ(E$5;ПЛАН!$D$3:$D$6;);));0))

Автор - buchlotnik
Дата добавления - 28.10.2016 в 19:25
chalayarv Дата: Понедельник, 31.10.2016, 10:14 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, ОГРОМНОЕ ВАМ СПАСИБО!!!!! :)
 
Ответить
Сообщениеbuchlotnik, ОГРОМНОЕ ВАМ СПАСИБО!!!!! :)

Автор - chalayarv
Дата добавления - 31.10.2016 в 10:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет потребности в сырье исходя из рецепта и плана пр-ва, (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!