Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет уникальных значений по двум условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет уникальных значений по двум условиям (Формулы/Formulas)
Подсчет уникальных значений по двум условиям
martyr Дата: Среда, 02.11.2016, 12:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день,
подскажите пож. как посчитать кол-во уникальных значений по двум условиям по примеру удаления дубликатов, но только в заданном периоде времени
К сообщению приложен файл: 5094022.xlsx(11Kb)
 
Ответить
СообщениеДобрый день,
подскажите пож. как посчитать кол-во уникальных значений по двум условиям по примеру удаления дубликатов, но только в заданном периоде времени

Автор - martyr
Дата добавления - 02.11.2016 в 12:50
_Boroda_ Дата: Среда, 02.11.2016, 13:46 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3949 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=СЧЁТ(1/(ПОИСКПОЗ(A$2:A$99&B2&C2;A$2:A$99&B$2:B$99&C$2:C$99;)=СТРОКА($1:$88)))

Почему В первом блоке 4, если там яблоки, груши и мы_ее?
К сообщению приложен файл: 5094022_1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=СЧЁТ(1/(ПОИСКПОЗ(A$2:A$99&B2&C2;A$2:A$99&B$2:B$99&C$2:C$99;)=СТРОКА($1:$88)))

Почему В первом блоке 4, если там яблоки, груши и мы_ее?

Автор - _Boroda_
Дата добавления - 02.11.2016 в 13:46
krosav4ig Дата: Среда, 02.11.2016, 19:58 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
а у мну немассивная получилась
Код
=СУММПРОИЗВ(АГРЕГАТ(15;6;1/СЧЁТЕСЛИМН(A$2:A$29;A$2:A$29;B$2:B$29;B$2:B$29;C$2:C$29;(C$2:C$29=C2)*C2);СТРОКА($A$1:ИНДЕКС($A:$A;СЧЁТЕСЛИМН(B$2:B$29;B2;C$2:C$29;C2)))))

тока для Excel 2010+


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Среда, 02.11.2016, 19:59
 
Ответить
Сообщениеа у мну немассивная получилась
Код
=СУММПРОИЗВ(АГРЕГАТ(15;6;1/СЧЁТЕСЛИМН(A$2:A$29;A$2:A$29;B$2:B$29;B$2:B$29;C$2:C$29;(C$2:C$29=C2)*C2);СТРОКА($A$1:ИНДЕКС($A:$A;СЧЁТЕСЛИМН(B$2:B$29;B2;C$2:C$29;C2)))))

тока для Excel 2010+

Автор - krosav4ig
Дата добавления - 02.11.2016 в 19:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет уникальных значений по двум условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!