Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подтянуть данные построчно - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтянуть данные построчно (Формулы/Formulas)
Подтянуть данные построчно
Dgerri Дата: Среда, 02.11.2016, 16:57 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте уважаемы Гуру!
Необходимо на автомате подтягивать данные по доп. время с учетом городов.
Так к примеру:
Водитель 01 каждый день посещает разные города, с учетом км. есть доп.время...
Как подтянуть данные доп.время в ячейку?
Города проставляются вручную...

п.с. разные водители могут в один день посетить один город

Заранее спасибо
К сообщению приложен файл: 1745037.xlsx(11Kb)
 
Ответить
СообщениеЗдравствуйте уважаемы Гуру!
Необходимо на автомате подтягивать данные по доп. время с учетом городов.
Так к примеру:
Водитель 01 каждый день посещает разные города, с учетом км. есть доп.время...
Как подтянуть данные доп.время в ячейку?
Города проставляются вручную...

п.с. разные водители могут в один день посетить один город

Заранее спасибо

Автор - Dgerri
Дата добавления - 02.11.2016 в 16:57
AVI Дата: Среда, 02.11.2016, 17:03 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Для ячейки H3
Код
=ДВССЫЛ("C"&(H1+1))

Формат ячейки ч:мм


Сообщение отредактировал AVI - Среда, 02.11.2016, 17:04
 
Ответить
СообщениеДля ячейки H3
Код
=ДВССЫЛ("C"&(H1+1))

Формат ячейки ч:мм

Автор - AVI
Дата добавления - 02.11.2016 в 17:03
sboy Дата: Среда, 02.11.2016, 17:03 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 48 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
Если правильно понял, то
Код
=ИНДЕКС($C$2:$C$28;ПОИСКПОЗ(E2;$A$2:$A$28;0))
К сообщению приложен файл: 8163273.xlsx(11Kb)
 
Ответить
СообщениеДобрый день.
Если правильно понял, то
Код
=ИНДЕКС($C$2:$C$28;ПОИСКПОЗ(E2;$A$2:$A$28;0))

Автор - sboy
Дата добавления - 02.11.2016 в 17:03
_Boroda_ Дата: Среда, 02.11.2016, 17:05 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ВПР(E2;$A$2:$C$99;3;)

Вернее, так
Код
=ЕСЛИ(E2="";"";ВПР(E2;$A$2:$C$99;3;))

Еще выпадающий список городов Вам сделал в желтых ячейках

Добавлено
Переделал на автоизменяемый список (файл _2)
Имя "Таб1" смотрите, нажав Контрл F3.
Выпадающие списки смотрите Данные - проверка данных (желтая ячейка должна быть выделена при этом)
К сообщению приложен файл: 1745037_1.xlsx(13Kb) · 1745037_2.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Среда, 02.11.2016, 17:14
 
Ответить
СообщениеТак нужно?
Код
=ВПР(E2;$A$2:$C$99;3;)

Вернее, так
Код
=ЕСЛИ(E2="";"";ВПР(E2;$A$2:$C$99;3;))

Еще выпадающий список городов Вам сделал в желтых ячейках

Добавлено
Переделал на автоизменяемый список (файл _2)
Имя "Таб1" смотрите, нажав Контрл F3.
Выпадающие списки смотрите Данные - проверка данных (желтая ячейка должна быть выделена при этом)

Автор - _Boroda_
Дата добавления - 02.11.2016 в 17:05
AVI Дата: Среда, 02.11.2016, 17:08 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Как всегда вариант Бороды практичней)
 
Ответить
СообщениеКак всегда вариант Бороды практичней)

Автор - AVI
Дата добавления - 02.11.2016 в 17:08
Dgerri Дата: Среда, 02.11.2016, 18:13 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
hands
То, что доктор прописал...
Не даром говорят, одна голова хорошо, а форум МИР MS EXCEL куда круче!!!
Огромное спасибо всем, выручили как всегда!!!
 
Ответить
Сообщениеhands
То, что доктор прописал...
Не даром говорят, одна голова хорошо, а форум МИР MS EXCEL куда круче!!!
Огромное спасибо всем, выручили как всегда!!!

Автор - Dgerri
Дата добавления - 02.11.2016 в 18:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтянуть данные построчно (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!