Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование знаков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование знаков (Формулы/Formulas)
Суммирование знаков
bikosan Дата: Суббота, 05.11.2016, 13:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Прошу помощи, в формуле для подчета количества символом в заданном диапазоне. В этом случае столбец B.

Ни как не могу разобраться какую формулу подставить, выводит на не правильные ответы.
А B С
1 otp 410
2 oooottssOOOO 1380
3 ot 350
4 o 240
5 osO 325

Нужно что бы ответ выходил вот такой:
O-5
o-8
t-4
p-1
s-3


Сообщение отредактировал bikosan - Суббота, 05.11.2016, 13:21
 
Ответить
СообщениеПрошу помощи, в формуле для подчета количества символом в заданном диапазоне. В этом случае столбец B.

Ни как не могу разобраться какую формулу подставить, выводит на не правильные ответы.
А B С
1 otp 410
2 oooottssOOOO 1380
3 ot 350
4 o 240
5 osO 325

Нужно что бы ответ выходил вот такой:
O-5
o-8
t-4
p-1
s-3

Автор - bikosan
Дата добавления - 05.11.2016 в 13:09
Nic70y Дата: Суббота, 05.11.2016, 14:55 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3492
Репутация: 723 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(ДЛСТР(B1:B5)-ДЛСТР(ПОДСТАВИТЬ(B1:B5;"O";)))
и т.п.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ДЛСТР(B1:B5)-ДЛСТР(ПОДСТАВИТЬ(B1:B5;"O";)))
и т.п.

Автор - Nic70y
Дата добавления - 05.11.2016 в 14:55
bikosan Дата: Суббота, 05.11.2016, 15:11 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо огромное. А что бы прям писало сколько чего. О - 5, что добавить?
 
Ответить
СообщениеСпасибо огромное. А что бы прям писало сколько чего. О - 5, что добавить?

Автор - bikosan
Дата добавления - 05.11.2016 в 15:11
Nic70y Дата: Суббота, 05.11.2016, 15:47 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3492
Репутация: 723 ±
Замечаний: 0% ±

Excel 2013
Код
="O - "&СУММПРОИЗВ(ДЛСТР(B1:B5)-ДЛСТР(ПОДСТАВИТЬ(B1:B5;"O";)))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
="O - "&СУММПРОИЗВ(ДЛСТР(B1:B5)-ДЛСТР(ПОДСТАВИТЬ(B1:B5;"O";)))

Автор - Nic70y
Дата добавления - 05.11.2016 в 15:47
Michael_S Дата: Суббота, 05.11.2016, 15:58 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
Nic70y, ПОДСТАВИТЬ не различает "O" и "o" (если они из одного алфавита)


ЯД: 41001136675053
WM: R389613894253
 
Ответить
СообщениеNic70y, ПОДСТАВИТЬ не различает "O" и "o" (если они из одного алфавита)

Автор - Michael_S
Дата добавления - 05.11.2016 в 15:58
_Boroda_ Дата: Суббота, 05.11.2016, 16:08 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3949 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Код
=СУММПРОИЗВ(--СОВПАД(ПСТР(B$1:B$5;СТОЛБЕЦ($A:$Z);1);F1))

Код
=F1&-СУММПРОИЗВ(--СОВПАД(ПСТР(B$1:B$5;СТОЛБЕЦ($A:$Z);1);F1))

только для О
Код
="O-"&СУММПРОИЗВ(--СОВПАД(ПСТР(B$1:B$5;СТОЛБЕЦ($A:$Z);1);"O"))
К сообщению приложен файл: 6517617387.xlsx(8Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Код
=СУММПРОИЗВ(--СОВПАД(ПСТР(B$1:B$5;СТОЛБЕЦ($A:$Z);1);F1))

Код
=F1&-СУММПРОИЗВ(--СОВПАД(ПСТР(B$1:B$5;СТОЛБЕЦ($A:$Z);1);F1))

только для О
Код
="O-"&СУММПРОИЗВ(--СОВПАД(ПСТР(B$1:B$5;СТОЛБЕЦ($A:$Z);1);"O"))

Автор - _Boroda_
Дата добавления - 05.11.2016 в 16:08
bikosan Дата: Суббота, 05.11.2016, 16:08 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
хз, все работает вроде б
 
Ответить
Сообщениехз, все работает вроде б

Автор - bikosan
Дата добавления - 05.11.2016 в 16:08
Michael_S Дата: Суббота, 05.11.2016, 16:12 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
Код
=СЧЁТ(НАЙТИ(A7;ПСТР($B$1:$B$5;СТОЛБЕЦ($A$1:$Q$1);1)))
формула массива (см. файл)
К сообщению приложен файл: bikosan.xlsx(9Kb)


ЯД: 41001136675053
WM: R389613894253
 
Ответить
Сообщение
Код
=СЧЁТ(НАЙТИ(A7;ПСТР($B$1:$B$5;СТОЛБЕЦ($A$1:$Q$1);1)))
формула массива (см. файл)

Автор - Michael_S
Дата добавления - 05.11.2016 в 16:12
Nic70y Дата: Суббота, 05.11.2016, 16:41 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3492
Репутация: 723 ±
Замечаний: 0% ±

Excel 2013
не различает
как это?
К сообщению приложен файл: 4279742.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
не различает
как это?

Автор - Nic70y
Дата добавления - 05.11.2016 в 16:41
bikosan Дата: Суббота, 05.11.2016, 17:38 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем спасибо все считает как нужно.
 
Ответить
СообщениеВсем спасибо все считает как нужно.

Автор - bikosan
Дата добавления - 05.11.2016 в 17:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование знаков (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!