Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подставить необходимые значения, сравнивая 2 таблицы. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставить необходимые значения, сравнивая 2 таблицы. (Формулы/Formulas)
Подставить необходимые значения, сравнивая 2 таблицы.
AVI Дата: Вторник, 08.11.2016, 17:40 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Есть очередные две таблицы, которые нужно сравнить.
Красная и зеленая.
В третью таблицу выводятся следующие данные: год Иванова из красной - если он не равен нулю (или пустому) и не равен году Иванова из зеленой. В остальных случаях подставляется год Иванова из зеленой таблицы.
Я это решил, но решил опять же коряво. Боюсь, что в боевом файле, где строк может быть более 500 тысяч, все может виснуть.
Я просто уверен, что есть что-то намного проще, чем я нарубил.
Можете подсказать?
Да, кстати, и в красной, и в зеленой таблицах может быть только один Иванов, Петров и так далее.
К сообщению приложен файл: otbor.xlsx(10Kb)
 
Ответить
СообщениеДобрый день!
Есть очередные две таблицы, которые нужно сравнить.
Красная и зеленая.
В третью таблицу выводятся следующие данные: год Иванова из красной - если он не равен нулю (или пустому) и не равен году Иванова из зеленой. В остальных случаях подставляется год Иванова из зеленой таблицы.
Я это решил, но решил опять же коряво. Боюсь, что в боевом файле, где строк может быть более 500 тысяч, все может виснуть.
Я просто уверен, что есть что-то намного проще, чем я нарубил.
Можете подсказать?
Да, кстати, и в красной, и в зеленой таблицах может быть только один Иванов, Петров и так далее.

Автор - AVI
Дата добавления - 08.11.2016 в 17:40
Udik Дата: Вторник, 08.11.2016, 17:56 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1201
Репутация: 152 ±
Замечаний: 0% ±

Excel 2013
Так вроде можно
Код

=ЕСЛИ(ЕЧИСЛО(C4);C4*(C4<>G4)+G4*((G4=C4)+(C4=0));G4)
К сообщению приложен файл: 0t.xlsx(10Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Вторник, 08.11.2016, 18:00
 
Ответить
СообщениеТак вроде можно
Код

=ЕСЛИ(ЕЧИСЛО(C4);C4*(C4<>G4)+G4*((G4=C4)+(C4=0));G4)

Автор - Udik
Дата добавления - 08.11.2016 в 17:56
AVI Дата: Вторник, 08.11.2016, 18:00 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Udik, спасибо, но мне нужно отобрать именно по Иванову.
Да, моя ошибка, что не уточнил:
[p.s.]фамилии могут идти вразнобой, каких-то фамилий может не быть в зеленой таблице, а каких-то в красной


Сообщение отредактировал AVI - Вторник, 08.11.2016, 18:01
 
Ответить
СообщениеUdik, спасибо, но мне нужно отобрать именно по Иванову.
Да, моя ошибка, что не уточнил:
[p.s.]фамилии могут идти вразнобой, каких-то фамилий может не быть в зеленой таблице, а каких-то в красной

Автор - AVI
Дата добавления - 08.11.2016 в 18:00
Udik Дата: Вторник, 08.11.2016, 18:06 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1201
Репутация: 152 ±
Замечаний: 0% ±

Excel 2013
То есть вообще не то задание.
Где зырить фамилию для поиска?
Что делать когда нет искомой фамилии в 1 таблице?
Что делать когда нет фамилии во 2 ?
Что делать когда фамилии нет ни в одной?


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеТо есть вообще не то задание.
Где зырить фамилию для поиска?
Что делать когда нет искомой фамилии в 1 таблице?
Что делать когда нет фамилии во 2 ?
Что делать когда фамилии нет ни в одной?

Автор - Udik
Дата добавления - 08.11.2016 в 18:06
jakim Дата: Вторник, 08.11.2016, 18:21 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 676
Репутация: 171 ±
Замечаний: 0% ±

Может такой вариант подойдёт?

Код
=IFERROR(AGGREGATE(15;6;C$4:C$100/($B$4:$B$100=$J4)/(C$4:C$10<>"");1);(AGGREGATE(15;6;G$4:G$100/($F$4:$F$100=$J4);1)))
К сообщению приложен файл: 3903970.xlsx(10Kb)
 
Ответить
Сообщение
Может такой вариант подойдёт?

Код
=IFERROR(AGGREGATE(15;6;C$4:C$100/($B$4:$B$100=$J4)/(C$4:C$10<>"");1);(AGGREGATE(15;6;G$4:G$100/($F$4:$F$100=$J4);1)))

Автор - jakim
Дата добавления - 08.11.2016 в 18:21
AVI Дата: Вторник, 08.11.2016, 18:29 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Что делать когда фамилии нет ни в одной?

В столбец J ловятся фамилии из столбцов В и F. Поэтому не может быть ситуации, когда фамилии в столбце J нет ни в B ни в F.
Где зырить фамилию для поиска?

Фамилия для поиска берется из J.
Что делать когда нет искомой фамилии в 1 таблице?

В примере эта фамилия Собакин: год брать из зеленой таблицы
Что делать когда нет фамилии во 2 ?

В данном случае год берется из красной таблицы.
 
Ответить
Сообщение
Что делать когда фамилии нет ни в одной?

В столбец J ловятся фамилии из столбцов В и F. Поэтому не может быть ситуации, когда фамилии в столбце J нет ни в B ни в F.
Где зырить фамилию для поиска?

Фамилия для поиска берется из J.
Что делать когда нет искомой фамилии в 1 таблице?

В примере эта фамилия Собакин: год брать из зеленой таблицы
Что делать когда нет фамилии во 2 ?

В данном случае год берется из красной таблицы.

Автор - AVI
Дата добавления - 08.11.2016 в 18:29
Udik Дата: Вторник, 08.11.2016, 19:27 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1201
Репутация: 152 ±
Замечаний: 0% ±

Excel 2013
Ну тогда длиннохвост выходит
Код

=ЕСЛИ(ЕНД(ВПР(J4;$B$4:$B$10;1;0));ВПР(J4;$F$4:$G$10;2;0);ЕСЛИ(ЕНД(ВПР(J4;$F$4:$F$10;1;0));ВПР(J4;$B$4:$C$9;2;0);ЕСЛИ(ЕЧИСЛО(ВПР(J4;$B$4:$C$9;2;0))*(ВПР(J4;$B$4:$C$9;2;0)>0);ЕСЛИ(ВПР(J4;$B$4:$C$9;2;0)<>ВПР(J4;$F$4:$G$10;2;0);ВПР(J4;$B$4:$C$9;2;0);ВПР(J4;$F$4:$G$10;2;0));ВПР(J4;$F$4:$G$10;2;0))))
К сообщению приложен файл: 3552554.xlsx(10Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеНу тогда длиннохвост выходит
Код

=ЕСЛИ(ЕНД(ВПР(J4;$B$4:$B$10;1;0));ВПР(J4;$F$4:$G$10;2;0);ЕСЛИ(ЕНД(ВПР(J4;$F$4:$F$10;1;0));ВПР(J4;$B$4:$C$9;2;0);ЕСЛИ(ЕЧИСЛО(ВПР(J4;$B$4:$C$9;2;0))*(ВПР(J4;$B$4:$C$9;2;0)>0);ЕСЛИ(ВПР(J4;$B$4:$C$9;2;0)<>ВПР(J4;$F$4:$G$10;2;0);ВПР(J4;$B$4:$C$9;2;0);ВПР(J4;$F$4:$G$10;2;0));ВПР(J4;$F$4:$G$10;2;0))))

Автор - Udik
Дата добавления - 08.11.2016 в 19:27
_Boroda_ Дата: Вторник, 08.11.2016, 21:16 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А вот так не пойдет?
Код
=ЕСЛИОШИБКА(1/(1/ВПР(J4;B$4:D$9;2;));ВПР(J4;F$4:H$10;2;))

Чтобы избежать маловероятной, но возможной ошибки округления Excel, можно вот так
Код
=ЕСЛИОШИБКА(ОКРУГЛ(1/(1/ВПР(J4;B$4:D$9;2;));0);ВПР(J4;F$4:H$10;2;))

Кстати, вот здесь
год Иванова из красной - если он ... не равен году Иванова из зеленой
в случае равенства годов Вам не все равно, откуда тянуть год? Он же одинаковый.
К сообщению приложен файл: otbor_1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА вот так не пойдет?
Код
=ЕСЛИОШИБКА(1/(1/ВПР(J4;B$4:D$9;2;));ВПР(J4;F$4:H$10;2;))

Чтобы избежать маловероятной, но возможной ошибки округления Excel, можно вот так
Код
=ЕСЛИОШИБКА(ОКРУГЛ(1/(1/ВПР(J4;B$4:D$9;2;));0);ВПР(J4;F$4:H$10;2;))

Кстати, вот здесь
год Иванова из красной - если он ... не равен году Иванова из зеленой
в случае равенства годов Вам не все равно, откуда тянуть год? Он же одинаковый.

Автор - _Boroda_
Дата добавления - 08.11.2016 в 21:16
AVI Дата: Среда, 09.11.2016, 01:30 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
jakim, Udik, _Boroda_, Спасибо, ребята, все работает!

в случае равенства годов Вам не все равно, откуда тянуть год? Он же одинаковый.
Конечно все равно, я пытался понятней объяснить пример.
Спасибо за хитрое решение!
 
Ответить
Сообщениеjakim, Udik, _Boroda_, Спасибо, ребята, все работает!

в случае равенства годов Вам не все равно, откуда тянуть год? Он же одинаковый.
Конечно все равно, я пытался понятней объяснить пример.
Спасибо за хитрое решение!

Автор - AVI
Дата добавления - 09.11.2016 в 01:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставить необходимые значения, сравнивая 2 таблицы. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!