Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если ячейка содержит значение то вставить. Макрос - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если ячейка содержит значение то вставить. Макрос (Формулы/Formulas)
Если ячейка содержит значение то вставить. Макрос
byte32 Дата: Вторник, 08.11.2016, 23:29 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброй ночи. Я снова к любимому форуму. Друзья, научите решить задачу, пожалуйста.

Есть более 40 параметров в ячейках.
Необходим макрос, который делает нечто такое. Если в ячейке есть в любом месте слово бордюр то вставить Бордюр, если есть слово панно - вставить панно, и так далее. Таких параметров может быть до сорока. Поэтому формула не подходит.

Пример файла в аттаче.

Заранее искренне Вам благодарен
К сообщению приложен файл: excelwif.xlsx(8Kb)
 
Ответить
СообщениеДоброй ночи. Я снова к любимому форуму. Друзья, научите решить задачу, пожалуйста.

Есть более 40 параметров в ячейках.
Необходим макрос, который делает нечто такое. Если в ячейке есть в любом месте слово бордюр то вставить Бордюр, если есть слово панно - вставить панно, и так далее. Таких параметров может быть до сорока. Поэтому формула не подходит.

Пример файла в аттаче.

Заранее искренне Вам благодарен

Автор - byte32
Дата добавления - 08.11.2016 в 23:29
_Boroda_ Дата: Вторник, 08.11.2016, 23:42 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Поэтому формула не подходит

Почему? Составляете список своих слов и пишете формулу
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2:F$99;A2)/ДЛСТР(F$2:F$99);F$2:F$99);"")

Если точно знаете, сколько у Вас слов, то
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2:F$8;A2);F$2:F$8);"")

Или можно именованный диапазон использовать (Контрл F3)
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(Список;A2);Список);"")

В первой формуле список в строках 2-99 (можно меньше), во второй жестко в 2-8 (8 можно менять но не с запасом пустых), в третьей - неограниченно, но без фанатизма. Пустых ячеек в середине списка быть не должно
К сообщению приложен файл: excelwif_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Поэтому формула не подходит

Почему? Составляете список своих слов и пишете формулу
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2:F$99;A2)/ДЛСТР(F$2:F$99);F$2:F$99);"")

Если точно знаете, сколько у Вас слов, то
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2:F$8;A2);F$2:F$8);"")

Или можно именованный диапазон использовать (Контрл F3)
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(Список;A2);Список);"")

В первой формуле список в строках 2-99 (можно меньше), во второй жестко в 2-8 (8 можно менять но не с запасом пустых), в третьей - неограниченно, но без фанатизма. Пустых ячеек в середине списка быть не должно

Автор - _Boroda_
Дата добавления - 08.11.2016 в 23:42
byte32 Дата: Среда, 09.11.2016, 12:11 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А можно ещё? А как сделать так, если содержит карт. то вставить Картонка?


Сообщение отредактировал byte32 - Среда, 09.11.2016, 14:13
 
Ответить
СообщениеА можно ещё? А как сделать так, если содержит карт. то вставить Картонка?

Автор - byte32
Дата добавления - 09.11.2016 в 12:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если ячейка содержит значение то вставить. Макрос (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!