Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вывод дат начала и окончания в ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывод дат начала и окончания в ячейки (Формулы/Formulas)
вывод дат начала и окончания в ячейки
zaak88 Дата: Среда, 09.11.2016, 10:15 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Добрый день, коллеги!

Прошу помочь со следующим вопросом, необходимо вывести даты начала и окончания поставки в ячейки.

Спасибо!
К сообщению приложен файл: 6429563.xlsx(9Kb)
 
Ответить
СообщениеДобрый день, коллеги!

Прошу помочь со следующим вопросом, необходимо вывести даты начала и окончания поставки в ячейки.

Спасибо!

Автор - zaak88
Дата добавления - 09.11.2016 в 10:15
Nic70y Дата: Среда, 09.11.2016, 10:21 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3473
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Что, Где, Куда надо вынести?
и что такое 145,125?

А понял, щас, минутку

массивки:
Код
=МИН(ЕСЛИ(E3:AI3<>0;E$2:AI$2))
Код
=МАКС(ЕСЛИ(E3:AI3<>0;E$2:AI$2))
то?
К сообщению приложен файл: 9295550.xlsx(9Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Среда, 09.11.2016, 10:29
 
Ответить
СообщениеЧто, Где, Куда надо вынести?
и что такое 145,125?

А понял, щас, минутку

массивки:
Код
=МИН(ЕСЛИ(E3:AI3<>0;E$2:AI$2))
Код
=МАКС(ЕСЛИ(E3:AI3<>0;E$2:AI$2))
то?

Автор - Nic70y
Дата добавления - 09.11.2016 в 10:21
buchlotnik Дата: Среда, 09.11.2016, 10:22 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ПРОСМОТР(;E3:AI3;F2:AJ2)
Код
=ПРОСМОТР(;-1/E3:AI3/F3:AI3;F2:AJ2)
К сообщению приложен файл: 4409812.xlsx(9Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 09.11.2016, 10:24
 
Ответить
Сообщениетак нужно?
Код
=ПРОСМОТР(;E3:AI3;F2:AJ2)
Код
=ПРОСМОТР(;-1/E3:AI3/F3:AI3;F2:AJ2)

Автор - buchlotnik
Дата добавления - 09.11.2016 в 10:22
SLAVICK Дата: Среда, 09.11.2016, 10:26 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1834
Репутация: 613 ±
Замечаний: 0% ±

2007,2010,2013,2016
Формулы массива:
минимум:
Код
=ИНДЕКС(A2:AI2;;МИН(ЕСЛИ(E3:AI3>0;СТОЛБЕЦ(E3:AI3);9^9)))

Максимум:
Код
=ИНДЕКС(A2:AI2;;МАКС((E3:AI3>0)*СТОЛБЕЦ(E3:AI3)))

[offtop]
массивки:

так нужно?

Пошел спать - видимо еще не проснулся -что-то длинные формулы получились :( [/offtop]
К сообщению приложен файл: 6209105.xlsx(9Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеФормулы массива:
минимум:
Код
=ИНДЕКС(A2:AI2;;МИН(ЕСЛИ(E3:AI3>0;СТОЛБЕЦ(E3:AI3);9^9)))

Максимум:
Код
=ИНДЕКС(A2:AI2;;МАКС((E3:AI3>0)*СТОЛБЕЦ(E3:AI3)))

[offtop]
массивки:

так нужно?

Пошел спать - видимо еще не проснулся -что-то длинные формулы получились :( [/offtop]

Автор - SLAVICK
Дата добавления - 09.11.2016 в 10:26
_Boroda_ Дата: Среда, 09.11.2016, 10:31 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Формулы массива. Вводятся одновременным нажатием Контрл Шифт Ентер
Код
=МИН(ЕСЛИ(E3:AI3<>0;E2:AI2))

Код
=МАКС((E3:AI3<>0)*E2:AI2)


[p.s.]Первая и/или последняя даты ведь тоже могут быть ненулевыми?
К сообщению приложен файл: 6429563_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФормулы массива. Вводятся одновременным нажатием Контрл Шифт Ентер
Код
=МИН(ЕСЛИ(E3:AI3<>0;E2:AI2))

Код
=МАКС((E3:AI3<>0)*E2:AI2)


[p.s.]Первая и/или последняя даты ведь тоже могут быть ненулевыми?

Автор - _Boroda_
Дата добавления - 09.11.2016 в 10:31
zaak88 Дата: Среда, 09.11.2016, 12:08 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Nic70y, buchlotnik, SLAVICK, _Boroda_, спасибо большое, очень помогли, все решения очень интересные. Воспользовался версией _Boroda_, .
 
Ответить
СообщениеNic70y, buchlotnik, SLAVICK, _Boroda_, спасибо большое, очень помогли, все решения очень интересные. Воспользовался версией _Boroda_, .

Автор - zaak88
Дата добавления - 09.11.2016 в 12:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывод дат начала и окончания в ячейки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!