Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если (несколько вариантов значений) то вставить Один вариан - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если (несколько вариантов значений) то вставить Один вариан (Формулы/Formulas)
Если (несколько вариантов значений) то вставить Один вариан
byte32 Дата: Среда, 09.11.2016, 18:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Я уже тут всем надоел( Простите. Мне уже помогали. но, к сожалению я не грамотно поставил вопрос
Пожалуйста. Как сделать?

Идентично формуле Если То.

Если ячейчка содержит одно из указанных значений (которые я ввожу вручную) то вставить в соседнюю значение. Правда там данных гораздо больше чем 5. Около 40 может быть

Во вложении пример
К сообщению приложен файл: excelworld.xlsx(8Kb)
 
Ответить
СообщениеЯ уже тут всем надоел( Простите. Мне уже помогали. но, к сожалению я не грамотно поставил вопрос
Пожалуйста. Как сделать?

Идентично формуле Если То.

Если ячейчка содержит одно из указанных значений (которые я ввожу вручную) то вставить в соседнюю значение. Правда там данных гораздо больше чем 5. Около 40 может быть

Во вложении пример

Автор - byte32
Дата добавления - 09.11.2016 в 18:54
Karataev Дата: Среда, 09.11.2016, 19:29 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
Сделан доплист, на него записывайте искомые данные. Для каждого цвета сделана умная таблица, чтобы формула видела конец таблицы.
Используются имена: вкладка "Формулы" - Диспетчер имен.
И на листе1 в столбце "B" вставлены формулы.
Если появится новый цвет, то на доплисте нужно сделать умную таблицу для этого цвета. Нужно сделать имя. И нужно изменить формулу в столбце "B".
К сообщению приложен файл: 0818944.xlsx(12Kb)




Сообщение отредактировал Karataev - Среда, 09.11.2016, 19:32
 
Ответить
СообщениеСделан доплист, на него записывайте искомые данные. Для каждого цвета сделана умная таблица, чтобы формула видела конец таблицы.
Используются имена: вкладка "Формулы" - Диспетчер имен.
И на листе1 в столбце "B" вставлены формулы.
Если появится новый цвет, то на доплисте нужно сделать умную таблицу для этого цвета. Нужно сделать имя. И нужно изменить формулу в столбце "B".

Автор - Karataev
Дата добавления - 09.11.2016 в 19:29
Udik Дата: Среда, 09.11.2016, 19:32 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 152 ±
Замечаний: 0% ±

Excel 2013
Не знаю можно ли такое формулами провернуть. Получается нужно выделить каждое слово в ячейке столбца А, потом каждое слово проверить на наличие в строке из диапазона вспомогательной таблички и, если будет совпадение - выдернуть соответствующее слово. Макросами еще можно, а формулами как-то плохо представляю.


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Среда, 09.11.2016, 19:32
 
Ответить
СообщениеНе знаю можно ли такое формулами провернуть. Получается нужно выделить каждое слово в ячейке столбца А, потом каждое слово проверить на наличие в строке из диапазона вспомогательной таблички и, если будет совпадение - выдернуть соответствующее слово. Макросами еще можно, а формулами как-то плохо представляю.

Автор - Udik
Дата добавления - 09.11.2016 в 19:32
byte32 Дата: Среда, 09.11.2016, 19:45 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Ого!. Уважаемый Karataev, я вообще не могу понять как Вы сделали. И добавть значения(((

Я понял. Вы сделали через диспетчер Имён)) Буду разбираться.


Сообщение отредактировал byte32 - Среда, 09.11.2016, 20:29
 
Ответить
СообщениеОго!. Уважаемый Karataev, я вообще не могу понять как Вы сделали. И добавть значения(((

Я понял. Вы сделали через диспетчер Имён)) Буду разбираться.

Автор - byte32
Дата добавления - 09.11.2016 в 19:45
Karataev Дата: Среда, 09.11.2016, 20:43 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
Другой вариант. Здесь используется доплист. На нем умная таблица. Умная таблица нужна, чтобы формула видела конец таблицы. В столбец "искомый" записывайте текст, который может быть в тексте, в столбец "вставка" записывайте текст, который формула должна вставить.
Имена в этом способе не используются.
На листе 1 используется формула массива (вставляется Ctrl+Shift+Enter). Формула для "B2":
Код
=ИНДЕКС(Таблица1[вставка];ПОИСКПОЗ(ИСТИНА;ЕСЛИ(ПОИСК(Таблица1[искомый];A2);ИСТИНА;);0);1)
К сообщению приложен файл: excelworld-.xlsx(11Kb)


 
Ответить
СообщениеДругой вариант. Здесь используется доплист. На нем умная таблица. Умная таблица нужна, чтобы формула видела конец таблицы. В столбец "искомый" записывайте текст, который может быть в тексте, в столбец "вставка" записывайте текст, который формула должна вставить.
Имена в этом способе не используются.
На листе 1 используется формула массива (вставляется Ctrl+Shift+Enter). Формула для "B2":
Код
=ИНДЕКС(Таблица1[вставка];ПОИСКПОЗ(ИСТИНА;ЕСЛИ(ПОИСК(Таблица1[искомый];A2);ИСТИНА;);0);1)

Автор - Karataev
Дата добавления - 09.11.2016 в 20:43
_Boroda_ Дата: Среда, 09.11.2016, 23:22 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Относительно прошлой темы http://www.excelworld.ru/forum/2-31107-200847-16-1478637735 практически ничего не поменялось. Просто добавили еще один столбец в список замен
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(G$2:G$99;A2)/ДЛСТР(G$2:G$99);H$2:H$99);"")

Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(G$2:G$11;A2);H$2:H$11);"")

Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(спис1;A2);Спис2);"")

И добавил еще формулу не с двумя именованными диапазонами, а с одним
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(ИНДЕКС(Спис12;;1);A2);ИНДЕКС(Спис12;;2));"")
К сообщению приложен файл: excelwif_2.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОтносительно прошлой темы http://www.excelworld.ru/forum/2-31107-200847-16-1478637735 практически ничего не поменялось. Просто добавили еще один столбец в список замен
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(G$2:G$99;A2)/ДЛСТР(G$2:G$99);H$2:H$99);"")

Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(G$2:G$11;A2);H$2:H$11);"")

Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(спис1;A2);Спис2);"")

И добавил еще формулу не с двумя именованными диапазонами, а с одним
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(ИНДЕКС(Спис12;;1);A2);ИНДЕКС(Спис12;;2));"")

Автор - _Boroda_
Дата добавления - 09.11.2016 в 23:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если (несколько вариантов значений) то вставить Один вариан (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!