Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула,которая берет предыдущее значение если оно больше - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула,которая берет предыдущее значение если оно больше (Формулы/Formulas)
Формула,которая берет предыдущее значение если оно больше
SoloNight Дата: Четверг, 17.11.2016, 16:41 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Ребят,добрый день. Помогите с поиском формулы для ячейки.
У меня есть четыре столбца. Название - Приход (Цена) - Процент и в четвертом столбце Формула - формула которую ищу.
Сама суть : Цены в столбце Приход расположены по порядку. Этот столбец (Приход) умножается на столбец Процент(который равен 0.6). И мне нужно чтоб в столбце Формула отображалось равенство умножения Приход на Процент. Но если равенство которое мы получаем больше предыдущего чем на 10 (можно изменять) то отображалось бы предыдущее значение столбца что выше.
Примерно так:
Приход Процент(0,6) Формула
1р.......... 0,6.............. 0,6
2р ..........1,2 ..............1,2
78р ........46,8............. 1,2 (вот здесь будет значение 1,2 ,т.к. 46,8 больше чем на 10 предыдущего значения (1,2) ,поэтому берется предыдущее значение,которое равно 1,2 соответственно)
4р........... 2,4.............. 2,4
5р........... 3,0.............. 3,0

Надеюсь получилось понятно обьяснить ^_^ Сильно тапками не бросайте,пожалуйста,я в exel только 3 день.
Сделал пример ,там может более наглядно.
Буду очень признателен за помощь!!!

Exel 2003 английская версия
К сообщению приложен файл: Primer-1-.xls(21Kb)


Сообщение отредактировал SoloNight - Четверг, 17.11.2016, 16:48
 
Ответить
СообщениеРебят,добрый день. Помогите с поиском формулы для ячейки.
У меня есть четыре столбца. Название - Приход (Цена) - Процент и в четвертом столбце Формула - формула которую ищу.
Сама суть : Цены в столбце Приход расположены по порядку. Этот столбец (Приход) умножается на столбец Процент(который равен 0.6). И мне нужно чтоб в столбце Формула отображалось равенство умножения Приход на Процент. Но если равенство которое мы получаем больше предыдущего чем на 10 (можно изменять) то отображалось бы предыдущее значение столбца что выше.
Примерно так:
Приход Процент(0,6) Формула
1р.......... 0,6.............. 0,6
2р ..........1,2 ..............1,2
78р ........46,8............. 1,2 (вот здесь будет значение 1,2 ,т.к. 46,8 больше чем на 10 предыдущего значения (1,2) ,поэтому берется предыдущее значение,которое равно 1,2 соответственно)
4р........... 2,4.............. 2,4
5р........... 3,0.............. 3,0

Надеюсь получилось понятно обьяснить ^_^ Сильно тапками не бросайте,пожалуйста,я в exel только 3 день.
Сделал пример ,там может более наглядно.
Буду очень признателен за помощь!!!

Exel 2003 английская версия

Автор - SoloNight
Дата добавления - 17.11.2016 в 16:41
_Boroda_ Дата: Четверг, 17.11.2016, 16:52 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(B2*0,6>E1+10;E1;B2*0,6)
К сообщению приложен файл: Primer-10-1.xls(30Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(B2*0,6>E1+10;E1;B2*0,6)

Автор - _Boroda_
Дата добавления - 17.11.2016 в 16:52
SoloNight Дата: Четверг, 17.11.2016, 17:02 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Boroda,Да!!! Спасибо огромное!!! Думал не получится объяснить и меня не поймут.Спасибо за оперативность!!!! hands hands hands


Сообщение отредактировал SoloNight - Четверг, 17.11.2016, 17:07
 
Ответить
СообщениеBoroda,Да!!! Спасибо огромное!!! Думал не получится объяснить и меня не поймут.Спасибо за оперативность!!!! hands hands hands

Автор - SoloNight
Дата добавления - 17.11.2016 в 17:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула,которая берет предыдущее значение если оно больше (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!