Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммесли (суммпроизв) с функцией ИЛИ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммесли (суммпроизв) с функцией ИЛИ (Формулы/Formulas)
Суммесли (суммпроизв) с функцией ИЛИ
AVI Дата: Пятница, 18.11.2016, 12:35 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
В столбце М вбита формула
Код
СУММЕСЛИМН($F$1:$F$99;$B$1:$B$99;"Начисление";$C$1:$C$99;K5)

Как формулу заставить искать в диапазоне
Код
$B$1:$B$99

не только "начисление", но и "перерасчет".
В целом мне не принципиальна СУММЕСЛИМН, главное , что бы работало.
У самого никак не получается.
К сообщению приложен файл: sum.xlsx(12Kb)
 
Ответить
СообщениеДобрый день!
В столбце М вбита формула
Код
СУММЕСЛИМН($F$1:$F$99;$B$1:$B$99;"Начисление";$C$1:$C$99;K5)

Как формулу заставить искать в диапазоне
Код
$B$1:$B$99

не только "начисление", но и "перерасчет".
В целом мне не принципиальна СУММЕСЛИМН, главное , что бы работало.
У самого никак не получается.

Автор - AVI
Дата добавления - 18.11.2016 в 12:35
pabchek Дата: Пятница, 18.11.2016, 12:40 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Если в лоб
Код
=СУММЕСЛИМН($F$1:$F$99;$B$1:$B$99;"Начисление";$C$1:$C$99;K5)+СУММЕСЛИМН($F$1:$F$99;$B$1:$B$99;"Перерасчет";$C$1:$C$99;K5)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 18.11.2016, 12:41
 
Ответить
СообщениеЗдравствуйте!
Если в лоб
Код
=СУММЕСЛИМН($F$1:$F$99;$B$1:$B$99;"Начисление";$C$1:$C$99;K5)+СУММЕСЛИМН($F$1:$F$99;$B$1:$B$99;"Перерасчет";$C$1:$C$99;K5)

Автор - pabchek
Дата добавления - 18.11.2016 в 12:40
Karataev Дата: Пятница, 18.11.2016, 12:41 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
Формула для "N5":
Код
=СУММЕСЛИМН($F$1:$F$99;$B$1:$B$99;"Начисление";$C$1:$C$99;K5)+СУММЕСЛИМН($F$1:$F$99;$B$1:$B$99;"Перерасчет";$C$1:$C$99;K5)
К сообщению приложен файл: 5941962.xlsx(13Kb)


 
Ответить
СообщениеФормула для "N5":
Код
=СУММЕСЛИМН($F$1:$F$99;$B$1:$B$99;"Начисление";$C$1:$C$99;K5)+СУММЕСЛИМН($F$1:$F$99;$B$1:$B$99;"Перерасчет";$C$1:$C$99;K5)

Автор - Karataev
Дата добавления - 18.11.2016 в 12:41
pabchek Дата: Пятница, 18.11.2016, 12:42 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Karataev, booze


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеKarataev, booze

Автор - pabchek
Дата добавления - 18.11.2016 в 12:42
AVI Дата: Пятница, 18.11.2016, 12:59 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Спасибо)) Топором)
А как, все же, это сделать одной формулой?
 
Ответить
СообщениеСпасибо)) Топором)
А как, все же, это сделать одной формулой?

Автор - AVI
Дата добавления - 18.11.2016 в 12:59
_Boroda_ Дата: Пятница, 18.11.2016, 13:13 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(СУММЕСЛИМН(F$1:F$99;B$1:B$99;{"Нач*";"Пер*"};C$1:C$99;K5))
К сообщению приложен файл: sum-1-1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(СУММЕСЛИМН(F$1:F$99;B$1:B$99;{"Нач*";"Пер*"};C$1:C$99;K5))

Автор - _Boroda_
Дата добавления - 18.11.2016 в 13:13
Karataev Дата: Пятница, 18.11.2016, 13:22 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
А как, все же, это сделать одной формулой?

В посте 3 одна формула. Вы наверное неточно выразились.


 
Ответить
Сообщение
А как, все же, это сделать одной формулой?

В посте 3 одна формула. Вы наверное неточно выразились.

Автор - Karataev
Дата добавления - 18.11.2016 в 13:22
AVI Дата: Пятница, 18.11.2016, 13:44 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Вы наверное неточно выразились.

Да, я имел ввиду одной функцией можно обойтись.
Так нужно?

Я думал, что можно внутри функции сделать. Что-то вроде впихнуть ИЛИ с СУММЕСЛИМН.
Да, работает! Спасибо!
 
Ответить
Сообщение
Вы наверное неточно выразились.

Да, я имел ввиду одной функцией можно обойтись.
Так нужно?

Я думал, что можно внутри функции сделать. Что-то вроде впихнуть ИЛИ с СУММЕСЛИМН.
Да, работает! Спасибо!

Автор - AVI
Дата добавления - 18.11.2016 в 13:44
Karataev Дата: Пятница, 18.11.2016, 14:01 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
В СУММЕСЛИМН между параметрами мысленно нужно ставить "И", а в файле одновременно не может быть в строке и Начисление и Перерасчет.


 
Ответить
СообщениеВ СУММЕСЛИМН между параметрами мысленно нужно ставить "И", а в файле одновременно не может быть в строке и Начисление и Перерасчет.

Автор - Karataev
Дата добавления - 18.11.2016 в 14:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммесли (суммпроизв) с функцией ИЛИ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!