Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод в таблице в зависимости от значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод в таблице в зависимости от значений (Формулы/Formulas)
Вывод в таблице в зависимости от значений
Raven2009 Дата: Пятница, 18.11.2016, 14:51 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 51
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.

Подскажите пожалуйста. Имеется таблица на листе Statistics. Над таблицей есть 2 ячейки Месяц и Год, которые берут данные с листа ММГГ в виде подстановочного списка.

Есть также 2 листа INB_STAT и RAZM_STAT, оттуда задуман источник данных, в таблицах на них есть такие же Месяц, Год и Логины сотрудников.

Подскажите пожалуйста правильный ВПР или формулу наподобие, чтобы в зависимости от выбранных месяца, года в основную таблицу в колонку Receiving подставлялись цифры изпоследней колонки таблицы с листа INB_STAT?

Заранее спасибо))
К сообщению приложен файл: 5137851.xlsx(59Kb)
 
Ответить
СообщениеДобрый день.

Подскажите пожалуйста. Имеется таблица на листе Statistics. Над таблицей есть 2 ячейки Месяц и Год, которые берут данные с листа ММГГ в виде подстановочного списка.

Есть также 2 листа INB_STAT и RAZM_STAT, оттуда задуман источник данных, в таблицах на них есть такие же Месяц, Год и Логины сотрудников.

Подскажите пожалуйста правильный ВПР или формулу наподобие, чтобы в зависимости от выбранных месяца, года в основную таблицу в колонку Receiving подставлялись цифры изпоследней колонки таблицы с листа INB_STAT?

Заранее спасибо))

Автор - Raven2009
Дата добавления - 18.11.2016 в 14:51
AVI Дата: Пятница, 18.11.2016, 18:25 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Проверяйте
Формула массива (вводится одновременным нажатием сочетания клавиш Ctrl + Shift + Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица_Total_Activity.accdb;ПОИСКПОЗ($E$2&$E$3&@Логин];INB_STAT!$A$2:$A$426&INB_STAT!$B$2:$B$426&INB_STAT!$C$2:$C$426;);4);"")
К сообщению приложен файл: 2695011.xlsx(62Kb)


Сообщение отредактировал AVI - Пятница, 18.11.2016, 18:27
 
Ответить
СообщениеПроверяйте
Формула массива (вводится одновременным нажатием сочетания клавиш Ctrl + Shift + Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица_Total_Activity.accdb;ПОИСКПОЗ($E$2&$E$3&@Логин];INB_STAT!$A$2:$A$426&INB_STAT!$B$2:$B$426&INB_STAT!$C$2:$C$426;);4);"")

Автор - AVI
Дата добавления - 18.11.2016 в 18:25
_Boroda_ Дата: Пятница, 18.11.2016, 21:25 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант обычной формулой
Код
=СУММЕСЛИМН(Таблица_Total_Activity.accdb[Принято линий];Таблица_Total_Activity.accdb[Месяц];E$2;Таблица_Total_Activity.accdb[Год];E$3;Таблица_Total_Activity.accdb[Логин];[@Логин])
К сообщению приложен файл: 5137851_1.xlsx(63Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант обычной формулой
Код
=СУММЕСЛИМН(Таблица_Total_Activity.accdb[Принято линий];Таблица_Total_Activity.accdb[Месяц];E$2;Таблица_Total_Activity.accdb[Год];E$3;Таблица_Total_Activity.accdb[Логин];[@Логин])

Автор - _Boroda_
Дата добавления - 18.11.2016 в 21:25
Raven2009 Дата: Суббота, 19.11.2016, 09:55 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 51
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо вам большое))) попробую оба способа.))
 
Ответить
СообщениеСпасибо вам большое))) попробую оба способа.))

Автор - Raven2009
Дата добавления - 19.11.2016 в 09:55
krosav4ig Дата: Вторник, 22.11.2016, 01:14 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1334
Репутация: 533 ±
Замечаний: 0% ±

Excel 2007, 2013
До кучи
SQL запрос с параметрами (через MSQuery)
К сообщению приложен файл: 5137851-2.xlsx(36Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Вторник, 22.11.2016, 01:15
 
Ответить
СообщениеДо кучи
SQL запрос с параметрами (через MSQuery)

Автор - krosav4ig
Дата добавления - 22.11.2016 в 01:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод в таблице в зависимости от значений (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!