Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/схема округления - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » схема округления (Формулы/Formulas)
схема округления
tov-stalyn Дата: Суббота, 19.11.2016, 13:08 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем добрый день!
Мне надо доработать бланк заказа расходки (см. вложение).
Работаем только со столбцом G на первой вкладке. В нем должно быть значение, которое удовлетворяет нескольким условиям:
1. нужно отобрать только те значения из F, которые больше 0.
2. при выполнении условия (1) нужно найти соответствующие значения из столбца D, и округлить их по принципу, который указан на второй вкладке и добавить уже округленный вариант в G. Например, строка 22, число в F22 больше 0, следовательно, нам в G22 надо указать число 22 из D22, но по схеме округляем до десяти, значит в G22 надо указать округленное в большую сторону число 30.

Такое возможно?
К сообщению приложен файл: __.xls(36Kb)


Сообщение отредактировал tov-stalyn - Суббота, 19.11.2016, 13:08
 
Ответить
СообщениеВсем добрый день!
Мне надо доработать бланк заказа расходки (см. вложение).
Работаем только со столбцом G на первой вкладке. В нем должно быть значение, которое удовлетворяет нескольким условиям:
1. нужно отобрать только те значения из F, которые больше 0.
2. при выполнении условия (1) нужно найти соответствующие значения из столбца D, и округлить их по принципу, который указан на второй вкладке и добавить уже округленный вариант в G. Например, строка 22, число в F22 больше 0, следовательно, нам в G22 надо указать число 22 из D22, но по схеме округляем до десяти, значит в G22 надо указать округленное в большую сторону число 30.

Такое возможно?

Автор - tov-stalyn
Дата добавления - 19.11.2016 в 13:08
Pelena Дата: Суббота, 19.11.2016, 13:14 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Если правильно поняла
Код
=ЕСЛИОШИБКА(ЕСЛИ(F2>0;ОКРВВЕРХ(D2;ВПР(B2;'Схема округления'!$B$3:$D$37;3;0));"");D2)
К сообщению приложен файл: 0634919.xls(40Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если правильно поняла
Код
=ЕСЛИОШИБКА(ЕСЛИ(F2>0;ОКРВВЕРХ(D2;ВПР(B2;'Схема округления'!$B$3:$D$37;3;0));"");D2)

Автор - Pelena
Дата добавления - 19.11.2016 в 13:14
Karataev Дата: Суббота, 19.11.2016, 13:27 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
Формула для "G2":
Код
=ЕСЛИ(F2>0;ЕСЛИ(ВПР(B2;'Схема округления'!$B:$D;3;0)="нет";D2;ОКРВВЕРХ.МАТ(D2;ВПР(B2;'Схема округления'!$B:$D;3;0)));"")

Формулы вставлены в G2:G22, дальше сами скопируйте до нужной строки.
К сообщению приложен файл: 0247802.xls(40Kb)


 
Ответить
СообщениеФормула для "G2":
Код
=ЕСЛИ(F2>0;ЕСЛИ(ВПР(B2;'Схема округления'!$B:$D;3;0)="нет";D2;ОКРВВЕРХ.МАТ(D2;ВПР(B2;'Схема округления'!$B:$D;3;0)));"")

Формулы вставлены в G2:G22, дальше сами скопируйте до нужной строки.

Автор - Karataev
Дата добавления - 19.11.2016 в 13:27
tov-stalyn Дата: Суббота, 19.11.2016, 13:38 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, Karataev, спасибо!!!
 
Ответить
СообщениеPelena, Karataev, спасибо!!!

Автор - tov-stalyn
Дата добавления - 19.11.2016 в 13:38
AlexM Дата: Суббота, 19.11.2016, 14:10 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3048
Репутация: 739 ±
Замечаний: 0% ±

Без функции ЕСЛИОШИБКА(), работает в Excel2003
Код
=ЕСЛИ(F2>0;ОКРВВЕРХ(D2;ТЕКСТ(ВПР(B2;'Схема округления'!$B$3:$D$37;3;);"0;;;\1"));"")
или
Код
=ЕСЛИ(F2>0;ОКРВВЕРХ(D2;МАКС(1;Ч(ВПР(B2;'Схема округления'!$B$3:$D$37;3;))));"")


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Суббота, 19.11.2016, 18:15
 
Ответить
СообщениеБез функции ЕСЛИОШИБКА(), работает в Excel2003
Код
=ЕСЛИ(F2>0;ОКРВВЕРХ(D2;ТЕКСТ(ВПР(B2;'Схема округления'!$B$3:$D$37;3;);"0;;;\1"));"")
или
Код
=ЕСЛИ(F2>0;ОКРВВЕРХ(D2;МАКС(1;Ч(ВПР(B2;'Схема округления'!$B$3:$D$37;3;))));"")

Автор - AlexM
Дата добавления - 19.11.2016 в 14:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » схема округления (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!