Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения по строкам и нескольким столбцам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по строкам и нескольким столбцам (Формулы/Formulas)
Поиск значения по строкам и нескольким столбцам
katy_1985 Дата: Пятница, 25.11.2016, 13:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Коллеги, добрый день. Помогите с необходимой формулой. Задание по вложении.
К сообщению приложен файл: 3682306.xlsx(73Kb)
 
Ответить
СообщениеКоллеги, добрый день. Помогите с необходимой формулой. Задание по вложении.

Автор - katy_1985
Дата добавления - 25.11.2016 в 13:33
buchlotnik Дата: Пятница, 25.11.2016, 13:45 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Здравствуйте, коллега.

Зачем же формулами одного вида - можно сразу ОДНОЙ формулой массива
Код
=ИНДЕКС(C4:Z13;ПОИСКПОЗ(A18:A22;A4:A13;0);ПОИСКПОЗ(B18:B22;C2:Z2;0))
К сообщению приложен файл: 0390212.xlsx(68Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеЗдравствуйте, коллега.

Зачем же формулами одного вида - можно сразу ОДНОЙ формулой массива
Код
=ИНДЕКС(C4:Z13;ПОИСКПОЗ(A18:A22;A4:A13;0);ПОИСКПОЗ(B18:B22;C2:Z2;0))

Автор - buchlotnik
Дата добавления - 25.11.2016 в 13:45
Manyasha Дата: Пятница, 25.11.2016, 13:53 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1582
Репутация: 659 ±
Замечаний: 0% ±

Excel 2007, 2010
Здравствуйте, еще вариант:
Код
=СУММПРОИЗВ($C$4:$Z$13*($A$4:$A$13=A18)*($C$2:$Z$2=B18))

или как у Михаила, но не массивная
Код
=ИНДЕКС($C$4:$Z$13;ПОИСКПОЗ(A18;$A$4:$A$13;);ПОИСКПОЗ(B18;$C$2:$Z$2;))
К сообщению приложен файл: 3682306-1.xlsx(73Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеЗдравствуйте, еще вариант:
Код
=СУММПРОИЗВ($C$4:$Z$13*($A$4:$A$13=A18)*($C$2:$Z$2=B18))

или как у Михаила, но не массивная
Код
=ИНДЕКС($C$4:$Z$13;ПОИСКПОЗ(A18;$A$4:$A$13;);ПОИСКПОЗ(B18;$C$2:$Z$2;))

Автор - Manyasha
Дата добавления - 25.11.2016 в 13:53
jakim Дата: Пятница, 25.11.2016, 16:03 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 676
Репутация: 171 ±
Замечаний: 0% ±

Ещё одна формула

Код
=MAX(INDEX($C$4:$Z$13*(A$4:A$13=A18)*(C$2:Z$2=B18)*(C$3:Z$3=C$17);0))
 
Ответить
Сообщение
Ещё одна формула

Код
=MAX(INDEX($C$4:$Z$13*(A$4:A$13=A18)*(C$2:Z$2=B18)*(C$3:Z$3=C$17);0))

Автор - jakim
Дата добавления - 25.11.2016 в 16:03
katy_1985 Дата: Пятница, 25.11.2016, 16:18 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Коллеги, спасибо вам огромное!
 
Ответить
СообщениеКоллеги, спасибо вам огромное!

Автор - katy_1985
Дата добавления - 25.11.2016 в 16:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по строкам и нескольким столбцам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!