Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/определение номера строки относительно заданной позиции - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » определение номера строки относительно заданной позиции (Формулы/Formulas)
определение номера строки относительно заданной позиции
Ghosto Дата: Среда, 30.11.2016, 18:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
есть 2 таблицы. одна со всеми субъектами рф - постоянная, а другая не со всеми - динамическая (лист 1).
вытащить данные по отдельно взятым субъектам - не проблема.
как вытащить данные по округам (из желтого столбца) и вставить в ячейки с красной заливкой?
я понимаю, что можно просто среднее вычислить, но бывают разные случаи.

функциями ИНДЕКС и ПОИСКПОЗ я нахожу название округа, а как спуститься вниз до первого "Всего по округу" начиная от заданного федерального округа?
отсчитать фиксированное количество строк не вариант - количество субъектов в динамической таблице может меняться, как и само количество округов.

P.S. ранее тут мне уже помогали с динамическим диапазоном суммирования, как раз через ИНДЕКС и ПОИСКПОЗ, но там фиксированные начала диапазонов, а тут мне надо искать по всему массиву.
К сообщению приложен файл: 3315832.xlsx(20Kb)
 
Ответить
Сообщениеесть 2 таблицы. одна со всеми субъектами рф - постоянная, а другая не со всеми - динамическая (лист 1).
вытащить данные по отдельно взятым субъектам - не проблема.
как вытащить данные по округам (из желтого столбца) и вставить в ячейки с красной заливкой?
я понимаю, что можно просто среднее вычислить, но бывают разные случаи.

функциями ИНДЕКС и ПОИСКПОЗ я нахожу название округа, а как спуститься вниз до первого "Всего по округу" начиная от заданного федерального округа?
отсчитать фиксированное количество строк не вариант - количество субъектов в динамической таблице может меняться, как и само количество округов.

P.S. ранее тут мне уже помогали с динамическим диапазоном суммирования, как раз через ИНДЕКС и ПОИСКПОЗ, но там фиксированные начала диапазонов, а тут мне надо искать по всему массиву.

Автор - Ghosto
Дата добавления - 30.11.2016 в 18:02
buchlotnik Дата: Среда, 30.11.2016, 18:19 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
И вам здрасьте
Код
=ИНДЕКС(ИНДЕКС(Динамическая!D:D;ПОИСКПОЗ(A4;Динамическая!A:A;0)):Динамическая!$D$75;ПОИСКПОЗ("всего по округу";ИНДЕКС(Динамическая!A:A;ПОИСКПОЗ(A4;Динамическая!A:A;0)):Динамическая!$A$75;0))
К сообщению приложен файл: 0390737.xlsx(20Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 30.11.2016, 19:20
 
Ответить
СообщениеИ вам здрасьте
Код
=ИНДЕКС(ИНДЕКС(Динамическая!D:D;ПОИСКПОЗ(A4;Динамическая!A:A;0)):Динамическая!$D$75;ПОИСКПОЗ("всего по округу";ИНДЕКС(Динамическая!A:A;ПОИСКПОЗ(A4;Динамическая!A:A;0)):Динамическая!$A$75;0))

Автор - buchlotnik
Дата добавления - 30.11.2016 в 18:19
Udik Дата: Среда, 30.11.2016, 18:37 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1208
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
Почти такая же, только со СМЕЩ
Код

=ИНДЕКС(Динамическая!$A$1:$D$100;ПОИСКПОЗ("Всего по округу";СМЕЩ(Динамическая!$A$1;ПОИСКПОЗ(A4;Динамическая!$A$1:$A$100;0);0;50);0)+ПОИСКПОЗ(A4;Динамическая!$A$1:$A$100;0);4)
К сообщению приложен файл: 4926982.xlsx(20Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеПочти такая же, только со СМЕЩ
Код

=ИНДЕКС(Динамическая!$A$1:$D$100;ПОИСКПОЗ("Всего по округу";СМЕЩ(Динамическая!$A$1;ПОИСКПОЗ(A4;Динамическая!$A$1:$A$100;0);0;50);0)+ПОИСКПОЗ(A4;Динамическая!$A$1:$A$100;0);4)

Автор - Udik
Дата добавления - 30.11.2016 в 18:37
Ghosto Дата: Среда, 30.11.2016, 19:23 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, и Udik, спасибо вам огромное!
то что нужно)
я сидел и думал как вкрутить этот СМЕЩ, но опыта катастрофически не хватает.

ещё раз спасибо!
 
Ответить
Сообщениеbuchlotnik, и Udik, спасибо вам огромное!
то что нужно)
я сидел и думал как вкрутить этот СМЕЩ, но опыта катастрофически не хватает.

ещё раз спасибо!

Автор - Ghosto
Дата добавления - 30.11.2016 в 19:23
AlexM Дата: Четверг, 01.12.2016, 11:15 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3049
Репутация: 739 ±
Замечаний: 0% ±

Еще вариант
Код
=ВПР("всего по округу";ИНДЕКС(Динамическая!A:A;ПОИСКПОЗ(A4;Динамическая!A:A;)):Динамическая!D99;4;)
Код
=ВПР("всего по округу";СМЕЩ(Динамическая!A$1;ПОИСКПОЗ(A4;Динамическая!A:A;);;99;4);4;)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Четверг, 01.12.2016, 13:34
 
Ответить
СообщениеЕще вариант
Код
=ВПР("всего по округу";ИНДЕКС(Динамическая!A:A;ПОИСКПОЗ(A4;Динамическая!A:A;)):Динамическая!D99;4;)
Код
=ВПР("всего по округу";СМЕЩ(Динамическая!A$1;ПОИСКПОЗ(A4;Динамическая!A:A;);;99;4);4;)

Автор - AlexM
Дата добавления - 01.12.2016 в 11:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » определение номера строки относительно заданной позиции (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!