Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сбор данных по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных по условию (Формулы/Formulas)
Сбор данных по условию
ASM_0408 Дата: Вторник, 25.04.2017, 06:54 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 162
Репутация: 0 ±
Замечаний: 0% ±

2016
Доброе утро, форумчане! Необходимо ваше содействие в поиске решения. В приложенном файле на листе ИТОГО производится расчет материалов по количеству и цене. Файл приложил урезанный по составу материалов. Не могу решить следующую задачу: перенести данные с этого листа по условию ячейка K16>0 на лист СВОД, с переносом всех необходимых данных: материал, ед. изм., количество, цена, стоимость (может быть вычисляемая). По форуму не смог найти, а может не там искал. Благодарю!!!
К сообщению приложен файл: _-.xlsx(55Kb)
 
Ответить
СообщениеДоброе утро, форумчане! Необходимо ваше содействие в поиске решения. В приложенном файле на листе ИТОГО производится расчет материалов по количеству и цене. Файл приложил урезанный по составу материалов. Не могу решить следующую задачу: перенести данные с этого листа по условию ячейка K16>0 на лист СВОД, с переносом всех необходимых данных: материал, ед. изм., количество, цена, стоимость (может быть вычисляемая). По форуму не смог найти, а может не там искал. Благодарю!!!

Автор - ASM_0408
Дата добавления - 25.04.2017 в 06:54
китин Дата: Вторник, 25.04.2017, 07:28 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4180
Репутация: 657 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Так надо? формула масива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Итого!A$16:A$50;НАИМЕНЬШИЙ(ЕСЛИ(Итого!$K$16:$K$50>0;СТРОКА(Итого!$A$16:$A$50)-15);СТРОКА(A1)));"")
К сообщению приложен файл: 222111.xlsx(60Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеТак надо? формула масива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Итого!A$16:A$50;НАИМЕНЬШИЙ(ЕСЛИ(Итого!$K$16:$K$50>0;СТРОКА(Итого!$A$16:$A$50)-15);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 25.04.2017 в 07:28
ASM_0408 Дата: Вторник, 25.04.2017, 07:47 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 162
Репутация: 0 ±
Замечаний: 0% ±

2016
Так надо? формула масива

Благодарю!!! Это то что нужно hands hands hands
 
Ответить
Сообщение
Так надо? формула масива

Благодарю!!! Это то что нужно hands hands hands

Автор - ASM_0408
Дата добавления - 25.04.2017 в 07:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!