Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений (Формулы/Formulas)
Подстановка значений
andron359 Дата: Понедельник, 01.05.2017, 17:40 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 20% ±

Всех с праздником !!!Добрый день ! Помогите с формулой , подставить -01,-02 и т.д. к основному значению на основе значений в других ячейках . Подробнее внутри файла.Спасибо заранее.
К сообщению приложен файл: 4159793.xlsx(11Kb)
 
Ответить
СообщениеВсех с праздником !!!Добрый день ! Помогите с формулой , подставить -01,-02 и т.д. к основному значению на основе значений в других ячейках . Подробнее внутри файла.Спасибо заранее.

Автор - andron359
Дата добавления - 01.05.2017 в 17:40
AlexM Дата: Понедельник, 01.05.2017, 17:50 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3600
Репутация: 903 ±
Замечаний: 0% ±

Excel 2003
Подробнее внутри файла
В файле еще не понятнее.
добавляется 01 - сколько совпадений, в каких столбцах и с чем совпадают
добавляется 02 - .....
добавляется 03 - .....
Если добавляется и другие значения, опишите подробно.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Подробнее внутри файла
В файле еще не понятнее.
добавляется 01 - сколько совпадений, в каких столбцах и с чем совпадают
добавляется 02 - .....
добавляется 03 - .....
Если добавляется и другие значения, опишите подробно.

Автор - AlexM
Дата добавления - 01.05.2017 в 17:50
vikttur Дата: Понедельник, 01.05.2017, 18:01 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2519
Репутация: 452 ±
Замечаний: 0% ±

Код
=ЕСЛИ(L9="";"";ИНДЕКС($C$4:$C$7;ПОИСКПОЗ(I9;$D$4:$D$7;))&ТЕКСТ(СЧЁТЕСЛИ($L$9:L9;H9&I9&J9&K9);"-00"))
К сообщению приложен файл: 7853168.xlsx(11Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(L9="";"";ИНДЕКС($C$4:$C$7;ПОИСКПОЗ(I9;$D$4:$D$7;))&ТЕКСТ(СЧЁТЕСЛИ($L$9:L9;H9&I9&J9&K9);"-00"))

Автор - vikttur
Дата добавления - 01.05.2017 в 18:01
andron359 Дата: Понедельник, 01.05.2017, 18:05 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 20% ±

AlexM,
Добавляется -01 , если во всех четырёх совпадение , если в следующих эти же четыре то -02 и т.д.
 
Ответить
СообщениеAlexM,
Добавляется -01 , если во всех четырёх совпадение , если в следующих эти же четыре то -02 и т.д.

Автор - andron359
Дата добавления - 01.05.2017 в 18:05
andron359 Дата: Понедельник, 01.05.2017, 18:15 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 86
Репутация: 0 ±
Замечаний: 20% ±

AlexM,
1111 это всегда Май ,Мос ,П ,Минск и когда эти четыре данные вводятся в другую строку то к 1111 добавляется -01 ( 1111-01) , если они же в другую то добавляется-02(1111-02).
Ну как-то так, попытался обьяснить
 
Ответить
СообщениеAlexM,
1111 это всегда Май ,Мос ,П ,Минск и когда эти четыре данные вводятся в другую строку то к 1111 добавляется -01 ( 1111-01) , если они же в другую то добавляется-02(1111-02).
Ну как-то так, попытался обьяснить

Автор - andron359
Дата добавления - 01.05.2017 в 18:15
jakim Дата: Понедельник, 01.05.2017, 20:06 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 808
Репутация: 209 ±
Замечаний: 0% ±

Для решения Вашей задачи необходимо наличие "таблицы соответствий" набора данных присваемому номеру.
Смотрите мой вариант с формулой

Код
=IF(H9="";"";LOOKUP(2;1/(C$4:C$7=I9)/(B$4:B$7=J9)/(D$4:D$7=K9);E$4:E$7))&TEXT(COUNTIFS(H$9:H9;H9;I$9:I9;I9;J$9:J9;J9;K$9:K9;K9);"-00")
К сообщению приложен файл: 6897361.xlsx(11Kb)


Сообщение отредактировал jakim - Понедельник, 01.05.2017, 20:07
 
Ответить
Сообщение
Для решения Вашей задачи необходимо наличие "таблицы соответствий" набора данных присваемому номеру.
Смотрите мой вариант с формулой

Код
=IF(H9="";"";LOOKUP(2;1/(C$4:C$7=I9)/(B$4:B$7=J9)/(D$4:D$7=K9);E$4:E$7))&TEXT(COUNTIFS(H$9:H9;H9;I$9:I9;I9;J$9:J9;J9;K$9:K9;K9);"-00")

Автор - jakim
Дата добавления - 01.05.2017 в 20:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!