Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула определения превышения заданных нормативов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула определения превышения заданных нормативов (Формулы/Formulas)
Формула определения превышения заданных нормативов
ФобоС Дата: Пятница, 05.05.2017, 06:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Доброго дня!
Не буду вдаваться в подробности для чего нужна данная формула. это лишь одна из частей большого расчета. Но суть такова:
Расчетом предполагается, что если хоть одно число в диапазоне больше другого в полтора раза и более, но выполняется определенное условие.

есть формула: A19
Код
=ЕСЛИ(СЧЁТЕСЛИ(D5:O5;">2545,5");1;0)

То есть если хоть одно из чисел диапазона D5:O5 больше заданного значения (2545,5), то выполняется условие (для простоты этим условием пока является "1")
НО! Необходимо чтобы вместо числа (2545,5) была формула, которая умножала бы необходимые данные на 1,5.
Ввожу
Код
=ЕСЛИ(СЧЁТЕСЛИ(D5:O5;">C5*1,5");1;0)
и эксель не видит C5*1,5 как условие, а видит как текст.
Не могу понять почему. Может есть другой подход к решению поставленной задачи.
К сообщению приложен файл: 1217947.xls(42Kb)


Сообщение отредактировал Pelena - Пятница, 05.05.2017, 06:55
 
Ответить
СообщениеДоброго дня!
Не буду вдаваться в подробности для чего нужна данная формула. это лишь одна из частей большого расчета. Но суть такова:
Расчетом предполагается, что если хоть одно число в диапазоне больше другого в полтора раза и более, но выполняется определенное условие.

есть формула: A19
Код
=ЕСЛИ(СЧЁТЕСЛИ(D5:O5;">2545,5");1;0)

То есть если хоть одно из чисел диапазона D5:O5 больше заданного значения (2545,5), то выполняется условие (для простоты этим условием пока является "1")
НО! Необходимо чтобы вместо числа (2545,5) была формула, которая умножала бы необходимые данные на 1,5.
Ввожу
Код
=ЕСЛИ(СЧЁТЕСЛИ(D5:O5;">C5*1,5");1;0)
и эксель не видит C5*1,5 как условие, а видит как текст.
Не могу понять почему. Может есть другой подход к решению поставленной задачи.

Автор - ФобоС
Дата добавления - 05.05.2017 в 06:16
buchlotnik Дата: Пятница, 05.05.2017, 06:49 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2866
Репутация: 806 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Не могу понять почему
в кавычках потому что :)
Код
=СЧЁТЕСЛИ(D5:O5;">"&C5*1,5)
К сообщению приложен файл: 7632232.xls(48Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
Не могу понять почему
в кавычках потому что :)
Код
=СЧЁТЕСЛИ(D5:O5;">"&C5*1,5)

Автор - buchlotnik
Дата добавления - 05.05.2017 в 06:49
ФобоС Дата: Пятница, 05.05.2017, 07:08 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
в кавычках потому что

Эксель сам предложил их вставить.
А для чего стоит знак "&" ?
 
Ответить
Сообщение
в кавычках потому что

Эксель сам предложил их вставить.
А для чего стоит знак "&" ?

Автор - ФобоС
Дата добавления - 05.05.2017 в 07:08
buchlotnik Дата: Пятница, 05.05.2017, 07:15 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2866
Репутация: 806 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Эксель сам предложил их вставить
Не верю! А амперсанд заменяет функцию СЦЕП() т.е. слепляет несколько кусков в один текст


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
Эксель сам предложил их вставить
Не верю! А амперсанд заменяет функцию СЦЕП() т.е. слепляет несколько кусков в один текст

Автор - buchlotnik
Дата добавления - 05.05.2017 в 07:15
ФобоС Дата: Пятница, 05.05.2017, 07:21 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Не верю!

Я что, вру по-Вашему? Попробуйте убрать кавычки из формулы =ЕСЛИ(СЧЁТЕСЛИ(D5:O5;">C5*1,5");1;0) и посмотрите, что получится.
 
Ответить
Сообщение
Не верю!

Я что, вру по-Вашему? Попробуйте убрать кавычки из формулы =ЕСЛИ(СЧЁТЕСЛИ(D5:O5;">C5*1,5");1;0) и посмотрите, что получится.

Автор - ФобоС
Дата добавления - 05.05.2017 в 07:21
buchlotnik Дата: Пятница, 05.05.2017, 07:26 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2866
Репутация: 806 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
посмотрите, что получится
получится стандартное окно, в котором про кавычки не слова.

А если ещё и знак больше убрать - Excel вообще ругаться перестанет, но вам нужно со знаком больше, потому и амперсанд :)
К сообщению приложен файл: 9601115.png(40Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 05.05.2017, 07:28
 
Ответить
Сообщение
Цитата
посмотрите, что получится
получится стандартное окно, в котором про кавычки не слова.

А если ещё и знак больше убрать - Excel вообще ругаться перестанет, но вам нужно со знаком больше, потому и амперсанд :)

Автор - buchlotnik
Дата добавления - 05.05.2017 в 07:26
Che79 Дата: Пятница, 05.05.2017, 09:13 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 403
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010 RUS
ФобоС, здравствуйте. Если у Вас условия всегда именно 0 или 1, то можно так:
Код
{=--ИЛИ(D5:O5>C5*1,5)}
. Формула массива, вводится одновременным нажатием Ктрл+Шифт+Энтер


Делай нормально и будет нормально!
 
Ответить
СообщениеФобоС, здравствуйте. Если у Вас условия всегда именно 0 или 1, то можно так:
Код
{=--ИЛИ(D5:O5>C5*1,5)}
. Формула массива, вводится одновременным нажатием Ктрл+Шифт+Энтер

Автор - Che79
Дата добавления - 05.05.2017 в 09:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула определения превышения заданных нормативов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!