Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/посчитать ячейки с заданными условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать ячейки с заданными условиями (Формулы/Formulas)
посчитать ячейки с заданными условиями
Gaidukoff Дата: Пятница, 05.05.2017, 16:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
есть таблица с данными. под ней две формулы итоговых значений: всего проверенных мультиметров и забракованных из них. с подсчетом первой формулы проблем нет, а вот вторая не подсчитывает, почему не могу понять. подскажите где ошибка
К сообщению приложен файл: 2186918.xlsx(13Kb)
 
Ответить
Сообщениеесть таблица с данными. под ней две формулы итоговых значений: всего проверенных мультиметров и забракованных из них. с подсчетом первой формулы проблем нет, а вот вторая не подсчитывает, почему не могу понять. подскажите где ошибка

Автор - Gaidukoff
Дата добавления - 05.05.2017 в 16:29
_Boroda_ Дата: Пятница, 05.05.2017, 16:32 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11850
Репутация: 4910 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
СУММПРОИЗВ так не работает
Попробуйте вот так
Код
=СЧЁТЕСЛИМН($A$2:$A$15;"Мультиметр";E$2:E$15;"и*")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСУММПРОИЗВ так не работает
Попробуйте вот так
Код
=СЧЁТЕСЛИМН($A$2:$A$15;"Мультиметр";E$2:E$15;"и*")

Автор - _Boroda_
Дата добавления - 05.05.2017 в 16:32
Gaidukoff Дата: Пятница, 05.05.2017, 16:36 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
СУММПРОИЗВ так не работает
Попробуйте вот так

=СЧЁТЕСЛИМН($A$2:$A$15;"Мультиметр";E$2:E$15;"и*")


Спасибо, вроде работает. пошёл на большой таблице пробовать
 
Ответить
Сообщение
СУММПРОИЗВ так не работает
Попробуйте вот так

=СЧЁТЕСЛИМН($A$2:$A$15;"Мультиметр";E$2:E$15;"и*")


Спасибо, вроде работает. пошёл на большой таблице пробовать

Автор - Gaidukoff
Дата добавления - 05.05.2017 в 16:36
sboy Дата: Пятница, 05.05.2017, 16:38 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1163
Репутация: 293 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
с суммпроизв можно так
Код
=СУММПРОИЗВ(($A$2:$A$15="Мультиметр")*ЕЧИСЛО(ПОИСК("и*";E$2:E$15)))
К сообщению приложен файл: 1140071.xlsx(13Kb)
 
Ответить
СообщениеДобрый день.
с суммпроизв можно так
Код
=СУММПРОИЗВ(($A$2:$A$15="Мультиметр")*ЕЧИСЛО(ПОИСК("и*";E$2:E$15)))

Автор - sboy
Дата добавления - 05.05.2017 в 16:38
buchlotnik Дата: Пятница, 05.05.2017, 16:46 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3430
Репутация: 920 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
до кучи массивка
Код
=СЧЁТ((B2:B15="Мультиметр")/ЕОШ(-E2:E15))
К сообщению приложен файл: 5391957.xlsx(13Kb)


"заступлюсь за Юрия" - публичный плевок в душу!
 
Ответить
Сообщениедо кучи массивка
Код
=СЧЁТ((B2:B15="Мультиметр")/ЕОШ(-E2:E15))

Автор - buchlotnik
Дата добавления - 05.05.2017 в 16:46
Che79 Дата: Пятница, 05.05.2017, 19:57 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 654
Репутация: 113 ±
Замечаний: 0% ±

Excel 2007, 2013
до кучи
сделаем кучу чуть больше :D
Код
=СУММПРОИЗВ((A2:A15="Мультиметр")*НЕ(ЕОШ(ПОИСК(".";E2:E15))))
или, если преобразовать массив E2:E15 из текста в числа (выделить диапазон - клацнуть на восклицательный знак в левом углу ячейки - Преобразовать в число - исчезнут зеленые треугольнички в ячейках), то можно и так
Код
=СУММПРОИЗВ((A2:A15="Мультиметр")*ЕТЕКСТ(E2:E15))
К сообщению приложен файл: 2186918_1.xlsx(13Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
до кучи
сделаем кучу чуть больше :D
Код
=СУММПРОИЗВ((A2:A15="Мультиметр")*НЕ(ЕОШ(ПОИСК(".";E2:E15))))
или, если преобразовать массив E2:E15 из текста в числа (выделить диапазон - клацнуть на восклицательный знак в левом углу ячейки - Преобразовать в число - исчезнут зеленые треугольнички в ячейках), то можно и так
Код
=СУММПРОИЗВ((A2:A15="Мультиметр")*ЕТЕКСТ(E2:E15))

Автор - Che79
Дата добавления - 05.05.2017 в 19:57
vikttur Дата: Суббота, 06.05.2017, 00:16 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2555
Репутация: 460 ±
Замечаний: 0% ±

Код
=СУММПРОИЗВ(--(A2:A15="Мультиметр");--(ЛЕВБ(E2:E15)="и"))

Код
=СУММПРОИЗВ(--(A2:A15="Мультиметр");--ЕОШ(--E2:E15))

Из всех лучше СЧЕТЕСЛИМН


Сообщение отредактировал vikttur - Суббота, 06.05.2017, 00:17
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--(A2:A15="Мультиметр");--(ЛЕВБ(E2:E15)="и"))

Код
=СУММПРОИЗВ(--(A2:A15="Мультиметр");--ЕОШ(--E2:E15))

Из всех лучше СЧЕТЕСЛИМН

Автор - vikttur
Дата добавления - 06.05.2017 в 00:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать ячейки с заданными условиями (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!