Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/автоматическое заполнение ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » автоматическое заполнение ячеек (Сводные таблицы/Pivot Table)
автоматическое заполнение ячеек
RedRex Дата: Понедельник, 08.05.2017, 22:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте товарищи! Помогите пожалуйста решить задачку. При выборе из выпадающего списка работ, необходимо чтобы заполнялись столбцы ед.изм. и Цена. Заранее благодарю.
Файл прилагаю.
К сообщению приложен файл: 9485771.xlsx(16Kb)
 
Ответить
СообщениеЗдравствуйте товарищи! Помогите пожалуйста решить задачку. При выборе из выпадающего списка работ, необходимо чтобы заполнялись столбцы ед.изм. и Цена. Заранее благодарю.
Файл прилагаю.

Автор - RedRex
Дата добавления - 08.05.2017 в 22:13
gling Дата: Понедельник, 08.05.2017, 22:24 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1587
Репутация: 388 ±
Замечаний: 0% ±

2010
Здравствуйте. Почитайте про функцию ВПР, и цена через тире это не число а текст. Текст не будет умножаться на количество для получения стоимости.
Пример для единиц измерения
Код
=ВПР(C8;Прайс!B:D;2;0)


Сообщение отредактировал gling - Понедельник, 08.05.2017, 22:26
 
Ответить
СообщениеЗдравствуйте. Почитайте про функцию ВПР, и цена через тире это не число а текст. Текст не будет умножаться на количество для получения стоимости.
Пример для единиц измерения
Код
=ВПР(C8;Прайс!B:D;2;0)

Автор - gling
Дата добавления - 08.05.2017 в 22:24
Che79 Дата: Понедельник, 08.05.2017, 23:21 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 383
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007, 2010, 2016 RUS
RedRex, здравствуйте. Посмотрите такой вариант. Формулы в желтых ячейках на листе "Наряд". На листе "Прайс" сделал пустой доп. столбец, чтобы формулу с ИНДЕКС+ПОИСКПОЗ можно было копировать.
Код
=ИНДЕКС(Прайс!C$2:C$6;ПОИСКПОЗ($C8;Прайс!$B$2:$B$6;))
Расц. за единицу там где указан интервал с тире можно посчитать, например, так
Код
=ЕСЛИОШИБКА(E8*F8;E8*СЛУЧМЕЖДУ(ПСТР(F8;1;ПОИСК("-";F8)-1);ПСТР(F8;ПОИСК("-";F8)+1;ДЛСТР(F8)-ПОИСК("-";F8))))
Вариант хулиганский, при каждом вычислении листа возвращается новое случайное целое число.
К сообщению приложен файл: 485771_1.xlsx(15Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 08.05.2017, 23:32
 
Ответить
СообщениеRedRex, здравствуйте. Посмотрите такой вариант. Формулы в желтых ячейках на листе "Наряд". На листе "Прайс" сделал пустой доп. столбец, чтобы формулу с ИНДЕКС+ПОИСКПОЗ можно было копировать.
Код
=ИНДЕКС(Прайс!C$2:C$6;ПОИСКПОЗ($C8;Прайс!$B$2:$B$6;))
Расц. за единицу там где указан интервал с тире можно посчитать, например, так
Код
=ЕСЛИОШИБКА(E8*F8;E8*СЛУЧМЕЖДУ(ПСТР(F8;1;ПОИСК("-";F8)-1);ПСТР(F8;ПОИСК("-";F8)+1;ДЛСТР(F8)-ПОИСК("-";F8))))
Вариант хулиганский, при каждом вычислении листа возвращается новое случайное целое число.

Автор - Che79
Дата добавления - 08.05.2017 в 23:21
RedRex Дата: Вторник, 09.05.2017, 07:47 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Благодарю Вас за помощь, друзья. Все отлично получилось. Прайс я подправил под целые числа. Ещё вопрос - скопировал формулу на нижние пустые строки для последующего заполнения, как скрыть #Н/Д?
 
Ответить
СообщениеБлагодарю Вас за помощь, друзья. Все отлично получилось. Прайс я подправил под целые числа. Ещё вопрос - скопировал формулу на нижние пустые строки для последующего заполнения, как скрыть #Н/Д?

Автор - RedRex
Дата добавления - 09.05.2017 в 07:47
DrMini Дата: Вторник, 09.05.2017, 08:23 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010, 2013
как скрыть #Н/Д?

Можно через УФ:
Код
=ЕОШИБКА(D8)

цвет подберёте.
 
Ответить
Сообщение
как скрыть #Н/Д?

Можно через УФ:
Код
=ЕОШИБКА(D8)

цвет подберёте.

Автор - DrMini
Дата добавления - 09.05.2017 в 08:23
DrMini Дата: Вторник, 09.05.2017, 08:55 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010, 2013
Можно ещё и так.
Посмотрите файл подправил формулу в D12 и F12. Формат ячейки ;;;

Не неправильно.


Сообщение отредактировал DrMini - Вторник, 09.05.2017, 10:28
 
Ответить
СообщениеМожно ещё и так.
Посмотрите файл подправил формулу в D12 и F12. Формат ячейки ;;;

Не неправильно.

Автор - DrMini
Дата добавления - 09.05.2017 в 08:55
DrMini Дата: Вторник, 09.05.2017, 09:26 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010, 2013
Для ед. изм.
Код
=ЕСЛИОШИБКА(ВПР(C8;Прайс!B:D;2;0);"")
 
Ответить
СообщениеДля ед. изм.
Код
=ЕСЛИОШИБКА(ВПР(C8;Прайс!B:D;2;0);"")

Автор - DrMini
Дата добавления - 09.05.2017 в 09:26
Che79 Дата: Вторник, 09.05.2017, 10:01 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 383
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007, 2010, 2016 RUS
RedRex, если у Вас прайс с целыми числами и нужно скрыть ошибки, то по Вашему примеру можно так. Для ед. изм. и цены копируемая формула
Код
=ЕСЛИОШИБКА(ВПР($C8;Прайс!$B$2:$D$1000;СТОЛБЕЦ(B$1)-(СТОЛБЕЦ(B$1)>2););0)
Для расц. за единицу
Код
=ЕСЛИОШИБКА(E8*F8;0)
К сообщению приложен файл: 485771_2.xlsx(15Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеRedRex, если у Вас прайс с целыми числами и нужно скрыть ошибки, то по Вашему примеру можно так. Для ед. изм. и цены копируемая формула
Код
=ЕСЛИОШИБКА(ВПР($C8;Прайс!$B$2:$D$1000;СТОЛБЕЦ(B$1)-(СТОЛБЕЦ(B$1)>2););0)
Для расц. за единицу
Код
=ЕСЛИОШИБКА(E8*F8;0)

Автор - Che79
Дата добавления - 09.05.2017 в 10:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » автоматическое заполнение ячеек (Сводные таблицы/Pivot Table)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!