Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества слов из в 1 ячейке (Формуламы) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества слов из в 1 ячейке (Формуламы) (Формулы/Formulas)
Подсчет количества слов из в 1 ячейке (Формуламы)
djorje15 Дата: Воскресенье, 14.05.2017, 20:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Добрый день. Задача подсчитать количество слов в одной ячейке.
Нашел тему Начальная тема Счет слов в ячейке, однако появляется ошибка, если в одной ячейке несколько одинаковых слов.
Например : мама введено 3 раза, а считает 2.
Пожалуйста, подправьте формулу, чтобы считало столько сколько нужно..
К сообщению приложен файл: 3617533_.xlsx(9Kb)
 
Ответить
СообщениеДобрый день. Задача подсчитать количество слов в одной ячейке.
Нашел тему Начальная тема Счет слов в ячейке, однако появляется ошибка, если в одной ячейке несколько одинаковых слов.
Например : мама введено 3 раза, а считает 2.
Пожалуйста, подправьте формулу, чтобы считало столько сколько нужно..

Автор - djorje15
Дата добавления - 14.05.2017 в 20:14
Nic70y Дата: Воскресенье, 14.05.2017, 20:24 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3917
Репутация: 829 ±
Замечаний: 0% ±

Excel 2013
нате вам еще 1 неправильную формулу
Код
=СУММ((ДЛСТР(B$5:B$8)-ДЛСТР(ПОДСТАВИТЬ(B$5:B$8;D5;)))/ДЛСТР(D5))
К сообщению приложен файл: 4618576.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениенате вам еще 1 неправильную формулу
Код
=СУММ((ДЛСТР(B$5:B$8)-ДЛСТР(ПОДСТАВИТЬ(B$5:B$8;D5;)))/ДЛСТР(D5))

Автор - Nic70y
Дата добавления - 14.05.2017 в 20:24
vikttur Дата: Воскресенье, 14.05.2017, 20:24 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2123
Репутация: 374 ±
Замечаний: 0% ±

Формула массив:
Код
=СУММ(ДЛСТР($B$5:$B$8)-ДЛСТР(ПОДСТАВИТЬ($B$5:$B$8;D5;)))/ДЛСТР(D5)

Нужно помнить, что формула посчитает не только слова, но и части слов. Например: "мама" в слове "мамалыга"
Считать только слова:
Код
=СУММ(ДЛСТР(" "&$B$5:$B$8&" ")-ДЛСТР(ПОДСТАВИТЬ(" "&$B$5:$B$8&" ";" "&D5&" ";)))/(ДЛСТР(D5)+2)


Сообщение отредактировал vikttur - Воскресенье, 14.05.2017, 20:27
 
Ответить
СообщениеФормула массив:
Код
=СУММ(ДЛСТР($B$5:$B$8)-ДЛСТР(ПОДСТАВИТЬ($B$5:$B$8;D5;)))/ДЛСТР(D5)

Нужно помнить, что формула посчитает не только слова, но и части слов. Например: "мама" в слове "мамалыга"
Считать только слова:
Код
=СУММ(ДЛСТР(" "&$B$5:$B$8&" ")-ДЛСТР(ПОДСТАВИТЬ(" "&$B$5:$B$8&" ";" "&D5&" ";)))/(ДЛСТР(D5)+2)

Автор - vikttur
Дата добавления - 14.05.2017 в 20:24
AlexM Дата: Воскресенье, 14.05.2017, 22:04 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3446
Репутация: 873 ±
Замечаний: 0% ±

Код
=СУММПРОИЗВ(Ч(ПСТР(B$5:B$8;СТОЛБЕЦ(1:1);ДЛСТР(D5))=D5))
К сообщению приложен файл: 3617533_01.xlsx(9Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(Ч(ПСТР(B$5:B$8;СТОЛБЕЦ(1:1);ДЛСТР(D5))=D5))

Автор - AlexM
Дата добавления - 14.05.2017 в 22:04
vikttur Дата: Понедельник, 15.05.2017, 00:22 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2123
Репутация: 374 ±
Замечаний: 0% ±

СТОЛБЕЦ(1:1) - это круто... Сколько же лишних вычислений лопатит формула?
 
Ответить
СообщениеСТОЛБЕЦ(1:1) - это круто... Сколько же лишних вычислений лопатит формула?

Автор - vikttur
Дата добавления - 15.05.2017 в 00:22
AlexM Дата: Понедельник, 15.05.2017, 09:02 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3446
Репутация: 873 ±
Замечаний: 0% ±

Мой Excel создает массив от 1 до 256, не смотря на расширение xlsx
В некоторых формулах используются массивы от 1 до 999 или больше.
Не так часто заметно увеличение времени обработки таблиц в такими формулами.
Это замечание вполне уместно, djorje15 должен знать специфику работы таких формул.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеМой Excel создает массив от 1 до 256, не смотря на расширение xlsx
В некоторых формулах используются массивы от 1 до 999 или больше.
Не так часто заметно увеличение времени обработки таблиц в такими формулами.
Это замечание вполне уместно, djorje15 должен знать специфику работы таких формул.

Автор - AlexM
Дата добавления - 15.05.2017 в 09:02
vikttur Дата: Понедельник, 15.05.2017, 09:22 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2123
Репутация: 374 ±
Замечаний: 0% ±

Цитата
массив от 1 до 256, не смотря на расширение xlsx

Странно... У меня считает правильно:
Код
=СЧЁТ(СТОЛБЕЦ(1:1)) = 16384


Вообще, я сторонник оптимизации вычислений. То, что вытворяют в МШ, не всегда применимо в рабочих файлах. Не всегда известно, где будет применена формула, на каких массивах данных и в каком количестве. И мы, соревнуясь друг с другом, ужимая формулы "до немогу", часто оказываем медвежью услугу. Сам иногда грешу )


Сообщение отредактировал vikttur - Понедельник, 15.05.2017, 09:35
 
Ответить
Сообщение
Цитата
массив от 1 до 256, не смотря на расширение xlsx

Странно... У меня считает правильно:
Код
=СЧЁТ(СТОЛБЕЦ(1:1)) = 16384


Вообще, я сторонник оптимизации вычислений. То, что вытворяют в МШ, не всегда применимо в рабочих файлах. Не всегда известно, где будет применена формула, на каких массивах данных и в каком количестве. И мы, соревнуясь друг с другом, ужимая формулы "до немогу", часто оказываем медвежью услугу. Сам иногда грешу )

Автор - vikttur
Дата добавления - 15.05.2017 в 09:22
AlexM Дата: Понедельник, 15.05.2017, 09:40 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3446
Репутация: 873 ±
Замечаний: 0% ±

Странно...
У меня Excel2003
То, что вытворяют в МШ, не всегда применимо в рабочих файлах
Из правил МШ - Правила просты: Вопрос должен быть оригинальным, нетривиальным и интересным. Но может не иметь практического смысла.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Странно...
У меня Excel2003
То, что вытворяют в МШ, не всегда применимо в рабочих файлах
Из правил МШ - Правила просты: Вопрос должен быть оригинальным, нетривиальным и интересным. Но может не иметь практического смысла.

Автор - AlexM
Дата добавления - 15.05.2017 в 09:40
vikttur Дата: Понедельник, 15.05.2017, 09:42 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2123
Репутация: 374 ±
Замечаний: 0% ±

Так об этом и пишу: не все, что дозволено в МШ, можно применять без оглядки.
Автору, возможно, достаточно посчитать 5 слов в массиве или извлечь 4 уникальных значения. Через время в тему заглянет другой, у которого слов для подсчета (или уникальных) - сотни... Потом будет обвинять форум в том, что ему подсунули тормоза )

Цитата
У меня Excel2003

Естественно, Excel-2003 так и покажет, он еще не знал, что у будущих младших братиков размеры с рождения побольше.


Сообщение отредактировал vikttur - Понедельник, 15.05.2017, 09:48
 
Ответить
СообщениеТак об этом и пишу: не все, что дозволено в МШ, можно применять без оглядки.
Автору, возможно, достаточно посчитать 5 слов в массиве или извлечь 4 уникальных значения. Через время в тему заглянет другой, у которого слов для подсчета (или уникальных) - сотни... Потом будет обвинять форум в том, что ему подсунули тормоза )

Цитата
У меня Excel2003

Естественно, Excel-2003 так и покажет, он еще не знал, что у будущих младших братиков размеры с рождения побольше.

Автор - vikttur
Дата добавления - 15.05.2017 в 09:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества слов из в 1 ячейке (Формуламы) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!