Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения по двум критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по двум критериям (Формулы/Formulas)
Поиск значения по двум критериям
humanunique Дата: Вторник, 16.05.2017, 13:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, уважаемые эксперты!

Прошу вашей помощи подкорректировать формулочку в приложенном примере.
Необходимо подтянуть даты каждой из задач из таблицы 1 в таблицу 2. Я смог добавить в формулу только один критерий - название задачи. Но необходимо также добавить второй критерий - код проекта.
То есть, дата должна искаться, исходя из кода проекта и имени задачи.

Большое спасибо за помощь!
К сообщению приложен файл: match_index_vlo.xlsx(13Kb)
 
Ответить
СообщениеДобрый день, уважаемые эксперты!

Прошу вашей помощи подкорректировать формулочку в приложенном примере.
Необходимо подтянуть даты каждой из задач из таблицы 1 в таблицу 2. Я смог добавить в формулу только один критерий - название задачи. Но необходимо также добавить второй критерий - код проекта.
То есть, дата должна искаться, исходя из кода проекта и имени задачи.

Большое спасибо за помощь!

Автор - humanunique
Дата добавления - 16.05.2017 в 13:53
китин Дата: Вторник, 16.05.2017, 13:57 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4345
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
почти как у вас :D формула массива
Код
=ИНДЕКС($D$5:$D$17;ПОИСКПОЗ(I$2&$H3;$C$5:$C$17&$B$5:$B$17;0))
К сообщению приложен файл: 222333.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 16.05.2017, 13:58
 
Ответить
Сообщениепочти как у вас :D формула массива
Код
=ИНДЕКС($D$5:$D$17;ПОИСКПОЗ(I$2&$H3;$C$5:$C$17&$B$5:$B$17;0))

Автор - китин
Дата добавления - 16.05.2017 в 13:57
AlexM Дата: Вторник, 16.05.2017, 14:09 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3585
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Обычная формула
Код
=ПРОСМОТР(2;1/($B$5:$B$17=$H3)/($C$5:$C$17=I$2);$D$5:$D$17)
К сообщению приложен файл: 1294424.xlsx(11Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеОбычная формула
Код
=ПРОСМОТР(2;1/($B$5:$B$17=$H3)/($C$5:$C$17=I$2);$D$5:$D$17)

Автор - AlexM
Дата добавления - 16.05.2017 в 14:09
Che79 Дата: Вторник, 16.05.2017, 16:17 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 533
Репутация: 92 ±
Замечаний: 0% ±

Excel 2010 RUS
Вариант из серии "А поизвращаться?" yes Лень на работе разбираться с ВПР'ом, поэтому загнал его в ТЕКСТ, вроде пашет как надо
Код
{=ТЕКСТ(ПСТР(ВПР($H3&I$2;$B$5:$B$17&$C$5:$D$17;2;);ДЛСТР($H3)+1;10);"ДД.ММ.ГГГГ")}
формула массива
К сообщению приложен файл: 123321.xlsx(14Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеВариант из серии "А поизвращаться?" yes Лень на работе разбираться с ВПР'ом, поэтому загнал его в ТЕКСТ, вроде пашет как надо
Код
{=ТЕКСТ(ПСТР(ВПР($H3&I$2;$B$5:$B$17&$C$5:$D$17;2;);ДЛСТР($H3)+1;10);"ДД.ММ.ГГГГ")}
формула массива

Автор - Che79
Дата добавления - 16.05.2017 в 16:17
humanunique Дата: Вторник, 16.05.2017, 16:55 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем спасибо! Имхо наиболее элегантный вариант первый :) Ну, и, может быть, второй...
 
Ответить
СообщениеВсем спасибо! Имхо наиболее элегантный вариант первый :) Ну, и, может быть, второй...

Автор - humanunique
Дата добавления - 16.05.2017 в 16:55
AlexM Дата: Вторник, 16.05.2017, 17:03 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3585
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Еще вариант обычной формулы
Код
=ПРОСМОТР(9^9;$D$5:$D$17/($B$5:$B$17&$C$5:$C$17=$H3&I$2))

и формула массива с ВПР()
Код
=ВПР(9^9;$D$5:$D$17/($B$5:$B$17&$C$5:$C$17=$H3&I$2);1)
и
Код
=-ВПР(;-$D$5:$D$17/($B$5:$B$17&$C$5:$C$17=$H3&I$2);1)
К сообщению приложен файл: 0010433.xlsx(11Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Вторник, 16.05.2017, 20:58
 
Ответить
СообщениеЕще вариант обычной формулы
Код
=ПРОСМОТР(9^9;$D$5:$D$17/($B$5:$B$17&$C$5:$C$17=$H3&I$2))

и формула массива с ВПР()
Код
=ВПР(9^9;$D$5:$D$17/($B$5:$B$17&$C$5:$C$17=$H3&I$2);1)
и
Код
=-ВПР(;-$D$5:$D$17/($B$5:$B$17&$C$5:$C$17=$H3&I$2);1)

Автор - AlexM
Дата добавления - 16.05.2017 в 17:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по двум критериям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!