Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить старшего и младшего в Экселе - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить старшего и младшего в Экселе (Формулы/Formulas)
Определить старшего и младшего в Экселе
kari_adam Дата: Среда, 17.05.2017, 10:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте!
Помогите, пожалуйста, с помощью возможностей Excel определить, какая девушка является старейшей, а какая младшей.
На рис. продемонстрировано, как должна выглядеть реализация указанной задачи (цветом выделены те ячейки,которые должны изменяться автоматически).
При этом построена таблица должна быть чувствительна к изменению имени или даты рождения.
Спасибо!
К сообщению приложен файл: 4453358.jpg(36Kb) · 4026300.xlsx(9Kb)
 
Ответить
СообщениеЗдравствуйте!
Помогите, пожалуйста, с помощью возможностей Excel определить, какая девушка является старейшей, а какая младшей.
На рис. продемонстрировано, как должна выглядеть реализация указанной задачи (цветом выделены те ячейки,которые должны изменяться автоматически).
При этом построена таблица должна быть чувствительна к изменению имени или даты рождения.
Спасибо!

Автор - kari_adam
Дата добавления - 17.05.2017 в 10:01
buchlotnik Дата: Среда, 17.05.2017, 10:09 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2995
Репутация: 839 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Код
=ИНДЕКС(C3:C5;ПОИСКПОЗ(МИН(D3:D5);D3:D5;0))
К сообщению приложен файл: 0661046.xlsx(9Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение
Код
=ИНДЕКС(C3:C5;ПОИСКПОЗ(МИН(D3:D5);D3:D5;0))

Автор - buchlotnik
Дата добавления - 17.05.2017 в 10:09
китин Дата: Среда, 17.05.2017, 10:11 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4331
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
старшая
Код
=ПРОСМОТР(;-1/(D3:D5=МИН(D3:D5));C3:C5)
младшая
Код
=ПРОСМОТР(;-1/(D3:D5=МАКС(D3:D5));C3:C5)
К сообщению приложен файл: 333222.xlsx(9Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 17.05.2017, 11:43
 
Ответить
Сообщениестаршая
Код
=ПРОСМОТР(;-1/(D3:D5=МИН(D3:D5));C3:C5)
младшая
Код
=ПРОСМОТР(;-1/(D3:D5=МАКС(D3:D5));C3:C5)

Автор - китин
Дата добавления - 17.05.2017 в 10:11
vikttur Дата: Среда, 17.05.2017, 10:11 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2400
Репутация: 413 ±
Замечаний: 0% ±

Используйте функции МАКС и МИН
Код
=ИНДЕКС(C3:C5;ПОИСКПОЗ(МАКС(E3:E5);E3:E5;))
 
Ответить
СообщениеИспользуйте функции МАКС и МИН
Код
=ИНДЕКС(C3:C5;ПОИСКПОЗ(МАКС(E3:E5);E3:E5;))

Автор - vikttur
Дата добавления - 17.05.2017 в 10:11
Che79 Дата: Среда, 17.05.2017, 10:23 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 464
Репутация: 72 ±
Замечаний: 0% ±

Excel 2010 RUS
Еще вариант
Код
=ВПР(МАКС($E$3:$E$5);ВЫБОР({1;2};$E$3:$E$5;$C$3:$C$5);2;)
Используйте функции МАКС и МИН


Делай нормально и будет нормально!
 
Ответить
СообщениеЕще вариант
Код
=ВПР(МАКС($E$3:$E$5);ВЫБОР({1;2};$E$3:$E$5;$C$3:$C$5);2;)
Используйте функции МАКС и МИН

Автор - Che79
Дата добавления - 17.05.2017 в 10:23
sboy Дата: Среда, 17.05.2017, 11:40 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 924
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
На основе формулы предложенной Игорем китин, сделал протягиваемую формулу
Код
=ПРОСМОТР(1;--($D$3:$D$5=АГРЕГАТ(СТОЛБЕЦ($F1)-СТОЛБЕЦ(A1);4;($D$3:$D$5)));$C$3:$C$5)
К сообщению приложен файл: 4278892.xlsx(9Kb)
 
Ответить
СообщениеДобрый день.
На основе формулы предложенной Игорем китин, сделал протягиваемую формулу
Код
=ПРОСМОТР(1;--($D$3:$D$5=АГРЕГАТ(СТОЛБЕЦ($F1)-СТОЛБЕЦ(A1);4;($D$3:$D$5)));$C$3:$C$5)

Автор - sboy
Дата добавления - 17.05.2017 в 11:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить старшего и младшего в Экселе (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!