Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как продлить строку, длина которой способна меняться - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как продлить строку, длина которой способна меняться (Формулы/Formulas)
Как продлить строку, длина которой способна меняться
EvaJa Дата: Четверг, 18.05.2017, 17:25 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемые знатоки! Помогите, пожалуйста, решить техническую задачу.
Есть строка (данные по темпам роста позиции), длина которой меняется от изменения констант (от 10 до 15 ячеек).
Необходимо продублировать эту строку так, чтобы после окончания данных они начинались с начала. (из одного цикла роста, сделать непрекращающийся процесс). Возможно ли это реализовать? Подскажите, пожалуйста!!!
К сообщению приложен файл: 7181799.xlsx(82Kb)
 
Ответить
СообщениеУважаемые знатоки! Помогите, пожалуйста, решить техническую задачу.
Есть строка (данные по темпам роста позиции), длина которой меняется от изменения констант (от 10 до 15 ячеек).
Необходимо продублировать эту строку так, чтобы после окончания данных они начинались с начала. (из одного цикла роста, сделать непрекращающийся процесс). Возможно ли это реализовать? Подскажите, пожалуйста!!!

Автор - EvaJa
Дата добавления - 18.05.2017 в 17:25
gling Дата: Четверг, 18.05.2017, 19:05 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1588
Репутация: 388 ±
Замечаний: 0% ±

2010
Попробуйте такую формулу массива вставить в Ваш пример
Код
=МАКС(ЕСЛИ($C$2:$CH$2=ИНДЕКС($C$25:$Q$25;ОСТАТ(СТОЛБЕЦ()-3;15)+1);$C$23:$CH$23))
Может не так понял.


Сообщение отредактировал gling - Четверг, 18.05.2017, 19:12
 
Ответить
СообщениеПопробуйте такую формулу массива вставить в Ваш пример
Код
=МАКС(ЕСЛИ($C$2:$CH$2=ИНДЕКС($C$25:$Q$25;ОСТАТ(СТОЛБЕЦ()-3;15)+1);$C$23:$CH$23))
Может не так понял.

Автор - gling
Дата добавления - 18.05.2017 в 19:05
EvaJa Дата: Четверг, 18.05.2017, 21:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Большое Вам спасибо за отклик! К сожалению, результата я не достигла. Если на первом листе увеличить "планируемый вес продукции", то строка 23 удлиняется, а в строке 32 данные, взятые из 23 строки, остаются статичными (т.е. обрываются). Буду признательна, если у Вас появится еще идея, как разрешить мой ребус.
 
Ответить
СообщениеБольшое Вам спасибо за отклик! К сожалению, результата я не достигла. Если на первом листе увеличить "планируемый вес продукции", то строка 23 удлиняется, а в строке 32 данные, взятые из 23 строки, остаются статичными (т.е. обрываются). Буду признательна, если у Вас появится еще идея, как разрешить мой ребус.

Автор - EvaJa
Дата добавления - 18.05.2017 в 21:57
gling Дата: Четверг, 18.05.2017, 23:23 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1588
Репутация: 388 ±
Замечаний: 0% ±

2010
Тогда попробуйте такую конструкцию ФМ
Код
=МАКС(ЕСЛИ($C$2:$CH$2=ИНДЕКС($C$25:$CH$25;ОСТАТ(СТОЛБЕЦ()-3;ПОИСКПОЗ(ИНДЕКС($C$2:$CH$2;ПОИСКПОЗ(9^9;$C$23:$CH$23;1));$C$25:$DF$25))+1);$C$23:$CH$23;0))
 
Ответить
СообщениеТогда попробуйте такую конструкцию ФМ
Код
=МАКС(ЕСЛИ($C$2:$CH$2=ИНДЕКС($C$25:$CH$25;ОСТАТ(СТОЛБЕЦ()-3;ПОИСКПОЗ(ИНДЕКС($C$2:$CH$2;ПОИСКПОЗ(9^9;$C$23:$CH$23;1));$C$25:$DF$25))+1);$C$23:$CH$23;0))

Автор - gling
Дата добавления - 18.05.2017 в 23:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как продлить строку, длина которой способна меняться (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!