Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложить дроби в ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложить дроби в ячейке (Формулы/Formulas)
Сложить дроби в ячейке
AVI Дата: Понедельник, 05.06.2017, 07:14 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 222
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Подскажите, пожалуйста, как формулой сложить доли в тексте
[vba]
Код
Зайцев Марк Михайлович 1/10, Зайцев Михаил Иванович 1/5, Зайцева Наталья Юрьевна 1/2, Шатилович Елизавета Михайловна 1/5
[/vba]
Формат итога без разницы (10/10 или 1 или 100%)
К сообщению приложен файл: 15.xlsx(9Kb)


Сообщение отредактировал AVI - Понедельник, 05.06.2017, 11:01
 
Ответить
СообщениеДобрый день!
Подскажите, пожалуйста, как формулой сложить доли в тексте
[vba]
Код
Зайцев Марк Михайлович 1/10, Зайцев Михаил Иванович 1/5, Зайцева Наталья Юрьевна 1/2, Шатилович Елизавета Михайловна 1/5
[/vba]
Формат итога без разницы (10/10 или 1 или 100%)

Автор - AVI
Дата добавления - 05.06.2017 в 07:14
AlexM Дата: Понедельник, 05.06.2017, 07:42 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
AVI, В строке всегда доли 4-х человек?
Доли всегда в сумме 10/10?
Пример должен быть не один. По одному алгоритм правильный не выбрать.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеAVI, В строке всегда доли 4-х человек?
Доли всегда в сумме 10/10?
Пример должен быть не один. По одному алгоритм правильный не выбрать.

Автор - AlexM
Дата добавления - 05.06.2017 в 07:42
buchlotnik Дата: Понедельник, 05.06.2017, 07:43 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2989
Репутация: 838 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
UDF в лоб [vba]
Код
Function sumpart(t$)
    Dim s$
    s = Replace(t, ",", "+")
    With CreateObject("VBScript.RegExp")
        .Global = True
        .Pattern = "[^0-9/+]"
        s = .Replace(s, "")
    End With
    sumpart = Evaluate(s)
End Function
[/vba]
К сообщению приложен файл: 15-2-.xlsm(14Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
СообщениеUDF в лоб [vba]
Код
Function sumpart(t$)
    Dim s$
    s = Replace(t, ",", "+")
    With CreateObject("VBScript.RegExp")
        .Global = True
        .Pattern = "[^0-9/+]"
        s = .Replace(s, "")
    End With
    sumpart = Evaluate(s)
End Function
[/vba]

Автор - buchlotnik
Дата добавления - 05.06.2017 в 07:43
AVI Дата: Понедельник, 05.06.2017, 11:01 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 222
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
AlexM, Добавил варианты. Спасибо за замечание!
 
Ответить
СообщениеAlexM, Добавил варианты. Спасибо за замечание!

Автор - AVI
Дата добавления - 05.06.2017 в 11:01
AVI Дата: Понедельник, 05.06.2017, 11:10 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 222
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, Спасибо!! "В лоб" отлично работает, 15000 строк просчитались за 10 секунд!
В целом, мне достаточного и этого!
Но если получится, то и формулой можно.
 
Ответить
Сообщениеbuchlotnik, Спасибо!! "В лоб" отлично работает, 15000 строк просчитались за 10 секунд!
В целом, мне достаточного и этого!
Но если получится, то и формулой можно.

Автор - AVI
Дата добавления - 05.06.2017 в 11:10
Светлый Дата: Понедельник, 05.06.2017, 12:42 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 293
Репутация: 73 ±
Замечаний: 0% ±

Excel 2007
Но если получится, то и формулой можно.

До / могут быть 3 цифры, после / м.б. 4 цифры:
Код
=СУММ(ЕСЛИОШИБКА(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A3;" ";"  ");",";"   ");(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A3;" ";"  ");",";"   ");СТРОКА($1:$999);1)="/")*СТРОКА($1:$999)-3;3)/ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A3;" ";"  ");",";"   ");(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A3;" ";"  ");",";"   ");СТРОКА($1:$999);1)="/")*СТРОКА($1:$999)+1;4);))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 05.06.2017, 12:56
 
Ответить
Сообщение
Но если получится, то и формулой можно.

До / могут быть 3 цифры, после / м.б. 4 цифры:
Код
=СУММ(ЕСЛИОШИБКА(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A3;" ";"  ");",";"   ");(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A3;" ";"  ");",";"   ");СТРОКА($1:$999);1)="/")*СТРОКА($1:$999)-3;3)/ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A3;" ";"  ");",";"   ");(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A3;" ";"  ");",";"   ");СТРОКА($1:$999);1)="/")*СТРОКА($1:$999)+1;4);))

Автор - Светлый
Дата добавления - 05.06.2017 в 12:42
AlexM Дата: Понедельник, 05.06.2017, 12:55 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
AVI, В строке 6 нет дробей. Функция Михаила возвращает ошибку.
Можно исправить.
В функции третью строку дополнить так
s = Replace(t & "+0", ",", "+")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеAVI, В строке 6 нет дробей. Функция Михаила возвращает ошибку.
Можно исправить.
В функции третью строку дополнить так
s = Replace(t & "+0", ",", "+")

Автор - AlexM
Дата добавления - 05.06.2017 в 12:55
AVI Дата: Понедельник, 05.06.2017, 12:58 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 222
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Функция Михаила возвращает ошибку.

Да, я заметил. Если ошибка - значит нет дроби. Мне главное выловить те, что не равны 1-це.
Но для "красоты" поставлю. Спасибо!
 
Ответить
Сообщение
Функция Михаила возвращает ошибку.

Да, я заметил. Если ошибка - значит нет дроби. Мне главное выловить те, что не равны 1-це.
Но для "красоты" поставлю. Спасибо!

Автор - AVI
Дата добавления - 05.06.2017 в 12:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложить дроби в ячейке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!