Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выпадающий список через ДВССЫЛ и СМЕЩ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выпадающий список через ДВССЫЛ и СМЕЩ (Формулы/Formulas)
Выпадающий список через ДВССЫЛ и СМЕЩ
Esperanto Дата: Среда, 14.06.2017, 10:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте. Помогите с проблемой.
Необходимо, чтобы когда менеджер выбирает день месяца - в соседнем столбце в выпадающем списке были доступны только те машины, которые отметили как "доступные" в этот день (и еще надо, чтобы пустых строк не было в выпадающем перечне)

Для этого сделал перечень авто и возможность, чтобы человек вручную по дням отмечал, какие из них будут доступны (т.к. надо чтобы можно было на сегодня и например на 3 дня вперед отметить доступные авто). После этого сделал еще одну таблицу в разрезе дней, куда переносятся доступные авто без пробелом и для каждого дня создал именованный диапазон (с помощью СМЕЩ, чтобы в конце не было пустых ячеек выпадающем списке).
Диапазоны каждого дня назвал д1, д2 ... д31.
И теперь когда пытаюсь привязать эти диапазоны к Дате с помощью ДВССЫЛ, то выпадает ошибка в источнике (как я понимаю, т.к. ДВССЫЛ и СМЕЩ не совместимы?)
Что можно еще придумать, как можно сразу в источник прописать формулу со СМЕЩ, чтобы при выборе дня месяца - сразу выбирался перечень доступных машин этого дня.
Без СМЕЩ всё получается, но тогда пустые ячейки в перечне.
Буду очень благодарен за помощь. Файл во вложении.
К сообщению приложен файл: 2273285.xlsx(62Kb)


Сообщение отредактировал Esperanto - Среда, 14.06.2017, 11:20
 
Ответить
СообщениеЗдравствуйте. Помогите с проблемой.
Необходимо, чтобы когда менеджер выбирает день месяца - в соседнем столбце в выпадающем списке были доступны только те машины, которые отметили как "доступные" в этот день (и еще надо, чтобы пустых строк не было в выпадающем перечне)

Для этого сделал перечень авто и возможность, чтобы человек вручную по дням отмечал, какие из них будут доступны (т.к. надо чтобы можно было на сегодня и например на 3 дня вперед отметить доступные авто). После этого сделал еще одну таблицу в разрезе дней, куда переносятся доступные авто без пробелом и для каждого дня создал именованный диапазон (с помощью СМЕЩ, чтобы в конце не было пустых ячеек выпадающем списке).
Диапазоны каждого дня назвал д1, д2 ... д31.
И теперь когда пытаюсь привязать эти диапазоны к Дате с помощью ДВССЫЛ, то выпадает ошибка в источнике (как я понимаю, т.к. ДВССЫЛ и СМЕЩ не совместимы?)
Что можно еще придумать, как можно сразу в источник прописать формулу со СМЕЩ, чтобы при выборе дня месяца - сразу выбирался перечень доступных машин этого дня.
Без СМЕЩ всё получается, но тогда пустые ячейки в перечне.
Буду очень благодарен за помощь. Файл во вложении.

Автор - Esperanto
Дата добавления - 14.06.2017 в 10:33
китин Дата: Среда, 14.06.2017, 10:48 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4214
Репутация: 659 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
файл будет?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениефайл будет?

Автор - китин
Дата добавления - 14.06.2017 в 10:48
Esperanto Дата: Среда, 14.06.2017, 11:21 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
файл будет?

Виноват, не прикрепился сразу. Уже добавил.
 
Ответить
Сообщение
файл будет?

Виноват, не прикрепился сразу. Уже добавил.

Автор - Esperanto
Дата добавления - 14.06.2017 в 11:21
_Boroda_ Дата: Среда, 14.06.2017, 11:54 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10842
Репутация: 4479 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вам достаточно только одного имени. Все эти д1, д2, ... вообще не нужны. И ДВССЫЛ при создании динамических вып. списков использовать, с моей точки зрения, крайне нежелательно.
Для понятности я не стал все засувывать в одно имя, сделал еще промежуточное имя "Диап" с формулой
Код
=ИНДЕКС(машины!$BV$3:$CZ$24;;ДЕНЬ(Заявки!$A8))
и основное имя для списка "Трансп"
Код
=ИНДЕКС(Диап;1):ИНДЕКС(Диап;СЧЁТЗ(Диап)-СЧЁТ(Диап))

Кстати, формулу для BV3 и дальше сделал Вам протягиваемой вправо
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$3:$A$24;ПОИСКПОЗ($BU3;ИНДЕКС($I$3:$BR$24;;BV$2*2);));)
К сообщению приложен файл: 2273285_1.xlsx(57Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВам достаточно только одного имени. Все эти д1, д2, ... вообще не нужны. И ДВССЫЛ при создании динамических вып. списков использовать, с моей точки зрения, крайне нежелательно.
Для понятности я не стал все засувывать в одно имя, сделал еще промежуточное имя "Диап" с формулой
Код
=ИНДЕКС(машины!$BV$3:$CZ$24;;ДЕНЬ(Заявки!$A8))
и основное имя для списка "Трансп"
Код
=ИНДЕКС(Диап;1):ИНДЕКС(Диап;СЧЁТЗ(Диап)-СЧЁТ(Диап))

Кстати, формулу для BV3 и дальше сделал Вам протягиваемой вправо
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$3:$A$24;ПОИСКПОЗ($BU3;ИНДЕКС($I$3:$BR$24;;BV$2*2);));)

Автор - _Boroda_
Дата добавления - 14.06.2017 в 11:54
Esperanto Дата: Среда, 14.06.2017, 12:14 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Вам достаточно только одного имени. Все эти д1, д2, ... вообще не нужны.

Открыл откорректированный Вами файл. Если в ячейке I6 я выбираю уже не 01.06.17, а 02.06.17, то всё равно доступные машины выбираются из первого числа месяца (т.е. лист "машины" колонка BV, а должно меняться и выбираться машины из BW.
Подскажите, что нужно еще подкорректировать?
 
Ответить
Сообщение
Вам достаточно только одного имени. Все эти д1, д2, ... вообще не нужны.

Открыл откорректированный Вами файл. Если в ячейке I6 я выбираю уже не 01.06.17, а 02.06.17, то всё равно доступные машины выбираются из первого числа месяца (т.е. лист "машины" колонка BV, а должно меняться и выбираться машины из BW.
Подскажите, что нужно еще подкорректировать?

Автор - Esperanto
Дата добавления - 14.06.2017 в 12:14
китин Дата: Среда, 14.06.2017, 12:16 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4214
Репутация: 659 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а попробуйте вместо ваших многочисленных д одну формулу массива. в диспетчере имя ААААА
Код
=СМЕЩ(машины!$BV$3;;ПОИСКПОЗ(ДЕНЬ(Заявки!$I6);--Таблица2[#Заголовки];0)-1;ПОИСКПОЗ("";ИНДЕКС(Таблица2;;ПОИСКПОЗ(ДЕНЬ(Заявки!$I6);--Таблица2[#Заголовки];0));0)-1)
К сообщению приложен файл: _2273285.xlsx(61Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 14.06.2017, 12:16
 
Ответить
Сообщениеа попробуйте вместо ваших многочисленных д одну формулу массива. в диспетчере имя ААААА
Код
=СМЕЩ(машины!$BV$3;;ПОИСКПОЗ(ДЕНЬ(Заявки!$I6);--Таблица2[#Заголовки];0)-1;ПОИСКПОЗ("";ИНДЕКС(Таблица2;;ПОИСКПОЗ(ДЕНЬ(Заявки!$I6);--Таблица2[#Заголовки];0));0)-1)

Автор - китин
Дата добавления - 14.06.2017 в 12:16
_Boroda_ Дата: Среда, 14.06.2017, 12:17 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10842
Репутация: 4479 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А просто я сделал по дате в столбце А, а не в столбце I. Посмотрите первую формулу моего предыдущего поста, видите, там ссылка на А8?
Держите по I
К сообщению приложен файл: 2273285_2.xlsx(57Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА просто я сделал по дате в столбце А, а не в столбце I. Посмотрите первую формулу моего предыдущего поста, видите, там ссылка на А8?
Держите по I

Автор - _Boroda_
Дата добавления - 14.06.2017 в 12:17
Esperanto Дата: Среда, 14.06.2017, 12:32 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Держите по I

Спасибо огромное, очень помогли!!!
 
Ответить
Сообщение
Держите по I

Спасибо огромное, очень помогли!!!

Автор - Esperanto
Дата добавления - 14.06.2017 в 12:32
Michael_S Дата: Среда, 14.06.2017, 12:32 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1808
Репутация: 339 ±
Замечаний: 0% ±

Excel2016
Esperanto, надо сообщать, что тема обсуждается и на других форумах.
Кросс


ЯД: 41001136675053
WM: R389613894253
 
Ответить
СообщениеEsperanto, надо сообщать, что тема обсуждается и на других форумах.
Кросс

Автор - Michael_S
Дата добавления - 14.06.2017 в 12:32
Esperanto Дата: Среда, 14.06.2017, 12:37 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
надо сообщать, что тема обсуждается и на других форумах.

Прошу прощения, виноват!
 
Ответить
Сообщение
надо сообщать, что тема обсуждается и на других форумах.

Прошу прощения, виноват!

Автор - Esperanto
Дата добавления - 14.06.2017 в 12:37
Esperanto Дата: Среда, 14.06.2017, 13:59 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Для понятности я не стал все засувывать в одно имя, сделал еще промежуточное имя "Диап" с формулой

=ИНДЕКС(машины!$BV$3:$CZ$24;;ДЕНЬ(Заявки!$A8))

Подскажите еще, пожалуйста.
В формуле выше ДЕНЬ(Заявки!$A8), который задает номер столбца, какой-то динамический ??
Я смотрю, когда на листе меняю расположения курсора по строчкам, и цифра возле Заявки!$A меняется. Как это сделано?
 
Ответить
Сообщение
Для понятности я не стал все засувывать в одно имя, сделал еще промежуточное имя "Диап" с формулой

=ИНДЕКС(машины!$BV$3:$CZ$24;;ДЕНЬ(Заявки!$A8))

Подскажите еще, пожалуйста.
В формуле выше ДЕНЬ(Заявки!$A8), который задает номер столбца, какой-то динамический ??
Я смотрю, когда на листе меняю расположения курсора по строчкам, и цифра возле Заявки!$A меняется. Как это сделано?

Автор - Esperanto
Дата добавления - 14.06.2017 в 13:59
Esperanto Дата: Среда, 14.06.2017, 14:01 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Как это сделано?

Или просто один раз указываем активную ячейку и она потом будет меняться автоматически?
 
Ответить
Сообщение
Как это сделано?

Или просто один раз указываем активную ячейку и она потом будет меняться автоматически?

Автор - Esperanto
Дата добавления - 14.06.2017 в 14:01
_Boroda_ Дата: Среда, 14.06.2017, 14:08 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10842
Репутация: 4479 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
цифра возле Заявки!$A меняется. Как это сделано?

Очень просто - ссылка не такая Заявки!$A$8, а такая Заявки!$A8.
Только писать нужно эту формулу, находясь курсором именно в строке 8. Желательно в ячейке J8


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
цифра возле Заявки!$A меняется. Как это сделано?

Очень просто - ссылка не такая Заявки!$A$8, а такая Заявки!$A8.
Только писать нужно эту формулу, находясь курсором именно в строке 8. Желательно в ячейке J8

Автор - _Boroda_
Дата добавления - 14.06.2017 в 14:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выпадающий список через ДВССЫЛ и СМЕЩ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!