Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма без учета строк с нулевыми значениями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма без учета строк с нулевыми значениями (Формулы/Formulas)
Сумма без учета строк с нулевыми значениями
barina Дата: Четверг, 22.06.2017, 22:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Добрый вечер! Помогите, пожалуйста. Необходимо просуммировать данные по тем ТТ, которые отработали полностью два года (сопоставимые условия). Если ТТ несколько месяцев за 2-летний период не работала, данные по ней в сумму не попадают. Заранее спасибо!
К сообщению приложен файл: 9525296.xlsx(15Kb)
 
Ответить
СообщениеДобрый вечер! Помогите, пожалуйста. Необходимо просуммировать данные по тем ТТ, которые отработали полностью два года (сопоставимые условия). Если ТТ несколько месяцев за 2-летний период не работала, данные по ней в сумму не попадают. Заранее спасибо!

Автор - barina
Дата добавления - 22.06.2017 в 22:07
vikttur Дата: Четверг, 22.06.2017, 22:59 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2511
Репутация: 452 ±
Замечаний: 0% ±

Код
=СУММ(ЕСЛИ(МУМНОЖ(--($B$2:$Z$11>0);ТРАНСП($B$2:$Z$2)^0)=25;B2:B11))

Формула массива, вводится сочетанием Ctrl+Shift+Enter (формула должна обрамиться фигурными скобками).
 
Ответить
Сообщение
Код
=СУММ(ЕСЛИ(МУМНОЖ(--($B$2:$Z$11>0);ТРАНСП($B$2:$Z$2)^0)=25;B2:B11))

Формула массива, вводится сочетанием Ctrl+Shift+Enter (формула должна обрамиться фигурными скобками).

Автор - vikttur
Дата добавления - 22.06.2017 в 22:59
ZORRO2005 Дата: Пятница, 23.06.2017, 00:28 | Сообщение № 3
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 147 ±
Замечаний: 0% ±

Excel2010
vikttur, формула выдаст ошибку, если TT1 не работала несколько месяцев.
Подправлю:
Код
=СУММ(ЕСЛИ(МУМНОЖ(--($B$2:$Z$11>0);ТРАНСП(СТОЛБЕЦ(B:Z)^0))=25;B2:B11))

еще вариант
Код
=СУММ(ЕСЛИ(ЧАСТОТА(ЕСЛИ($B$2:$Z$11=0;СТРОКА(2:11));СТРОКА(2:10));;B2:B11))
 
Ответить
Сообщениеvikttur, формула выдаст ошибку, если TT1 не работала несколько месяцев.
Подправлю:
Код
=СУММ(ЕСЛИ(МУМНОЖ(--($B$2:$Z$11>0);ТРАНСП(СТОЛБЕЦ(B:Z)^0))=25;B2:B11))

еще вариант
Код
=СУММ(ЕСЛИ(ЧАСТОТА(ЕСЛИ($B$2:$Z$11=0;СТРОКА(2:11));СТРОКА(2:10));;B2:B11))

Автор - ZORRO2005
Дата добавления - 23.06.2017 в 00:28
vikttur Дата: Пятница, 23.06.2017, 10:20 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2511
Репутация: 452 ±
Замечаний: 0% ±

Это мои незавершенные метания :)
Сначала ссылка на строку 1, но там есть текст, перешел на вторую - там нули. Поменяю... так и осталось.
 
Ответить
СообщениеЭто мои незавершенные метания :)
Сначала ссылка на строку 1, но там есть текст, перешел на вторую - там нули. Поменяю... так и осталось.

Автор - vikttur
Дата добавления - 23.06.2017 в 10:20
Nic70y Дата: Пятница, 23.06.2017, 10:49 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4185
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
вариант с тотальным мухлежом
a2
Код
="ТТ "&СТРОКА(A1)&ЕСЛИ(ЕНД(ПОИСКПОЗ(0;B2:Z2;));СИМВОЛ(13);"")
сумма
Код
=СУММЕСЛИ($A2:$A11;"*"&СИМВОЛ(13);B2:B11)
К сообщению приложен файл: 7308595.xlsx(15Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениевариант с тотальным мухлежом
a2
Код
="ТТ "&СТРОКА(A1)&ЕСЛИ(ЕНД(ПОИСКПОЗ(0;B2:Z2;));СИМВОЛ(13);"")
сумма
Код
=СУММЕСЛИ($A2:$A11;"*"&СИМВОЛ(13);B2:B11)

Автор - Nic70y
Дата добавления - 23.06.2017 в 10:49
zs Дата: Пятница, 23.06.2017, 11:58 | Сообщение № 6
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
вариант с дополнительным столбцом В:
Код
=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(0;C2:T2;0));"+";"-")

формула:
Код
=СУММЕСЛИ($B$2:$B$11;"+";C2:C11)
 
Ответить
Сообщениевариант с дополнительным столбцом В:
Код
=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(0;C2:T2;0));"+";"-")

формула:
Код
=СУММЕСЛИ($B$2:$B$11;"+";C2:C11)

Автор - zs
Дата добавления - 23.06.2017 в 11:58
barina Дата: Пятница, 23.06.2017, 12:58 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Всем спасибо))) vikttur, подскажите, пожалуйста, 25 - это просто число столбцов? Смещение учитывается?
 
Ответить
СообщениеВсем спасибо))) vikttur, подскажите, пожалуйста, 25 - это просто число столбцов? Смещение учитывается?

Автор - barina
Дата добавления - 23.06.2017 в 12:58
vikttur Дата: Пятница, 23.06.2017, 13:07 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2511
Репутация: 452 ±
Замечаний: 0% ±

Да, это число столбцов в диапазоне
 
Ответить
СообщениеДа, это число столбцов в диапазоне

Автор - vikttur
Дата добавления - 23.06.2017 в 13:07
barina Дата: Понедельник, 26.06.2017, 18:03 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
vikttur, еще раз огромное спасибо! Подскажите, как можно исключить месяц до закрытия и месяц после открытия ТТ, т.к. эти месяца отработаны не полностью?
 
Ответить
Сообщениеvikttur, еще раз огромное спасибо! Подскажите, как можно исключить месяц до закрытия и месяц после открытия ТТ, т.к. эти месяца отработаны не полностью?

Автор - barina
Дата добавления - 26.06.2017 в 18:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма без учета строк с нулевыми значениями (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!