Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчёт таблицы результатов через функцию ЕПУСТО (либо ЕСЛИ). - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт таблицы результатов через функцию ЕПУСТО (либо ЕСЛИ). (Формулы/Formulas)
Расчёт таблицы результатов через функцию ЕПУСТО (либо ЕСЛИ).
Prosto_Lena Дата: Суббота, 24.06.2017, 01:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, уважаемые! В приведённой в примере таблице нужна формула для автоматического подсчёта суммы очков, набранных участниками автогоночных соревнований, в зависимости от того, проводился ли собственно основной заезд (гонка), или проводился только лишь один тренировочный заезд (квалификация). Я подозреваю, что делается это через функцию ЕПУСТО (или просто ЕСЛИ), но я, к сожалению, в экселе новичок, поэтому и обращаюсь за помощью. Более наглядное и подробное описание проблемы дано непосредственно в прикреплённом файле. Надеюсь на вашу помощь :'(
К сообщению приложен файл: 9154144.xlsx(22Kb)
 
Ответить
СообщениеЗдравствуйте, уважаемые! В приведённой в примере таблице нужна формула для автоматического подсчёта суммы очков, набранных участниками автогоночных соревнований, в зависимости от того, проводился ли собственно основной заезд (гонка), или проводился только лишь один тренировочный заезд (квалификация). Я подозреваю, что делается это через функцию ЕПУСТО (или просто ЕСЛИ), но я, к сожалению, в экселе новичок, поэтому и обращаюсь за помощью. Более наглядное и подробное описание проблемы дано непосредственно в прикреплённом файле. Надеюсь на вашу помощь :'(

Автор - Prosto_Lena
Дата добавления - 24.06.2017 в 01:06
zs Дата: Суббота, 24.06.2017, 08:48 | Сообщение № 2
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
для подсчёта суммы очков, набранных участниками автогоночных соревнований

не понятно как ведется подсчёт очков, поэтому ТОЛЬКО ФОРМУЛА УСЛОВИЯ, в формуле соответственно используются 1 и 2
Код
=ЕСЛИ(СУММ(--ЕПУСТО('РЕЗУЛЬТАТЫ СОРЕВНОВАНИЙ'!B1:B22))<22;1;2)

формула массива


Сообщение отредактировал zs - Суббота, 24.06.2017, 15:03
 
Ответить
Сообщение
для подсчёта суммы очков, набранных участниками автогоночных соревнований

не понятно как ведется подсчёт очков, поэтому ТОЛЬКО ФОРМУЛА УСЛОВИЯ, в формуле соответственно используются 1 и 2
Код
=ЕСЛИ(СУММ(--ЕПУСТО('РЕЗУЛЬТАТЫ СОРЕВНОВАНИЙ'!B1:B22))<22;1;2)

формула массива

Автор - zs
Дата добавления - 24.06.2017 в 08:48
vikttur Дата: Суббота, 24.06.2017, 10:21 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2511
Репутация: 452 ±
Замечаний: 0% ±

Объяснять задачу нужно не формулами (возможно, ошибочными), а самой завдачей. Забудьте об Excel, сядьте за баранку, проникнитесь соревнованиями и объясните суть )
 
Ответить
СообщениеОбъяснять задачу нужно не формулами (возможно, ошибочными), а самой завдачей. Забудьте об Excel, сядьте за баранку, проникнитесь соревнованиями и объясните суть )

Автор - vikttur
Дата добавления - 24.06.2017 в 10:21
zs Дата: Суббота, 24.06.2017, 11:35 | Сообщение № 4
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
сядьте за баранку, проникнитесь соревнованиями и объясните суть )

спасибо за совет


Сообщение отредактировал zs - Суббота, 24.06.2017, 11:59
 
Ответить
Сообщение
сядьте за баранку, проникнитесь соревнованиями и объясните суть )

спасибо за совет

Автор - zs
Дата добавления - 24.06.2017 в 11:35
Pelena Дата: Суббота, 24.06.2017, 14:40 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11756
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Формула массива
Код
=СУММ((((МУМНОЖ(ТРАНСП(СТРОКА('РЕЗУЛЬТАТЫ СОРЕВНОВАНИЙ'!$A$24:$A$45)^1);--'РЕЗУЛЬТАТЫ СОРЕВНОВАНИЙ'!$B$24:$F$45)=0)*'РЕЗУЛЬТАТЫ СОРЕВНОВАНИЙ'!$B$1:$F$22)=A2)*'ОЧКОВАЯ СИСТЕМА'!$C$2:$C$23+('РЕЗУЛЬТАТЫ СОРЕВНОВАНИЙ'!$B$24:$F$45=A2)*'ОЧКОВАЯ СИСТЕМА'!$B$2:$B$23)
К сообщению приложен файл: 0486743.xlsx(23Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива
Код
=СУММ((((МУМНОЖ(ТРАНСП(СТРОКА('РЕЗУЛЬТАТЫ СОРЕВНОВАНИЙ'!$A$24:$A$45)^1);--'РЕЗУЛЬТАТЫ СОРЕВНОВАНИЙ'!$B$24:$F$45)=0)*'РЕЗУЛЬТАТЫ СОРЕВНОВАНИЙ'!$B$1:$F$22)=A2)*'ОЧКОВАЯ СИСТЕМА'!$C$2:$C$23+('РЕЗУЛЬТАТЫ СОРЕВНОВАНИЙ'!$B$24:$F$45=A2)*'ОЧКОВАЯ СИСТЕМА'!$B$2:$B$23)

Автор - Pelena
Дата добавления - 24.06.2017 в 14:40
Prosto_Lena Дата: Суббота, 24.06.2017, 16:05 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Большое спасибо, Pelena! Я вам так благодарна!!!
hands
 
Ответить
СообщениеБольшое спасибо, Pelena! Я вам так благодарна!!!
hands

Автор - Prosto_Lena
Дата добавления - 24.06.2017 в 16:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт таблицы результатов через функцию ЕПУСТО (либо ЕСЛИ). (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!