Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Присвоить определенный бал значению, попавшему в интервал - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоить определенный бал значению, попавшему в интервал (Формулы/Formulas)
Присвоить определенный бал значению, попавшему в интервал
Начинающий Дата: Среда, 28.06.2017, 18:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго всем времени суток!

Подскажите, как сделать, чтобы значению, попадающему в один из интервалов, присваивался соответствующий балл.
т.е., например, если 0,1<=х<0,2; х=12 и т.д.
Как это сделать не используя формулу ЕСЛИ?

Заранее благодарен!
К сообщению приложен файл: 5574899.xlsx(9Kb)
 
Ответить
СообщениеДоброго всем времени суток!

Подскажите, как сделать, чтобы значению, попадающему в один из интервалов, присваивался соответствующий балл.
т.е., например, если 0,1<=х<0,2; х=12 и т.д.
Как это сделать не используя формулу ЕСЛИ?

Заранее благодарен!

Автор - Начинающий
Дата добавления - 28.06.2017 в 18:33
buchlotnik Дата: Среда, 28.06.2017, 18:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3332
Репутация: 887 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Код
=ПРОСМОТР(F5;$B$5:$B$14;$D$5:$D$14)
Код
=ВПР(F5;$B$5:$D$14;3;1)
К сообщению приложен файл: 4962506.xlsx(10Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 28.06.2017, 18:36
 
Ответить
Сообщение
Код
=ПРОСМОТР(F5;$B$5:$B$14;$D$5:$D$14)
Код
=ВПР(F5;$B$5:$D$14;3;1)

Автор - buchlotnik
Дата добавления - 28.06.2017 в 18:35
Начинающий Дата: Среда, 28.06.2017, 18:48 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, спасибо!
обалдеть как быстро!

Быть может, кто-то из знатоков захочет предложить иные варианты? (видел в др. темах такое бывает)
Буду признателен! Все пойдет на развитие.
 
Ответить
Сообщениеbuchlotnik, спасибо!
обалдеть как быстро!

Быть может, кто-то из знатоков захочет предложить иные варианты? (видел в др. темах такое бывает)
Буду признателен! Все пойдет на развитие.

Автор - Начинающий
Дата добавления - 28.06.2017 в 18:48
buchlotnik Дата: Среда, 28.06.2017, 19:08 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3332
Репутация: 887 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
иные варианты
ну ещё
Код
=ИНДЕКС($D$5:$D$14;ПОИСКПОЗ(F5;$B$5:$B$14;1))
а под конкретный вариант можно и так
Код
=ИНДЕКС($D$5:$D$14;МИН(F5*10+1;10))
Код
=ВЫБОР(МИН(ЦЕЛОЕ(H5*10)+1;10);0;12;23;34;45;56;67;78;89;100)
ну и ЕСЛИ() обижать не надо
Код
=ЕСЛИ(H5<0,2;ЦЕЛОЕ(H5*10)*12;МИН(100;12+(ЦЕЛОЕ(H5*10)-1)*11))
К сообщению приложен файл: 4962506-1-.xlsx(11Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 28.06.2017, 19:23
 
Ответить
Сообщение
Цитата
иные варианты
ну ещё
Код
=ИНДЕКС($D$5:$D$14;ПОИСКПОЗ(F5;$B$5:$B$14;1))
а под конкретный вариант можно и так
Код
=ИНДЕКС($D$5:$D$14;МИН(F5*10+1;10))
Код
=ВЫБОР(МИН(ЦЕЛОЕ(H5*10)+1;10);0;12;23;34;45;56;67;78;89;100)
ну и ЕСЛИ() обижать не надо
Код
=ЕСЛИ(H5<0,2;ЦЕЛОЕ(H5*10)*12;МИН(100;12+(ЦЕЛОЕ(H5*10)-1)*11))

Автор - buchlotnik
Дата добавления - 28.06.2017 в 19:08
_Boroda_ Дата: Среда, 28.06.2017, 21:25 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11666
Репутация: 4833 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И еще
Код
=МИН(100;ОТБР(H5/,1)*11+(ОТБР(H5/,1)>0))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИ еще
Код
=МИН(100;ОТБР(H5/,1)*11+(ОТБР(H5/,1)>0))

Автор - _Boroda_
Дата добавления - 28.06.2017 в 21:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоить определенный бал значению, попавшему в интервал (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!