Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Матрешка из двухуровневых списков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Матрешка из двухуровневых списков (Формулы/Formulas)
Матрешка из двухуровневых списков
heaven33rus Дата: Вторник, 04.07.2017, 14:58 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Всем привет.
Делаю одну штуку, которая в последствии должна стать калькулятором, но столкнулся с рядом проблем связанных со списками (выпадающие списки строка 28-32 на листе 1 файла с примером)

1. Раскрывающийся список в строке 32 показывает только одно значение, хотя должен забирать несколько с листа "Типобъекта". Как исправить?
2. Как сделать так, чтоб при отсутствии выбранного значения в расположенном выше выпадающем списке, в нижних выпадающих списке также было пусто?

P.S. Там замах на 3 организации сделан, на это можно не обращать внимания, надо сделать для организации 1 только.
К сообщению приложен файл: 7875282.xlsx(54Kb)
 
Ответить
СообщениеВсем привет.
Делаю одну штуку, которая в последствии должна стать калькулятором, но столкнулся с рядом проблем связанных со списками (выпадающие списки строка 28-32 на листе 1 файла с примером)

1. Раскрывающийся список в строке 32 показывает только одно значение, хотя должен забирать несколько с листа "Типобъекта". Как исправить?
2. Как сделать так, чтоб при отсутствии выбранного значения в расположенном выше выпадающем списке, в нижних выпадающих списке также было пусто?

P.S. Там замах на 3 организации сделан, на это можно не обращать внимания, надо сделать для организации 1 только.

Автор - heaven33rus
Дата добавления - 04.07.2017 в 14:58
_Boroda_ Дата: Вторник, 04.07.2017, 15:06 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11659
Репутация: 4831 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В Выбранном объекте вместо последнего 140 напишите 1
Код
=ИНДЕКС(Типобъекта!$B$2:$W$140;;ПОИСКПОЗ(Лист1!$A$31;Типобъекта!$B$1:$W$1;))
К сообщению приложен файл: 7875282_1.xlsx(54Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ Выбранном объекте вместо последнего 140 напишите 1
Код
=ИНДЕКС(Типобъекта!$B$2:$W$140;;ПОИСКПОЗ(Лист1!$A$31;Типобъекта!$B$1:$W$1;))

Автор - _Boroda_
Дата добавления - 04.07.2017 в 15:06
heaven33rus Дата: Вторник, 04.07.2017, 15:09 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Спасибо!!! помогло :-)
 
Ответить
СообщениеСпасибо!!! помогло :-)

Автор - heaven33rus
Дата добавления - 04.07.2017 в 15:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Матрешка из двухуровневых списков (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!