Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/В таблице расставить 1 .в зависимости от данных. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В таблице расставить 1 .в зависимости от данных. (Формулы/Formulas)
В таблице расставить 1 .в зависимости от данных.
Totalmen Дата: Воскресенье, 09.07.2017, 18:56 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
У меня есть таблица в которую я копирую данные по вертикали пример 32,2(А:B), 32,1(B:B) всё что не в скобках мне не важно и эти цифры меняются .а вот что в скобках ,мне совпадения нужно посчитать,для этого нужно поставить 1 в свою ячейку в зависимости от горизонтальных ячеек.В прикреплённом файле 1 я расставлял в ручную.
К сообщению приложен файл: 4663948.xlsx(10Kb)
 
Ответить
СообщениеУ меня есть таблица в которую я копирую данные по вертикали пример 32,2(А:B), 32,1(B:B) всё что не в скобках мне не важно и эти цифры меняются .а вот что в скобках ,мне совпадения нужно посчитать,для этого нужно поставить 1 в свою ячейку в зависимости от горизонтальных ячеек.В прикреплённом файле 1 я расставлял в ручную.

Автор - Totalmen
Дата добавления - 09.07.2017 в 18:56
n0leg68 Дата: Воскресенье, 09.07.2017, 19:19 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 74
Репутация: 9 ±
Замечаний: 0% ±

Excel 2013
Проверяй :)

Код
=ЕСЛИ((ПСТР($A5;1+ПОИСК("(";$A5);ПОИСК(")";$A5)-ПОИСК("(";$A5)-1))=B$4;1;"")
К сообщению приложен файл: 4815830.xlsx(11Kb)
 
Ответить
СообщениеПроверяй :)

Код
=ЕСЛИ((ПСТР($A5;1+ПОИСК("(";$A5);ПОИСК(")";$A5)-ПОИСК("(";$A5)-1))=B$4;1;"")

Автор - n0leg68
Дата добавления - 09.07.2017 в 19:19
Che79 Дата: Воскресенье, 09.07.2017, 19:33 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 464
Репутация: 72 ±
Замечаний: 0% ±

Excel 2010 RUS
Totalmen, здравствуйте. Такой вариант (серые ячейки в файле)
Код
=--СОВПАД(Q$4;ПСТР($A5;ПОИСК("(";$A5)+1;3))
+ формат ячеек 0;;;@. Только, сдается мне, либо Вы неверно вручную единички поставили, либо наши с n0leg68 варианты, мягко говоря, не совсем верны %)
К сообщению приложен файл: 4663949.xlsx(14Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеTotalmen, здравствуйте. Такой вариант (серые ячейки в файле)
Код
=--СОВПАД(Q$4;ПСТР($A5;ПОИСК("(";$A5)+1;3))
+ формат ячеек 0;;;@. Только, сдается мне, либо Вы неверно вручную единички поставили, либо наши с n0leg68 варианты, мягко говоря, не совсем верны %)

Автор - Che79
Дата добавления - 09.07.2017 в 19:33
Totalmen Дата: Воскресенье, 09.07.2017, 19:55 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Да я сам не заметил,что в ручную поставил не правильно,большое спасибо.
 
Ответить
СообщениеДа я сам не заметил,что в ручную поставил не правильно,большое спасибо.

Автор - Totalmen
Дата добавления - 09.07.2017 в 19:55
_Boroda_ Дата: Воскресенье, 09.07.2017, 21:01 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11315
Репутация: 4675 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Totalmen, в ячейках A5, B4, C4, D4 поменяйте русскую А на латинскую
И еще вариант формулы
Код
=--ЕЧИСЛО(ПОИСК(B$4;$A5))
К сообщению приложен файл: 4663948_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеTotalmen, в ячейках A5, B4, C4, D4 поменяйте русскую А на латинскую
И еще вариант формулы
Код
=--ЕЧИСЛО(ПОИСК(B$4;$A5))

Автор - _Boroda_
Дата добавления - 09.07.2017 в 21:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В таблице расставить 1 .в зависимости от данных. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!