Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ввод дат по столбцам периода - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ввод дат по столбцам периода (Формулы/Formulas)
Ввод дат по столбцам периода
Saff Дата: Вторник, 11.07.2017, 12:12 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 1 ±
Замечаний: 20% ±

Добрый день, Уважаемые!

Требуется найти через Индекс(Таблица А;Поискпоз();Поискпоз()) в таблице А и перенести даты в соответствующий столбец в таблице Б
К сообщению приложен файл: 0515147.xlsx(11Kb)
 
Ответить
СообщениеДобрый день, Уважаемые!

Требуется найти через Индекс(Таблица А;Поискпоз();Поискпоз()) в таблице А и перенести даты в соответствующий столбец в таблице Б

Автор - Saff
Дата добавления - 11.07.2017 в 12:12
_Boroda_ Дата: Вторник, 11.07.2017, 12:27 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если Вы так настаиваете на ИНДЕКС-ПОИСКПОЗ, то держите
Код
=ЕСЛИОШИБКА(ИНДЕКС($S$5:$S$8;ЕСЛИ(B$4;ПОИСКПОЗ($A5&B$4&B$1;$R$5:$R$8&ТЕКСТ($S$5:$S$8;"МГГГ"););ПОИСКПОЗ($A5&B$2;$R$5:$R$8&ТЕКСТ($S$5:$S$8;"ГГГ");)));"")

Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Еще вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($S$5:$S$8;ПОИСКПОЗ($A5&B$2&B$1;$R$5:$R$8&ТЕКСТ($S$5:$S$8;ЕСЛИ(B$4;"ММММ";"")&"ГГГ");));"")
К сообщению приложен файл: 0515147_1.xlsx(13Kb) · 0515147_2.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли Вы так настаиваете на ИНДЕКС-ПОИСКПОЗ, то держите
Код
=ЕСЛИОШИБКА(ИНДЕКС($S$5:$S$8;ЕСЛИ(B$4;ПОИСКПОЗ($A5&B$4&B$1;$R$5:$R$8&ТЕКСТ($S$5:$S$8;"МГГГ"););ПОИСКПОЗ($A5&B$2;$R$5:$R$8&ТЕКСТ($S$5:$S$8;"ГГГ");)));"")

Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Еще вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($S$5:$S$8;ПОИСКПОЗ($A5&B$2&B$1;$R$5:$R$8&ТЕКСТ($S$5:$S$8;ЕСЛИ(B$4;"ММММ";"")&"ГГГ");));"")

Автор - _Boroda_
Дата добавления - 11.07.2017 в 12:27
Saff Дата: Вторник, 11.07.2017, 13:43 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 1 ±
Замечаний: 20% ±

Спасибо ОГРОМНОЕ!!!! скинул на wmr ) для настроения ;)

люди тут Золотые!!!


Сообщение отредактировал Saff - Вторник, 11.07.2017, 14:40
 
Ответить
СообщениеСпасибо ОГРОМНОЕ!!!! скинул на wmr ) для настроения ;)

люди тут Золотые!!!

Автор - Saff
Дата добавления - 11.07.2017 в 13:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ввод дат по столбцам периода (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!