Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нумерация договоров в зависимости от его типа. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация договоров в зависимости от его типа. (Формулы/Formulas)
Нумерация договоров в зависимости от его типа.
pianeer91 Дата: Четверг, 13.07.2017, 13:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Добрый день!
Требуется помощь.
У меня в файле заносятся данные о договоре. Договоры есть трех типов (Д-0001, Т-0001 и С-0001)
У каждой буквы своя личная нумерация.
Требуется, чтобы в столбце D при новой операции создавался новый номер, который отличался от предыдущего
на одну цифру больше в зависимости от типа договора столбец С.
Сейчас я это делаю в ручную, но хочется автоматизации данного процесса.
Спасибо.
К сообщению приложен файл: 5512146.xlsx(9Kb)


Сообщение отредактировал pianeer91 - Четверг, 13.07.2017, 13:03
 
Ответить
СообщениеДобрый день!
Требуется помощь.
У меня в файле заносятся данные о договоре. Договоры есть трех типов (Д-0001, Т-0001 и С-0001)
У каждой буквы своя личная нумерация.
Требуется, чтобы в столбце D при новой операции создавался новый номер, который отличался от предыдущего
на одну цифру больше в зависимости от типа договора столбец С.
Сейчас я это делаю в ручную, но хочется автоматизации данного процесса.
Спасибо.

Автор - pianeer91
Дата добавления - 13.07.2017 в 13:03
Nic70y Дата: Четверг, 13.07.2017, 13:21 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4022
Репутация: 855 ±
Замечаний: 0% ±

Excel 2013
Код
="-"&ПРАВБ("000"&СЧЁТЕСЛИ(C$1:C1;C1);4)
К сообщению приложен файл: 5794590.xlsx(9Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 13.07.2017, 13:21
 
Ответить
Сообщение
Код
="-"&ПРАВБ("000"&СЧЁТЕСЛИ(C$1:C1;C1);4)

Автор - Nic70y
Дата добавления - 13.07.2017 в 13:21
_Boroda_ Дата: Четверг, 13.07.2017, 13:26 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10842
Репутация: 4479 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ТЕКСТ(СЧЁТЕСЛИ(C$1:C1;C1);"-0000")
К сообщению приложен файл: 5512146_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ТЕКСТ(СЧЁТЕСЛИ(C$1:C1;C1);"-0000")

Автор - _Boroda_
Дата добавления - 13.07.2017 в 13:26
Udik Дата: Четверг, 13.07.2017, 13:29 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1503
Репутация: 184 ±
Замечаний: 0% ±

Excel 2016 х 64
ы, у меня массивка
Код

{=ТЕКСТ(МАКС(-ЗНАЧЕН($D$1:D6)*($C$1:C6=C7)+1);"-0000")}
К сообщению приложен файл: 2902985.xlsx(10Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениеы, у меня массивка
Код

{=ТЕКСТ(МАКС(-ЗНАЧЕН($D$1:D6)*($C$1:C6=C7)+1);"-0000")}

Автор - Udik
Дата добавления - 13.07.2017 в 13:29
pabchek Дата: Четверг, 13.07.2017, 15:21 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 725
Репутация: 162 ±
Замечаний: 0% ±

Excel 2007
Можно и мой вариант? :)
Код
=ЕСЛИОШИБКА(ПРОСМОТР(1;1/(C$1:C1=C2);D$1:D1);1)+1
К сообщению приложен файл: -000.xlsx(12Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеМожно и мой вариант? :)
Код
=ЕСЛИОШИБКА(ПРОСМОТР(1;1/(C$1:C1=C2);D$1:D1);1)+1

Автор - pabchek
Дата добавления - 13.07.2017 в 15:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация договоров в зависимости от его типа. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!