Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск данных по трем критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск данных по трем критериям (Формулы/Formulas)
поиск данных по трем критериям
qsc Дата: Пятница, 14.07.2017, 22:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Прощу помочь с формулой для поиска данных по трем критериям в таблице, по наименованию товара и дистрибутора исполюзую массив ИНДЕКС($A$1:$I$37;ПОИСКПОЗ($A43;$A$1:$A$37;0);ПОИСКПОЗ(B$42;$A$1:$I$1;0)), как применить к третьему критерию, оборот в шт или количество ТТ?
К сообщению приложен файл: 1157940.xlsx(13Kb)
 
Ответить
СообщениеПрощу помочь с формулой для поиска данных по трем критериям в таблице, по наименованию товара и дистрибутора исполюзую массив ИНДЕКС($A$1:$I$37;ПОИСКПОЗ($A43;$A$1:$A$37;0);ПОИСКПОЗ(B$42;$A$1:$I$1;0)), как применить к третьему критерию, оборот в шт или количество ТТ?

Автор - qsc
Дата добавления - 14.07.2017 в 22:31
gling Дата: Пятница, 14.07.2017, 22:39 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1621
Репутация: 394 ±
Замечаний: 0% ±

2010
Не понятно чего и куда выводить, где формула в файле, которую используете, в каком виде должен быть результат?


Сообщение отредактировал gling - Пятница, 14.07.2017, 22:39
 
Ответить
СообщениеНе понятно чего и куда выводить, где формула в файле, которую используете, в каком виде должен быть результат?

Автор - gling
Дата добавления - 14.07.2017 в 22:39
AndreTM Дата: Пятница, 14.07.2017, 22:41 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1762
Репутация: 496 ±
Замечаний: 0% ±

2003 & 2010
Прибавляйте во второму ПОИСКПОЗ() значение 0 или 1 в зависимости от значения третьего параметра:
Код
... +ЕСЛИ(ячейкаТретьегоУсловия="Оборот в штуках";1;0)


P.S. а, увидел далее...
Просто в таблице2 используйте свою формулу (добавляем 0), а в таблице3 - эту же формулу, но с добавлением 1
Код
=ИНДЕКС($A$1:$I$37;ПОИСКПОЗ($A54;$A$1:$A$37;0);ПОИСКПОЗ(B$53;$A$1:$I$1;0)+1)


Skype: andre.tm.007
Donate: Qiwi: 9517375010


Сообщение отредактировал AndreTM - Пятница, 14.07.2017, 22:45
 
Ответить
СообщениеПрибавляйте во второму ПОИСКПОЗ() значение 0 или 1 в зависимости от значения третьего параметра:
Код
... +ЕСЛИ(ячейкаТретьегоУсловия="Оборот в штуках";1;0)


P.S. а, увидел далее...
Просто в таблице2 используйте свою формулу (добавляем 0), а в таблице3 - эту же формулу, но с добавлением 1
Код
=ИНДЕКС($A$1:$I$37;ПОИСКПОЗ($A54;$A$1:$A$37;0);ПОИСКПОЗ(B$53;$A$1:$I$1;0)+1)

Автор - AndreTM
Дата добавления - 14.07.2017 в 22:41
qsc Дата: Пятница, 14.07.2017, 22:48 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
gling, нужно их первой таблицы во вторую и третью перенести данные по трем критериям, два подтягиваю, а третий не знаю как. ячейка L3-пример формулы
К сообщению приложен файл: 1157940-1-.xlsx(13Kb)
 
Ответить
Сообщениеgling, нужно их первой таблицы во вторую и третью перенести данные по трем критериям, два подтягиваю, а третий не знаю как. ячейка L3-пример формулы

Автор - qsc
Дата добавления - 14.07.2017 в 22:48
qsc Дата: Пятница, 14.07.2017, 22:51 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
большое спасибо,AndreTM)!
 
Ответить
Сообщениебольшое спасибо,AndreTM)!

Автор - qsc
Дата добавления - 14.07.2017 в 22:51
gling Дата: Пятница, 14.07.2017, 23:09 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1621
Репутация: 394 ±
Замечаний: 0% ±

2010
Оказывается нужно было просто прокрутить данные вниз.
Еще вариант для ТТ
Код
=ИНДЕКС(($A$1:$I$37;$B$1:$J$37);ПОИСКПОЗ($K3;$A$1:$A$37;0);ПОИСКПОЗ(L$2;$A$1:$I$1;0);1)
Для Оборот в штуках
Код
=ИНДЕКС(($A$1:$I$37;$B$1:$J$37);ПОИСКПОЗ($K3;$A$1:$A$37;0);ПОИСКПОЗ(L$2;$A$1:$I$1;0);2)
 
Ответить
СообщениеОказывается нужно было просто прокрутить данные вниз.
Еще вариант для ТТ
Код
=ИНДЕКС(($A$1:$I$37;$B$1:$J$37);ПОИСКПОЗ($K3;$A$1:$A$37;0);ПОИСКПОЗ(L$2;$A$1:$I$1;0);1)
Для Оборот в штуках
Код
=ИНДЕКС(($A$1:$I$37;$B$1:$J$37);ПОИСКПОЗ($K3;$A$1:$A$37;0);ПОИСКПОЗ(L$2;$A$1:$I$1;0);2)

Автор - gling
Дата добавления - 14.07.2017 в 23:09
_Boroda_ Дата: Пятница, 14.07.2017, 23:25 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Люди, а ничего, что в первом посте формула без тегов, а?
qsc, исправьте. Последовательность: правка поста - выделbть формулу, нажать кнопку fx


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЛюди, а ничего, что в первом посте формула без тегов, а?
qsc, исправьте. Последовательность: правка поста - выделbть формулу, нажать кнопку fx

Автор - _Boroda_
Дата добавления - 14.07.2017 в 23:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск данных по трем критериям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!