Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование при выполнении условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование при выполнении условий (Формулы/Formulas)
Суммирование при выполнении условий
Antoshka1989 Дата: Понедельник, 17.07.2017, 12:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
Подскажите пожалуйста, как в формулу итогового расчета добавить условие, что при нулевм значении 1, 2 или 3 пункта - пункт 4 и 5 не прибавляется.
К сообщению приложен файл: 6533705.xls(40Kb)


Сообщение отредактировал Antoshka1989 - Понедельник, 17.07.2017, 13:24
 
Ответить
СообщениеПодскажите пожалуйста, как в формулу итогового расчета добавить условие, что при нулевм значении 1, 2 или 3 пункта - пункт 4 и 5 не прибавляется.

Автор - Antoshka1989
Дата добавления - 17.07.2017 в 12:30
китин Дата: Понедельник, 17.07.2017, 12:34 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4416
Репутация: 698 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Название ниАчём. а решение есть


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеНазвание ниАчём. а решение есть

Автор - китин
Дата добавления - 17.07.2017 в 12:34
sboy Дата: Понедельник, 17.07.2017, 12:56 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1105
Репутация: 277 ±
Замечаний: 0% ±

Excel 2010
[offtop]
ниАчём

С возвращением! :D
 
Ответить
Сообщение[offtop]
ниАчём

С возвращением! :D

Автор - sboy
Дата добавления - 17.07.2017 в 12:56
Antoshka1989 Дата: Понедельник, 17.07.2017, 12:57 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
подскажите пожалуйста. новичок в деле оформления, буду учиться
 
Ответить
Сообщениеподскажите пожалуйста. новичок в деле оформления, буду учиться

Автор - Antoshka1989
Дата добавления - 17.07.2017 в 12:57
sboy Дата: Понедельник, 17.07.2017, 13:00 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1105
Репутация: 277 ±
Замечаний: 0% ±

Excel 2010
Antoshka1989, что-то вроде "Суммирование при выполнении условий"
 
Ответить
СообщениеAntoshka1989, что-то вроде "Суммирование при выполнении условий"

Автор - sboy
Дата добавления - 17.07.2017 в 13:00
Antoshka1989 Дата: Понедельник, 17.07.2017, 13:09 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
понял
 
Ответить
Сообщениепонял

Автор - Antoshka1989
Дата добавления - 17.07.2017 в 13:09
Antoshka1989 Дата: Понедельник, 17.07.2017, 13:12 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
sboy, создать новую тему? или тут решение подскажете?
 
Ответить
Сообщениеsboy, создать новую тему? или тут решение подскажете?

Автор - Antoshka1989
Дата добавления - 17.07.2017 в 13:12
sboy Дата: Понедельник, 17.07.2017, 13:13 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1105
Репутация: 277 ±
Замечаний: 0% ±

Excel 2010
Antoshka1989, в первом своем сообщении, нажмите правка. Измените название темы
 
Ответить
СообщениеAntoshka1989, в первом своем сообщении, нажмите правка. Измените название темы

Автор - sboy
Дата добавления - 17.07.2017 в 13:13
Antoshka1989 Дата: Понедельник, 17.07.2017, 13:24 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
sboy, готово.
 
Ответить
Сообщениеsboy, готово.

Автор - Antoshka1989
Дата добавления - 17.07.2017 в 13:24
Che79 Дата: Понедельник, 17.07.2017, 13:29 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 599
Репутация: 108 ±
Замечаний: 0% ±

Excel 2007, 2013
Antoshka1989, здравствуйте.
так нужно?, формула массива в F28
Код
{=ЕСЛИ(ИЛИ(C28:E28=0);СУММ(C28:E28);СУММ(C28:E28;D31;D34))}


UPD добавил файл
К сообщению приложен файл: 6121965_1.xls(38Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 17.07.2017, 13:37
 
Ответить
СообщениеAntoshka1989, здравствуйте.
так нужно?, формула массива в F28
Код
{=ЕСЛИ(ИЛИ(C28:E28=0);СУММ(C28:E28);СУММ(C28:E28;D31;D34))}


UPD добавил файл

Автор - Che79
Дата добавления - 17.07.2017 в 13:29
sboy Дата: Понедельник, 17.07.2017, 13:29 | Сообщение № 11
Группа: Проверенные
Ранг: Старожил
Сообщений: 1105
Репутация: 277 ±
Замечаний: 0% ±

Excel 2010
Как-то так, проверяйте
Код
=СУММ(C28:E28)+(СУММПРОИЗВ(--(C28:E28>0))>2)*СУММ(D31;D34)
К сообщению приложен файл: 6121965.xls(40Kb)
 
Ответить
СообщениеКак-то так, проверяйте
Код
=СУММ(C28:E28)+(СУММПРОИЗВ(--(C28:E28>0))>2)*СУММ(D31;D34)

Автор - sboy
Дата добавления - 17.07.2017 в 13:29
Antoshka1989 Дата: Понедельник, 17.07.2017, 14:31 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
sboy, Che79, спасибо Вам огромное. Выручили.
 
Ответить
Сообщениеsboy, Che79, спасибо Вам огромное. Выручили.

Автор - Antoshka1989
Дата добавления - 17.07.2017 в 14:31
vikttur Дата: Понедельник, 17.07.2017, 15:39 | Сообщение № 13
Группа: Друзья
Ранг: Старожил
Сообщений: 2511
Репутация: 452 ±
Замечаний: 0% ±

СУММПРОИЗВ штука хорошая, но пересаливать не стоит.
Код
=СУММ(C28:E28;ЕСЛИ(СЧЁТЕСЛИ(C28:E28;0);;D31+D34))


Сообщение отредактировал vikttur - Понедельник, 17.07.2017, 15:40
 
Ответить
СообщениеСУММПРОИЗВ штука хорошая, но пересаливать не стоит.
Код
=СУММ(C28:E28;ЕСЛИ(СЧЁТЕСЛИ(C28:E28;0);;D31+D34))

Автор - vikttur
Дата добавления - 17.07.2017 в 15:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование при выполнении условий (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!