Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск и выбор непустых ячеек в ряд - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и выбор непустых ячеек в ряд (Формулы/Formulas)
Поиск и выбор непустых ячеек в ряд
Fireman1969 Дата: Понедельник, 17.07.2017, 18:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здраствуйте! Помогите пожалуйста. Есть два диапазона ячеек - текст и пустые ячейки. Как с помощью формулы(желательно) выбрать непустые ячейки. Поиск идет от A4;A9, B4;B9 и т.д.?
К сообщению приложен файл: 5813047.xls(28Kb)
 
Ответить
СообщениеЗдраствуйте! Помогите пожалуйста. Есть два диапазона ячеек - текст и пустые ячейки. Как с помощью формулы(желательно) выбрать непустые ячейки. Поиск идет от A4;A9, B4;B9 и т.д.?

Автор - Fireman1969
Дата добавления - 17.07.2017 в 18:01
gling Дата: Понедельник, 17.07.2017, 20:01 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1587
Репутация: 388 ±
Замечаний: 0% ±

2010
Здравствуйте. Вариант с формулой в диспетчере имен
Код
НАИБОЛЬШИЙ(НЕ(ЕПУСТО(Лист1!$A$3:$L$20))*(СТОЛБЕЦ(Лист1!$A$3:$L$20)&","&СТРОКА(Лист1!$A$3:$L$20));СЧЁТЗ(Лист1!$A$3:$L$20)+1-СТОЛБЕЦ(Лист1!IM16))
и формулой в ячейках
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$Q$30;ПСТР(ОСТАТ(Kod;1);3;5);ЦЕЛОЕ(Kod));"")
К сообщению приложен файл: Fireman1969.xls(30Kb)
 
Ответить
СообщениеЗдравствуйте. Вариант с формулой в диспетчере имен
Код
НАИБОЛЬШИЙ(НЕ(ЕПУСТО(Лист1!$A$3:$L$20))*(СТОЛБЕЦ(Лист1!$A$3:$L$20)&","&СТРОКА(Лист1!$A$3:$L$20));СЧЁТЗ(Лист1!$A$3:$L$20)+1-СТОЛБЕЦ(Лист1!IM16))
и формулой в ячейках
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$Q$30;ПСТР(ОСТАТ(Kod;1);3;5);ЦЕЛОЕ(Kod));"")

Автор - gling
Дата добавления - 17.07.2017 в 20:01
Fireman1969 Дата: Понедельник, 17.07.2017, 21:01 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо за помощь. Может я не до конца разобрался но формула выдает ошибку во всех ячейках, то бишь - пусто
P.S. Использовал
Код
НАИБОЛЬШИЙ(НЕ(ЕПУСТО(Лист1!$A$3:$L$20))*(СТОЛБЕЦ(Лист1!$A$3:$L$20)&","&СТРОКА(Лист1!$A$3:$L$20));СЧЁТЗ(Лист1!$A$3:$L$20)+1-СТОЛБЕЦ(Лист1!IM16))

и
Код
НАИБОЛЬШИЙ(НЕ(ЕПУСТО(Лист1!$A$3:$L$20))*(СТОЛБЕЦ(Лист1!$A$3:$L$20)&","&СТРОКА(Лист1!$A$3:$L$20));СЧЁТЗ(Лист1!$A$3:$L$20)+1-СТОЛБЕЦ(Лист1!IL6))
как в файле, пока пусто )
 
Ответить
СообщениеСпасибо за помощь. Может я не до конца разобрался но формула выдает ошибку во всех ячейках, то бишь - пусто
P.S. Использовал
Код
НАИБОЛЬШИЙ(НЕ(ЕПУСТО(Лист1!$A$3:$L$20))*(СТОЛБЕЦ(Лист1!$A$3:$L$20)&","&СТРОКА(Лист1!$A$3:$L$20));СЧЁТЗ(Лист1!$A$3:$L$20)+1-СТОЛБЕЦ(Лист1!IM16))

и
Код
НАИБОЛЬШИЙ(НЕ(ЕПУСТО(Лист1!$A$3:$L$20))*(СТОЛБЕЦ(Лист1!$A$3:$L$20)&","&СТРОКА(Лист1!$A$3:$L$20));СЧЁТЗ(Лист1!$A$3:$L$20)+1-СТОЛБЕЦ(Лист1!IL6))
как в файле, пока пусто )

Автор - Fireman1969
Дата добавления - 17.07.2017 в 21:01
gling Дата: Понедельник, 17.07.2017, 21:34 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1587
Репутация: 388 ±
Замечаний: 0% ±

2010
Забыл написать, у Вас в примере в строках 4 и 9 ячейки без значений не пустые, я удалил в них невидимые символы Delet. И формулы сделаны под Ваш пример, возможно на других строках и диапазонах результата не будет. Надо смотреть в примере.
 
Ответить
СообщениеЗабыл написать, у Вас в примере в строках 4 и 9 ячейки без значений не пустые, я удалил в них невидимые символы Delet. И формулы сделаны под Ваш пример, возможно на других строках и диапазонах результата не будет. Надо смотреть в примере.

Автор - gling
Дата добавления - 17.07.2017 в 21:34
Fireman1969 Дата: Понедельник, 17.07.2017, 22:15 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Да-а, без Вашей помощи не разобраться. Все время выдает ошибку
 
Ответить
СообщениеДа-а, без Вашей помощи не разобраться. Все время выдает ошибку

Автор - Fireman1969
Дата добавления - 17.07.2017 в 22:15
gling Дата: Понедельник, 17.07.2017, 22:29 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1587
Репутация: 388 ±
Замечаний: 0% ±

2010
Файл у Вас 2003, Оффис 2013, в моём примере результат без ошибок? Если да, то нужен кусочек того что Вы наваяли.
 
Ответить
СообщениеФайл у Вас 2003, Оффис 2013, в моём примере результат без ошибок? Если да, то нужен кусочек того что Вы наваяли.

Автор - gling
Дата добавления - 17.07.2017 в 22:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и выбор непустых ячеек в ряд (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!