Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить время как рабочее или не рабочее время. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить время как рабочее или не рабочее время. (Формулы/Formulas)
Определить время как рабочее или не рабочее время.
Stigant Дата: Пятница, 21.07.2017, 13:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Такая проблема, есть рабочее время Пн-Пт с 08:00 до 12:30 и с 14:00 до 18:00 все остальное считается свободным временем и есть массив данных с указанием времени.
Как напротив каждого столбца с временем присвоить его к рабочему времени или к нерабочему соответственно.
Должно выглядеть что то вроде такой таблице.
Вт 02.05.2017 12:29:55 рабочее время
Вт 02.05.2017 18:53:15 не рабочее время
Вс 07.05.2017 07:28:43 не рабочее время
Вс 07.05.2017 21:56:24 не рабочее время
Пн 08.05.2017 06:49:09 не рабочее время
Пн 08.05.2017 08:00:06 рабочее время
Пн 08.05.2017 08:40:30 рабочее время

Спасибо.
 
Ответить
СообщениеДобрый день!
Такая проблема, есть рабочее время Пн-Пт с 08:00 до 12:30 и с 14:00 до 18:00 все остальное считается свободным временем и есть массив данных с указанием времени.
Как напротив каждого столбца с временем присвоить его к рабочему времени или к нерабочему соответственно.
Должно выглядеть что то вроде такой таблице.
Вт 02.05.2017 12:29:55 рабочее время
Вт 02.05.2017 18:53:15 не рабочее время
Вс 07.05.2017 07:28:43 не рабочее время
Вс 07.05.2017 21:56:24 не рабочее время
Пн 08.05.2017 06:49:09 не рабочее время
Пн 08.05.2017 08:00:06 рабочее время
Пн 08.05.2017 08:40:30 рабочее время

Спасибо.

Автор - Stigant
Дата добавления - 21.07.2017 в 13:06
Nic70y Дата: Пятница, 21.07.2017, 13:12 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4041
Репутация: 861 ±
Замечаний: 0% ±

Excel 2013
праздников и доп.рабочих не бывает?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениепраздников и доп.рабочих не бывает?

Автор - Nic70y
Дата добавления - 21.07.2017 в 13:12
Stigant Дата: Пятница, 21.07.2017, 13:26 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
С рабочими и доп. днями вроде сам разобрался.
Файл с примером отправляю.
К сообщению приложен файл: 3217178.xlsx(9Kb)
 
Ответить
СообщениеС рабочими и доп. днями вроде сам разобрался.
Файл с примером отправляю.

Автор - Stigant
Дата добавления - 21.07.2017 в 13:26
sboy Дата: Пятница, 21.07.2017, 13:35 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 841
Репутация: 224 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Код
=ПРОСМОТР(A2*24;{0;8;12,5;14;18};{"не ";"";"не ";"";"не "})&"рабочее время"

upd. Забыл про выходные
Код
=ЕСЛИ(ДЕНЬНЕД(B2;2)<6;ПРОСМОТР(A2*24;{0;8;12,5;14;18};{"не ";"";"не ";"";"не "});"не ")&"рабочее время"
К сообщению приложен файл: 7554603.xlsx(9Kb)


Сообщение отредактировал sboy - Пятница, 21.07.2017, 13:40
 
Ответить
СообщениеДобрый день.
Код
=ПРОСМОТР(A2*24;{0;8;12,5;14;18};{"не ";"";"не ";"";"не "})&"рабочее время"

upd. Забыл про выходные
Код
=ЕСЛИ(ДЕНЬНЕД(B2;2)<6;ПРОСМОТР(A2*24;{0;8;12,5;14;18};{"не ";"";"не ";"";"не "});"не ")&"рабочее время"

Автор - sboy
Дата добавления - 21.07.2017 в 13:35
Stigant Дата: Понедельник, 24.07.2017, 05:28 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, большое.
 
Ответить
СообщениеСпасибо, большое.

Автор - Stigant
Дата добавления - 24.07.2017 в 05:28
AlexM Дата: Понедельник, 24.07.2017, 09:19 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3570
Репутация: 899 ±
Замечаний: 0% ±

Excel 2003
Еще вариант
Код
=ЕСЛИ(ИЛИ((ДЕНЬНЕД(B2;2)<6)*(A2*24>={8;14})*(A2*24<{12,5;18}));"";"не ")&"рабочее время"
или
Код
=ЕСЛИ(ИЛИ((ОСТАТ(B2;7)>1)*(A2*24>={8;14})*(A2*24<{12,5;18}));"";"не ")&"рабочее время"



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 24.07.2017, 09:22
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИ(ИЛИ((ДЕНЬНЕД(B2;2)<6)*(A2*24>={8;14})*(A2*24<{12,5;18}));"";"не ")&"рабочее время"
или
Код
=ЕСЛИ(ИЛИ((ОСТАТ(B2;7)>1)*(A2*24>={8;14})*(A2*24<{12,5;18}));"";"не ")&"рабочее время"

Автор - AlexM
Дата добавления - 24.07.2017 в 09:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить время как рабочее или не рабочее время. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!