Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения в таблице по нескольким критериям (формула) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения в таблице по нескольким критериям (формула) (Формулы/Formulas)
Поиск значения в таблице по нескольким критериям (формула)
xrutsec Дата: Понедельник, 24.07.2017, 08:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем привет!
Можно ли по формуле найти значение по нескольким критериям в таблице с повторяющимися данными, как то:

Есть номер компании, номер чека, дата чека, наименование товаров в чеке и цена
Необходимо найти цену на последнюю дату чека для каждой компании, только если в чеке было одно наименование товара, в противном случае значение не подтягивается.

Пример во вложении
К сообщению приложен файл: example.xls(18Kb)
 
Ответить
СообщениеВсем привет!
Можно ли по формуле найти значение по нескольким критериям в таблице с повторяющимися данными, как то:

Есть номер компании, номер чека, дата чека, наименование товаров в чеке и цена
Необходимо найти цену на последнюю дату чека для каждой компании, только если в чеке было одно наименование товара, в противном случае значение не подтягивается.

Пример во вложении

Автор - xrutsec
Дата добавления - 24.07.2017 в 08:11
Russel Дата: Понедельник, 24.07.2017, 08:42 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1263
Репутация: 286 ±
Замечаний: 0% ±

Excel 2010
Решение "в лоб" с кучей допстолбцов. Наверное можно объединить в одну массивную формулу.
К сообщению приложен файл: example-1-.xls(29Kb)


QIWI 9173973973
 
Ответить
СообщениеРешение "в лоб" с кучей допстолбцов. Наверное можно объединить в одну массивную формулу.

Автор - Russel
Дата добавления - 24.07.2017 в 08:42
Russel Дата: Понедельник, 24.07.2017, 08:49 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1263
Репутация: 286 ±
Замечаний: 0% ±

Excel 2010
Вот монстр, даже не массивный:
Код
=СУММПРОИЗВ(($A$3:$A$15=A20)*($E$3:$E$15)*(МАКС(($A$3:$A$15=A20)*($C$3:$C$15=$C$3:$C$15)*($B$3:$B$15))=$B$3:$B$15)*(СЧЁТЕСЛИ($B$3:$B$15;$B$3:$B$15)=1)*(МАКС(($A$3:$A$15=A20)*$C$3:$C$15)=$C$3:$C$15))


QIWI 9173973973
 
Ответить
СообщениеВот монстр, даже не массивный:
Код
=СУММПРОИЗВ(($A$3:$A$15=A20)*($E$3:$E$15)*(МАКС(($A$3:$A$15=A20)*($C$3:$C$15=$C$3:$C$15)*($B$3:$B$15))=$B$3:$B$15)*(СЧЁТЕСЛИ($B$3:$B$15;$B$3:$B$15)=1)*(МАКС(($A$3:$A$15=A20)*$C$3:$C$15)=$C$3:$C$15))

Автор - Russel
Дата добавления - 24.07.2017 в 08:49
xrutsec Дата: Понедельник, 24.07.2017, 08:56 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
я уже тоже начал дробить на подстолбцы, чтобы легче было большую формулу сделать, но всё что успел это счет наименований сделать

спасибо за оперативность :)


Сообщение отредактировал xrutsec - Понедельник, 24.07.2017, 09:00
 
Ответить
Сообщениея уже тоже начал дробить на подстолбцы, чтобы легче было большую формулу сделать, но всё что успел это счет наименований сделать

спасибо за оперативность :)

Автор - xrutsec
Дата добавления - 24.07.2017 в 08:56
_Boroda_ Дата: Понедельник, 24.07.2017, 09:09 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ПРОСМОТР(;-1/(A$3:A$15=A20);E$3:E$15*(СЧЁТЕСЛИ(B$3:B$15;B$3:B$15)=1))
К сообщению приложен файл: example_1.xls(26Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ПРОСМОТР(;-1/(A$3:A$15=A20);E$3:E$15*(СЧЁТЕСЛИ(B$3:B$15;B$3:B$15)=1))

Автор - _Boroda_
Дата добавления - 24.07.2017 в 09:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения в таблице по нескольким критериям (формула) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!