Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как данные из горизонтальной таблицы преобразо в вертикально - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как данные из горизонтальной таблицы преобразо в вертикально (Помогите пожалуйста!!! Битый час бьюсь)
Как данные из горизонтальной таблицы преобразо в вертикально
Meredit Дата: Вторник, 25.07.2017, 17:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2010
Необходимо преобразовать данные из горизонтальной таблицы в вертикальную. Используя толькл функции и формулы
 
Ответить
СообщениеНеобходимо преобразовать данные из горизонтальной таблицы в вертикальную. Используя толькл функции и формулы

Автор - Meredit
Дата добавления - 25.07.2017 в 17:35
_Boroda_ Дата: Вторник, 25.07.2017, 17:37 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11850
Репутация: 4910 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
функция ТРАНСП
Формула
Код
=ТРАНСП(диапазон)

Без Вашего примера это всё


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениефункция ТРАНСП
Формула
Код
=ТРАНСП(диапазон)

Без Вашего примера это всё

Автор - _Boroda_
Дата добавления - 25.07.2017 в 17:37
sboy Дата: Вторник, 25.07.2017, 17:37 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1163
Репутация: 293 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
функций несколько можно использовать
Код
=ТРАНСП()

Код
=ИНДЕКС()

Код
=СМЕЩ()

подробнее с файлом-примером, что есть и что надо...
 
Ответить
СообщениеДобрый день.
функций несколько можно использовать
Код
=ТРАНСП()

Код
=ИНДЕКС()

Код
=СМЕЩ()

подробнее с файлом-примером, что есть и что надо...

Автор - sboy
Дата добавления - 25.07.2017 в 17:37
Meredit Дата: Вторник, 25.07.2017, 17:45 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2010
Добрый вечер! Спасибо что откликнулись. В этом файле затруднения вызывает верхняя строка. Уже даже не знаю что с ней делать((
К сообщению приложен файл: 5409156.xlsx(16Kb)
 
Ответить
СообщениеДобрый вечер! Спасибо что откликнулись. В этом файле затруднения вызывает верхняя строка. Уже даже не знаю что с ней делать((

Автор - Meredit
Дата добавления - 25.07.2017 в 17:45
_Boroda_ Дата: Вторник, 25.07.2017, 17:49 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11850
Репутация: 4910 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(B$9:M$14;ПОИСКПОЗ(B19;A$9:A$14;);A19)

Код
=СУММЕСЛИ(A$9:A$14;B19;ИНДЕКС(B$9:M$14;;A19))

Код
=ВПР(B19;A$9:M$14;A19+1;)

Код
=СУММПРОИЗВ(B$9:M$14*(A$9:A$14=B19)*(B$8:M$8=A19))

Код
=ПРОСМОТР(;-1/(B19=A$9:A$14);ИНДЕКС(B$9:M$14;;A19))

Код
=ПРОСМОТР(A19;B$8:M$8;ИНДЕКС(B$9:M$14;ПОИСКПОЗ(B19;A$9:A$14;);))

СМЕЩ и ДВССЫЛ не использую сознательно, ибо моветон
К сообщению приложен файл: 5409156_1.xlsx(20Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(B$9:M$14;ПОИСКПОЗ(B19;A$9:A$14;);A19)

Код
=СУММЕСЛИ(A$9:A$14;B19;ИНДЕКС(B$9:M$14;;A19))

Код
=ВПР(B19;A$9:M$14;A19+1;)

Код
=СУММПРОИЗВ(B$9:M$14*(A$9:A$14=B19)*(B$8:M$8=A19))

Код
=ПРОСМОТР(;-1/(B19=A$9:A$14);ИНДЕКС(B$9:M$14;;A19))

Код
=ПРОСМОТР(A19;B$8:M$8;ИНДЕКС(B$9:M$14;ПОИСКПОЗ(B19;A$9:A$14;);))

СМЕЩ и ДВССЫЛ не использую сознательно, ибо моветон

Автор - _Boroda_
Дата добавления - 25.07.2017 в 17:49
Meredit Дата: Вторник, 25.07.2017, 17:58 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2010
все так!! Огромное спасибо!
Скажите, пожалуйста, ты случайно никаких курсов по экселю не ведете?
 
Ответить
Сообщениевсе так!! Огромное спасибо!
Скажите, пожалуйста, ты случайно никаких курсов по экселю не ведете?

Автор - Meredit
Дата добавления - 25.07.2017 в 17:58
_Boroda_ Дата: Вторник, 25.07.2017, 18:01 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11850
Репутация: 4910 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Веду. Частным порядком. С выездом или по Скайпу


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВеду. Частным порядком. С выездом или по Скайпу

Автор - _Boroda_
Дата добавления - 25.07.2017 в 18:01
Meredit Дата: Вторник, 25.07.2017, 18:39 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2010
Как можно с вами договориться о курсах по скайпу?
 
Ответить
СообщениеКак можно с вами договориться о курсах по скайпу?

Автор - Meredit
Дата добавления - 25.07.2017 в 18:39
_Boroda_ Дата: Вторник, 25.07.2017, 20:24 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11850
Репутация: 4910 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Напишите на почту Boroda_Excel@mail.ru , а там уж решим


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНапишите на почту Boroda_Excel@mail.ru , а там уж решим

Автор - _Boroda_
Дата добавления - 25.07.2017 в 20:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как данные из горизонтальной таблицы преобразо в вертикально (Помогите пожалуйста!!! Битый час бьюсь)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!