Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных из условия выпадающей ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из условия выпадающей ячейки (Формулы/Formulas)
Перенос данных из условия выпадающей ячейки
Delex Дата: Четверг, 27.07.2017, 07:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Привет форумчане, не закидывайте тапками, я новый, может кто поможет, суть в чем

Нужно при выборе месяца во 2 листе перенести значения из 1
1 столб значения предыдущего месяца, 2 столб актуальные на заданный месяц
т.е.
нажимая январь на 2 листе, в 1 столб должны перенестись значения декабря, во 2столб январские
нажимая февраль в 1 столб должны перенестись значения января, во 2 февраля

Перелазил форум как мог со своими знаниями, пробовал химичить и с двсыл и впр и прочим, у самого не получилось
К сообщению приложен файл: 8995826.xlsx(14Kb)


Сообщение отредактировал Delex - Четверг, 27.07.2017, 07:15
 
Ответить
СообщениеПривет форумчане, не закидывайте тапками, я новый, может кто поможет, суть в чем

Нужно при выборе месяца во 2 листе перенести значения из 1
1 столб значения предыдущего месяца, 2 столб актуальные на заданный месяц
т.е.
нажимая январь на 2 листе, в 1 столб должны перенестись значения декабря, во 2столб январские
нажимая февраль в 1 столб должны перенестись значения января, во 2 февраля

Перелазил форум как мог со своими знаниями, пробовал химичить и с двсыл и впр и прочим, у самого не получилось

Автор - Delex
Дата добавления - 27.07.2017 в 07:14
китин Дата: Четверг, 27.07.2017, 07:21 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4278
Репутация: 665 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
И вам доброго! Так?
Код
=ИНДЕКС(Лист1!$D$2:$P$17;ПОИСКПОЗ(Лист2!$A5;Лист1!$A$2:$A$17;0);ПОИСКПОЗ(Лист2!$E$1;Лист1!$D$1:$P$1;0)-1)
К сообщению приложен файл: Delex.xlsx(15Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеИ вам доброго! Так?
Код
=ИНДЕКС(Лист1!$D$2:$P$17;ПОИСКПОЗ(Лист2!$A5;Лист1!$A$2:$A$17;0);ПОИСКПОЗ(Лист2!$E$1;Лист1!$D$1:$P$1;0)-1)

Автор - китин
Дата добавления - 27.07.2017 в 07:21
Delex Дата: Четверг, 27.07.2017, 07:28 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
И вам доброго! Так?

=ИНДЕКС(Лист1!$D$2:$P$17;ПОИСКПОЗ(Лист2!$A5;Лист1!$A$2:$A$17;0);ПОИСКПОЗ(Лист2!$E$1;Лист1!$D$1:$P$1;0)-1)


Мать моя женщина! Да, спасибо!
 
Ответить
Сообщение
И вам доброго! Так?

=ИНДЕКС(Лист1!$D$2:$P$17;ПОИСКПОЗ(Лист2!$A5;Лист1!$A$2:$A$17;0);ПОИСКПОЗ(Лист2!$E$1;Лист1!$D$1:$P$1;0)-1)


Мать моя женщина! Да, спасибо!

Автор - Delex
Дата добавления - 27.07.2017 в 07:28
_Boroda_ Дата: Четверг, 27.07.2017, 09:57 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10969
Репутация: 4555 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Для первого столбца
Код
=ПРОСМОТР(;-1/(E$1=Лист1!E$1:P$1);Лист1!D2:O2)

Для второго
Код
=ПРОСМОТР(;-1/(E$1=Лист1!E$1:P$1);Лист1!E2:P2)

или
Код
=ГПР(E$1;Лист1!D$1:P2;СТРОКА(F2);)
К сообщению приложен файл: 8995826_1.xlsx(34Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Для первого столбца
Код
=ПРОСМОТР(;-1/(E$1=Лист1!E$1:P$1);Лист1!D2:O2)

Для второго
Код
=ПРОСМОТР(;-1/(E$1=Лист1!E$1:P$1);Лист1!E2:P2)

или
Код
=ГПР(E$1;Лист1!D$1:P2;СТРОКА(F2);)

Автор - _Boroda_
Дата добавления - 27.07.2017 в 09:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из условия выпадающей ячейки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!