Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как их объединить ЕслиОшиб()... и ВПР(), ? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как их объединить ЕслиОшиб()... и ВПР(), ? (Формулы/Formulas)
как их объединить ЕслиОшиб()... и ВПР(), ?
seregadushka Дата: Пятница, 28.07.2017, 11:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Есть текстовая (любая) ячейка ..
Если в ней -- текст, то он должен выводиться &"слово"
Если в ней --- пусто, то результат -- пусто
Ячейку находит ВПР( ...)

если нет такой даты, ЕСЛИОШИБКА(ВПР(дата; ...;...;...)&"слово";"") -- работает хорошо, Дает ошибку и выводит ""
Но если есть такая дата, И в ячейке пусто , то Мешает, что ВПР( ...)=" " дает 0 &"слово" .. Одно Слово лишнее ничего не значит.

Как заставить ВПР() давать ошибку на пустом значении, или как несложно добавить какую функцию спереди. Сам ВПР (очень длинный), желательно его не копировать.
Спасибо за идеи
К сообщению приложен файл: 0390464.xls(32Kb)


Сообщение отредактировал seregadushka - Пятница, 28.07.2017, 15:00
 
Ответить
СообщениеЕсть текстовая (любая) ячейка ..
Если в ней -- текст, то он должен выводиться &"слово"
Если в ней --- пусто, то результат -- пусто
Ячейку находит ВПР( ...)

если нет такой даты, ЕСЛИОШИБКА(ВПР(дата; ...;...;...)&"слово";"") -- работает хорошо, Дает ошибку и выводит ""
Но если есть такая дата, И в ячейке пусто , то Мешает, что ВПР( ...)=" " дает 0 &"слово" .. Одно Слово лишнее ничего не значит.

Как заставить ВПР() давать ошибку на пустом значении, или как несложно добавить какую функцию спереди. Сам ВПР (очень длинный), желательно его не копировать.
Спасибо за идеи

Автор - seregadushka
Дата добавления - 28.07.2017 в 11:16
китин Дата: Пятница, 28.07.2017, 11:22 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4352
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вы бы приложили файлик. лично я ничего не понял


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениевы бы приложили файлик. лично я ничего не понял

Автор - китин
Дата добавления - 28.07.2017 в 11:22
AndreTM Дата: Пятница, 28.07.2017, 11:34 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1762
Репутация: 496 ±
Замечаний: 0% ±

2003 & 2010


Skype: andre.tm.007
Donate: Qiwi: 9517375010
 
Ответить
СообщениеКросс

Автор - AndreTM
Дата добавления - 28.07.2017 в 11:34
seregadushka Дата: Пятница, 28.07.2017, 11:40 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Кросс, понятно. Потому что на том форуме админы более озабочены белизной своих страниц, а не желанием помочь.
AndreTM, ты бы попробовал ответить, а Кросс я сам удалю


Сообщение отредактировал seregadushka - Пятница, 28.07.2017, 11:41
 
Ответить
СообщениеКросс, понятно. Потому что на том форуме админы более озабочены белизной своих страниц, а не желанием помочь.
AndreTM, ты бы попробовал ответить, а Кросс я сам удалю

Автор - seregadushka
Дата добавления - 28.07.2017 в 11:40
vikttur Дата: Пятница, 28.07.2017, 11:44 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2479
Репутация: 432 ±
Замечаний: 0% ±

В своей кваритире Вы тоже озабочены порядком, не так ли? И если на ковер с дождя да мокрыми лаптями - понравится? Попросите же снять обувь, только после этого кофе заварите?


Сообщение отредактировал vikttur - Пятница, 28.07.2017, 11:45
 
Ответить
СообщениеВ своей кваритире Вы тоже озабочены порядком, не так ли? И если на ковер с дождя да мокрыми лаптями - понравится? Попросите же снять обувь, только после этого кофе заварите?

Автор - vikttur
Дата добавления - 28.07.2017 в 11:44
китин Дата: Пятница, 28.07.2017, 11:45 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4352
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вы бы приложили файлик

[p.s.]Вы так близко знакомы с Андреем, что можно на ТЫ?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
вы бы приложили файлик

[p.s.]Вы так близко знакомы с Андреем, что можно на ТЫ?

Автор - китин
Дата добавления - 28.07.2017 в 11:45
Pelena Дата: Пятница, 28.07.2017, 12:15 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11608
Репутация: 2573 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Так подойдёт?
Код
=ЕСЛИОШИБКА(ВПР(F2;$A$2:$B$16;2;ЛОЖЬ)&ЕСЛИ(B2="";"";" ячейка");"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак подойдёт?
Код
=ЕСЛИОШИБКА(ВПР(F2;$A$2:$B$16;2;ЛОЖЬ)&ЕСЛИ(B2="";"";" ячейка");"")

Автор - Pelena
Дата добавления - 28.07.2017 в 12:15
seregadushka Дата: Пятница, 28.07.2017, 12:27 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
наверное , пойдет, , но нет, просто сама дата тоже берется издалека , с другого листа, она переменное . Итоговая формула около 5 строк в окошке. А есть функция , которая отслеживает Н/Д и 0 сразу ?
Спасибо , Pelena


Сообщение отредактировал seregadushka - Пятница, 28.07.2017, 12:33
 
Ответить
Сообщениенаверное , пойдет, , но нет, просто сама дата тоже берется издалека , с другого листа, она переменное . Итоговая формула около 5 строк в окошке. А есть функция , которая отслеживает Н/Д и 0 сразу ?
Спасибо , Pelena

Автор - seregadushka
Дата добавления - 28.07.2017 в 12:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как их объединить ЕслиОшиб()... и ВПР(), ? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!