Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Транспортировать с привязкой к диапазону - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспортировать с привязкой к диапазону (Формулы/Formulas)
Транспортировать с привязкой к диапазону
Strimer86 Дата: Пятница, 28.07.2017, 14:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Возможно ли транспортировать таблицу так, чтобы ID(T1) брал диапазон (J1-S1) и создавал таблицу ID(X2-X9)? "Размер"(Y2-Y9) и "Цена"(AA2-AA9). После того, как доходил до конца диапазона (S1), переходил к ID2 и создал дальше из диапазона J1-S1 и т.д. Если нет возможности, то хотя бы Id1 создавал столбец ID(X2-X9) без размера, но с ценой. А Размер можно будет и зациклить.
К сообщению приложен файл: 0553753.xlsx(11Kb)


Сообщение отредактировал Strimer86 - Пятница, 28.07.2017, 14:21
 
Ответить
СообщениеДобрый день! Возможно ли транспортировать таблицу так, чтобы ID(T1) брал диапазон (J1-S1) и создавал таблицу ID(X2-X9)? "Размер"(Y2-Y9) и "Цена"(AA2-AA9). После того, как доходил до конца диапазона (S1), переходил к ID2 и создал дальше из диапазона J1-S1 и т.д. Если нет возможности, то хотя бы Id1 создавал столбец ID(X2-X9) без размера, но с ценой. А Размер можно будет и зациклить.

Автор - Strimer86
Дата добавления - 28.07.2017 в 14:20
_Boroda_ Дата: Пятница, 28.07.2017, 14:31 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11512
Репутация: 4736 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(T$2:T$6;(СТРОКА(AD1)-1)/СЧЁТ(J$1:S$1)+1)

Код
=ИНДЕКС(J$1:S$1;ОСТАТ(СТРОКА(AD1)-1;СЧЁТ(J$1:S$1))+1)
К сообщению приложен файл: 0553753_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(T$2:T$6;(СТРОКА(AD1)-1)/СЧЁТ(J$1:S$1)+1)

Код
=ИНДЕКС(J$1:S$1;ОСТАТ(СТРОКА(AD1)-1;СЧЁТ(J$1:S$1))+1)

Автор - _Boroda_
Дата добавления - 28.07.2017 в 14:31
Strimer86 Дата: Пятница, 28.07.2017, 14:54 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое, все работает, все супер!!!!! hands hands hands hands hands
 
Ответить
СообщениеСпасибо большое, все работает, все супер!!!!! hands hands hands hands hands

Автор - Strimer86
Дата добавления - 28.07.2017 в 14:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспортировать с привязкой к диапазону (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!