Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как выбрать данные из списка по новой дате? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как выбрать данные из списка по новой дате? (Формулы/Formulas)
Как выбрать данные из списка по новой дате?
ZorKon71 Дата: Суббота, 29.07.2017, 00:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго времени суток!
С прошедшим всех праздником, днём сисалмина!
Вопрос!
Есть база:
№№ Name
5000 йцук
5001 фыва
5005 ячсм
5010 укен
5020 вап
5021 вапп
5021 смит

Сюда надо проставить следующие сведения:
Дата Ф.И.О. Каб.

На втором листе они есть. Но они не уникальные. Повторяются частично, не отсортированы.
№№ Дата Ф.И.О. Каб.
5000 01.07.2017 цждле 1
5001 01.07.2017 кургкцо 2
5005 01.07.2017 кыпот 3
5010 01.07.2017 ык 4
5020 01.07.2017 поткы 5
5021 01.07.2017 ткы 6
5021 01.07.2017 тоыт 7
5000 05.07.2017 уи 1
5005 05.07.2017 укп 2
5010 05.07.2017 у 3
5021 05.07.2017 пупи 4
5000 10.07.2017 уйц 1
5010 10.07.2017 кецупе 2

Необходимо для каждого номера "№№", найти максимальную (самую свежую) дату, и взять оттуда сведения.

Я бы запросто сделал это через ВПР(), но как найти новую дату!?
И хотелось бы без макросов...

Спасибо!
 
Ответить
СообщениеДоброго времени суток!
С прошедшим всех праздником, днём сисалмина!
Вопрос!
Есть база:
№№ Name
5000 йцук
5001 фыва
5005 ячсм
5010 укен
5020 вап
5021 вапп
5021 смит

Сюда надо проставить следующие сведения:
Дата Ф.И.О. Каб.

На втором листе они есть. Но они не уникальные. Повторяются частично, не отсортированы.
№№ Дата Ф.И.О. Каб.
5000 01.07.2017 цждле 1
5001 01.07.2017 кургкцо 2
5005 01.07.2017 кыпот 3
5010 01.07.2017 ык 4
5020 01.07.2017 поткы 5
5021 01.07.2017 ткы 6
5021 01.07.2017 тоыт 7
5000 05.07.2017 уи 1
5005 05.07.2017 укп 2
5010 05.07.2017 у 3
5021 05.07.2017 пупи 4
5000 10.07.2017 уйц 1
5010 10.07.2017 кецупе 2

Необходимо для каждого номера "№№", найти максимальную (самую свежую) дату, и взять оттуда сведения.

Я бы запросто сделал это через ВПР(), но как найти новую дату!?
И хотелось бы без макросов...

Спасибо!

Автор - ZorKon71
Дата добавления - 29.07.2017 в 00:16
buchlotnik Дата: Суббота, 29.07.2017, 00:31 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3120
Репутация: 854 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Здравствуйте,
Цитата
найти максимальную (самую свежую) дату
МАКС() или НАИБОЛЬШИЙ(), остальное с вашим файлом-примером
Цитата
И хотелось бы без макросов...
тут они точно не понадобятся


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Суббота, 29.07.2017, 00:34
 
Ответить
СообщениеЗдравствуйте,
Цитата
найти максимальную (самую свежую) дату
МАКС() или НАИБОЛЬШИЙ(), остальное с вашим файлом-примером
Цитата
И хотелось бы без макросов...
тут они точно не понадобятся

Автор - buchlotnik
Дата добавления - 29.07.2017 в 00:31
ZorKon71 Дата: Суббота, 29.07.2017, 00:40 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, спасибо...

Я так думаю решаемо, что-то типо:
Код
=ИНДЕКС(Лист2!C:C;ПОИСКПОЗ(МАКС(Лист2!A:A);Лист2!A:A;0))

Но как выделить №№!?
К сообщению приложен файл: -Date.xlsx(18Kb)


Сообщение отредактировал ZorKon71 - Суббота, 29.07.2017, 00:54
 
Ответить
Сообщениеbuchlotnik, спасибо...

Я так думаю решаемо, что-то типо:
Код
=ИНДЕКС(Лист2!C:C;ПОИСКПОЗ(МАКС(Лист2!A:A);Лист2!A:A;0))

Но как выделить №№!?

Автор - ZorKon71
Дата добавления - 29.07.2017 в 00:40
buchlotnik Дата: Суббота, 29.07.2017, 00:48 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3120
Репутация: 854 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Вот так (формула массива):
Код
=ИНДЕКС(Лист2!$C$2:$C$14;ПОИСКПОЗ(МАКС(ЕСЛИ(Лист2!$B$2:$B$14=B2;Лист2!$C$2:$C$14;""));ЕСЛИ(Лист2!$B$2:$B$14=B2;Лист2!$C$2:$C$14;"");0))
и вам свою формулу следует оформить тегами

UPD Что-то я перегрелся похоже, так проще:
Код
=МАКС(Лист2!$C$2:$C$14*(Лист2!$B$2:$B$14=B2))
К сообщению приложен файл: -Date2.xlsx(13Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Суббота, 29.07.2017, 00:52
 
Ответить
СообщениеВот так (формула массива):
Код
=ИНДЕКС(Лист2!$C$2:$C$14;ПОИСКПОЗ(МАКС(ЕСЛИ(Лист2!$B$2:$B$14=B2;Лист2!$C$2:$C$14;""));ЕСЛИ(Лист2!$B$2:$B$14=B2;Лист2!$C$2:$C$14;"");0))
и вам свою формулу следует оформить тегами

UPD Что-то я перегрелся похоже, так проще:
Код
=МАКС(Лист2!$C$2:$C$14*(Лист2!$B$2:$B$14=B2))

Автор - buchlotnik
Дата добавления - 29.07.2017 в 00:48
ZorKon71 Дата: Суббота, 29.07.2017, 00:59 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, класс!
Но как мне добавлять на второй лист сведения?!

И мне кажется первая формула была правильней!
Мне же не только дату надо!
А Ф.И.О. и Кабинеты!


Сообщение отредактировал ZorKon71 - Суббота, 29.07.2017, 01:03
 
Ответить
Сообщениеbuchlotnik, класс!
Но как мне добавлять на второй лист сведения?!

И мне кажется первая формула была правильней!
Мне же не только дату надо!
А Ф.И.О. и Кабинеты!

Автор - ZorKon71
Дата добавления - 29.07.2017 в 00:59
ZorKon71 Дата: Суббота, 29.07.2017, 01:05 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А как формулу исправить для массива?
Что-то не получилось...
К сообщению приложен файл: 3398944.xlsx(19Kb)
 
Ответить
СообщениеА как формулу исправить для массива?
Что-то не получилось...

Автор - ZorKon71
Дата добавления - 29.07.2017 в 01:05
buchlotnik Дата: Суббота, 29.07.2017, 01:06 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3120
Репутация: 854 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Сделайте диапазоны изначально с запасом не Лист2!$B$2:$B$14, а Лист2!$B$2:$B$140, например, но лучше оформить в виде таблицы, тогда и формулы нагляднее станут:
для дат
Код
=МАКС(Сведения[Дата]*(Сведения[№№]=[@№№]))
для остального
Код
=ИНДЕКС(Сведения[Ф.И.О.];ПОИСКПОЗ([@№№]&"-"&[@Дата];Сведения[№№]&"-"&Сведения[Дата];0))
Цитата
Что-то не получилось...
вы дорисовали фигурные скобки руками - так делать не нужно, формула массива вводится одновременным нажатием ctrl+shift+enter - тогда эти скобочки сами появятся :)
К сообщению приложен файл: -Date2-1-.xlsx(15Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Суббота, 29.07.2017, 01:08
 
Ответить
СообщениеСделайте диапазоны изначально с запасом не Лист2!$B$2:$B$14, а Лист2!$B$2:$B$140, например, но лучше оформить в виде таблицы, тогда и формулы нагляднее станут:
для дат
Код
=МАКС(Сведения[Дата]*(Сведения[№№]=[@№№]))
для остального
Код
=ИНДЕКС(Сведения[Ф.И.О.];ПОИСКПОЗ([@№№]&"-"&[@Дата];Сведения[№№]&"-"&Сведения[Дата];0))
Цитата
Что-то не получилось...
вы дорисовали фигурные скобки руками - так делать не нужно, формула массива вводится одновременным нажатием ctrl+shift+enter - тогда эти скобочки сами появятся :)

Автор - buchlotnik
Дата добавления - 29.07.2017 в 01:06
ZorKon71 Дата: Суббота, 29.07.2017, 01:09 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Класс!
Спасибо!

Да. Про таблицы я и забыл...
Так лучше...

Спасибо!
 
Ответить
СообщениеКласс!
Спасибо!

Да. Про таблицы я и забыл...
Так лучше...

Спасибо!

Автор - ZorKon71
Дата добавления - 29.07.2017 в 01:09
ZorKon71 Дата: Суббота, 29.07.2017, 01:23 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Обнаружилась проблемка!
№№ не все цифровые!
есть 50010-01, и 50010/01, и 50010a...
Что делать?!
:(
 
Ответить
СообщениеОбнаружилась проблемка!
№№ не все цифровые!
есть 50010-01, и 50010/01, и 50010a...
Что делать?!
:(

Автор - ZorKon71
Дата добавления - 29.07.2017 в 01:23
buchlotnik Дата: Суббота, 29.07.2017, 01:27 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3120
Репутация: 854 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Что делать?!
скрываться от моего праведного гнева и возвращаться к исходной формуле
Код
=ИНДЕКС(Сведения[Дата];ПОИСКПОЗ(МАКС(ЕСЛИ(Сведения[№№]=[@№№];Сведения[Дата];""));ЕСЛИ(Сведения[№№]=[@№№];Сведения[Дата];"");0))
К сообщению приложен файл: 7193885.xlsx(15Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
Что делать?!
скрываться от моего праведного гнева и возвращаться к исходной формуле
Код
=ИНДЕКС(Сведения[Дата];ПОИСКПОЗ(МАКС(ЕСЛИ(Сведения[№№]=[@№№];Сведения[Дата];""));ЕСЛИ(Сведения[№№]=[@№№];Сведения[Дата];"");0))

Автор - buchlotnik
Дата добавления - 29.07.2017 в 01:27
ZorKon71 Дата: Суббота, 29.07.2017, 08:19 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, СПАСИБО!!!
 
Ответить
Сообщениеbuchlotnik, СПАСИБО!!!

Автор - ZorKon71
Дата добавления - 29.07.2017 в 08:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как выбрать данные из списка по новой дате? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!