Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Данные записываем в ячейку в зависимости от текущей даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Данные записываем в ячейку в зависимости от текущей даты (Формулы/Formulas)
Данные записываем в ячейку в зависимости от текущей даты
AnatolyZhilichev Дата: Вторник, 01.08.2017, 15:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!

Прошу помощи в записи значения ячейки С16 в ячейки с С21 по С24.
Суть проблемы: ячейка С21 соответствует интервалу 1-го квартала
ячейка С22 соответствует интервалу 2-го квартала
ячейка С23 соответствует интервалу 3-го квартала
ячейка С24 соответствует интервалу 4-го квартала
требуется записать значение ячейки в соответствующую текущей дате (ячейка К1) в ячейку с С21 по С24, т.е. на 01.08.2017 запись должна быть сделана в ячейку С23, при этом при переходе даты с одного квартала на другой запись значения ячейки С16 в предыдущем квартале должна остатся а изменяться уже в другой ячейке

Я попытался решить через если, но чего-то мне не хватает
К сообщению приложен файл: ______V2.xlsx(40Kb)


Сообщение отредактировал AnatolyZhilichev - Вторник, 01.08.2017, 15:45
 
Ответить
СообщениеДобрый день!

Прошу помощи в записи значения ячейки С16 в ячейки с С21 по С24.
Суть проблемы: ячейка С21 соответствует интервалу 1-го квартала
ячейка С22 соответствует интервалу 2-го квартала
ячейка С23 соответствует интервалу 3-го квартала
ячейка С24 соответствует интервалу 4-го квартала
требуется записать значение ячейки в соответствующую текущей дате (ячейка К1) в ячейку с С21 по С24, т.е. на 01.08.2017 запись должна быть сделана в ячейку С23, при этом при переходе даты с одного квартала на другой запись значения ячейки С16 в предыдущем квартале должна остатся а изменяться уже в другой ячейке

Я попытался решить через если, но чего-то мне не хватает

Автор - AnatolyZhilichev
Дата добавления - 01.08.2017 в 15:44
Perfect2You Дата: Вторник, 01.08.2017, 19:07 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 234
Репутация: 59 ±
Замечаний: 0% ±

Excel 2010
Можно попробовать вот так:
Код
=ЕСЛИ(ОКРВВЕРХ(МЕСЯЦ($K$1)/3;1)&" квартал"=D21;C$16;"")

Это для ячейки С21 и скопировать формулу.
 
Ответить
СообщениеМожно попробовать вот так:
Код
=ЕСЛИ(ОКРВВЕРХ(МЕСЯЦ($K$1)/3;1)&" квартал"=D21;C$16;"")

Это для ячейки С21 и скопировать формулу.

Автор - Perfect2You
Дата добавления - 01.08.2017 в 19:07
Nic70y Дата: Вторник, 01.08.2017, 19:32 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4236
Репутация: 922 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(ОКРВВЕРХ(МЕСЯЦ($K$1)/3;1)=СТРОКА(C1);C$16;"")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(ОКРВВЕРХ(МЕСЯЦ($K$1)/3;1)=СТРОКА(C1);C$16;"")

Автор - Nic70y
Дата добавления - 01.08.2017 в 19:32
AnatolyZhilichev Дата: Среда, 02.08.2017, 19:14 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Почему-то не работает, при смене даты опять стирает данные в ячейке с прошлым кварталом..(((
 
Ответить
СообщениеПочему-то не работает, при смене даты опять стирает данные в ячейке с прошлым кварталом..(((

Автор - AnatolyZhilichev
Дата добавления - 02.08.2017 в 19:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Данные записываем в ячейку в зависимости от текущей даты (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!