Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сбор данных в новой таблице по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных в новой таблице по условию (Формулы/Formulas)
Сбор данных в новой таблице по условию
ASM_0408 Дата: Понедельник, 07.08.2017, 09:21 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 191
Репутация: 0 ±
Замечаний: 0% ±

2016
Доброго времени суток, уважаемые форумчане! Посодействуте пожалуйста в решении следующей задачи. В примере представлена форма, при проставлении галочки в столбце F на против нужного изделия, это изделие должно сваливаться в первую строчку таблицы комплектация которая расположена на этом же листе ниже со всеми своими атрибутами ед.изм и количество. Если поставить следующую галочку, то это изделие со всеми своими атрибутами должно занять следующую после занятой строчки, и т.д. Галочки могут ставится в разном порядке а заполняться должно сверху вниз без пустых строк. Благодарю за содействие!
К сообщению приложен файл: 6942530.xlsx(20Kb)
 
Ответить
СообщениеДоброго времени суток, уважаемые форумчане! Посодействуте пожалуйста в решении следующей задачи. В примере представлена форма, при проставлении галочки в столбце F на против нужного изделия, это изделие должно сваливаться в первую строчку таблицы комплектация которая расположена на этом же листе ниже со всеми своими атрибутами ед.изм и количество. Если поставить следующую галочку, то это изделие со всеми своими атрибутами должно занять следующую после занятой строчки, и т.д. Галочки могут ставится в разном порядке а заполняться должно сверху вниз без пустых строк. Благодарю за содействие!

Автор - ASM_0408
Дата добавления - 07.08.2017 в 09:21
sboy Дата: Понедельник, 07.08.2017, 09:28 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1166
Репутация: 294 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Вот такой вариант, отсортированы будут также как в исходной таблице
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$19;АГРЕГАТ(15;6;(СТРОКА($A$2:$C$19)-1)/$F$2:$F$19;СТРОКА(A1)));"")
К сообщению приложен файл: 9262171.xlsx(20Kb)
 
Ответить
СообщениеДобрый день.
Вот такой вариант, отсортированы будут также как в исходной таблице
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$19;АГРЕГАТ(15;6;(СТРОКА($A$2:$C$19)-1)/$F$2:$F$19;СТРОКА(A1)));"")

Автор - sboy
Дата добавления - 07.08.2017 в 09:28
ASM_0408 Дата: Понедельник, 07.08.2017, 10:06 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 191
Репутация: 0 ±
Замечаний: 0% ±

2016
Вот такой вариант, отсортированы будут также как в исходной таблице

Благодарю, все работает отлично! Замечательно, что сразу сортируется.
 
Ответить
Сообщение
Вот такой вариант, отсортированы будут также как в исходной таблице

Благодарю, все работает отлично! Замечательно, что сразу сортируется.

Автор - ASM_0408
Дата добавления - 07.08.2017 в 10:06
_Boroda_ Дата: Понедельник, 07.08.2017, 10:20 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Замечательно, что сразу сортируется.

Ну предупреждать же нужно! Я, например, так понял, что в том и затык, что нужно выводить значения в нижнюю таблицу в том порядке, в каком они будут натыканы. И метры квадратные не так отображаться будут. Сижу, блин, макрос думаю, а тут на тебе!
А так если, то вариантов куча. Один из самых распространенных (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$19;НАИМЕНЬШИЙ(ЕСЛИ($F$2:$F$19;СТРОКА(A$2:A$19));СТРОКА(A1)));"")
К сообщению приложен файл: 6942530_1.xlsx(21Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Замечательно, что сразу сортируется.

Ну предупреждать же нужно! Я, например, так понял, что в том и затык, что нужно выводить значения в нижнюю таблицу в том порядке, в каком они будут натыканы. И метры квадратные не так отображаться будут. Сижу, блин, макрос думаю, а тут на тебе!
А так если, то вариантов куча. Один из самых распространенных (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$19;НАИМЕНЬШИЙ(ЕСЛИ($F$2:$F$19;СТРОКА(A$2:A$19));СТРОКА(A1)));"")

Автор - _Boroda_
Дата добавления - 07.08.2017 в 10:20
ASM_0408 Дата: Понедельник, 07.08.2017, 10:26 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 191
Репутация: 0 ±
Замечаний: 0% ±

2016
Ну предупреждать же нужно!

Прошу прощения, что не достаточно понятно пояснил что требовалось. Главное условие было отсутствие пустых строк в комплектации.
Благодарю за отзывчивость!
 
Ответить
Сообщение
Ну предупреждать же нужно!

Прошу прощения, что не достаточно понятно пояснил что требовалось. Главное условие было отсутствие пустых строк в комплектации.
Благодарю за отзывчивость!

Автор - ASM_0408
Дата добавления - 07.08.2017 в 10:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных в новой таблице по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!