Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Количество цифр в числе - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество цифр в числе (Формулы/Formulas)
Количество цифр в числе
ПАМ Дата: Понедельник, 07.08.2017, 14:02 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 118
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, уважаемые знатоки Excel.

Подскажите мне пожалуйста: как в Экселе задать формулу для расчета количества цифр в числе?
То есть например число 15 состоит из 2 цифр, 145 из 3, 1225 из 4 и так далее.
Искал на форуме похожее, но не нашел. Возможно не правильно искал или плохо искал.
Если можно без макросов.

Спасибо огромное заранее.
К сообщению приложен файл: 4063409.xls(24Kb)
 
Ответить
СообщениеЗдравствуйте, уважаемые знатоки Excel.

Подскажите мне пожалуйста: как в Экселе задать формулу для расчета количества цифр в числе?
То есть например число 15 состоит из 2 цифр, 145 из 3, 1225 из 4 и так далее.
Искал на форуме похожее, но не нашел. Возможно не правильно искал или плохо искал.
Если можно без макросов.

Спасибо огромное заранее.

Автор - ПАМ
Дата добавления - 07.08.2017 в 14:02
_Boroda_ Дата: Понедельник, 07.08.2017, 14:03 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11547
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы про это?
Код
=ДЛСТР(B2)

Или Вам нужно количество цифр там, где есть не только цифры? Тогда так, например
Код
=СУММПРОИЗВ(ДЛСТР(B5)-ДЛСТР(ПОДСТАВИТЬ(B5;СТРОКА($1:$10)-1;)))

Или количество уникальных цифр? Тогда
Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК(СТРОКА($1:$9)-1;B2)))
К сообщению приложен файл: 4063409_1.xls(28Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВы про это?
Код
=ДЛСТР(B2)

Или Вам нужно количество цифр там, где есть не только цифры? Тогда так, например
Код
=СУММПРОИЗВ(ДЛСТР(B5)-ДЛСТР(ПОДСТАВИТЬ(B5;СТРОКА($1:$10)-1;)))

Или количество уникальных цифр? Тогда
Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК(СТРОКА($1:$9)-1;B2)))

Автор - _Boroda_
Дата добавления - 07.08.2017 в 14:03
ПАМ Дата: Понедельник, 07.08.2017, 14:11 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 118
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Так точно Александр! Огромное спасибо Вам. А я то думал через формулы
Код
счет
или
Код
суммы
:)
 
Ответить
СообщениеТак точно Александр! Огромное спасибо Вам. А я то думал через формулы
Код
счет
или
Код
суммы
:)

Автор - ПАМ
Дата добавления - 07.08.2017 в 14:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество цифр в числе (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!