Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выгрузить информацию с двух таблиц в третью - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выгрузить информацию с двух таблиц в третью (Формулы/Formulas)
Выгрузить информацию с двух таблиц в третью
RidShilk Дата: Вторник, 08.08.2017, 14:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго всем дня!

Очень надеюсь на Вашу помощь. Уже несколько дней бьюсь над задачей, никак не выходит.
Требуется выгрузить из двух таблиц, совпадающие условия.

Т.е. дана таблица с "товаром", "ценой товара", "поставщиком" и "ценой поставщика", и аналогичная вторая таблица. Нужно найти совпадающие одновременно "товар" и "поставщика" в двух таблицах и составить третью с их ценами.
Объяснил криво, знаю, и сразу прошу меня простить за это

Прикрепляю файлом пример, чтобы понять что я имел ввиду.

Я пробовал через функции "ИНДЕКС" и "ПОИСКПОЗ", но получается выгрузить только наименования друг за другом.

Заранее всем спасибо за помощь, надеюсь сможете выручить!!!
К сообщению приложен файл: 0316806.xlsx(12Kb)
 
Ответить
СообщениеДоброго всем дня!

Очень надеюсь на Вашу помощь. Уже несколько дней бьюсь над задачей, никак не выходит.
Требуется выгрузить из двух таблиц, совпадающие условия.

Т.е. дана таблица с "товаром", "ценой товара", "поставщиком" и "ценой поставщика", и аналогичная вторая таблица. Нужно найти совпадающие одновременно "товар" и "поставщика" в двух таблицах и составить третью с их ценами.
Объяснил криво, знаю, и сразу прошу меня простить за это

Прикрепляю файлом пример, чтобы понять что я имел ввиду.

Я пробовал через функции "ИНДЕКС" и "ПОИСКПОЗ", но получается выгрузить только наименования друг за другом.

Заранее всем спасибо за помощь, надеюсь сможете выручить!!!

Автор - RidShilk
Дата добавления - 08.08.2017 в 14:02
sboy Дата: Вторник, 08.08.2017, 14:40 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1166
Репутация: 294 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если правильно понял, формула массива
Код
=ИНДЕКС(B$5:B$9;ПОИСКПОЗ($J5&$L5;A$5:A$9&C$5:C$9;))
К сообщению приложен файл: 2993433.xlsx(12Kb)
 
Ответить
СообщениеДобрый день.
Если правильно понял, формула массива
Код
=ИНДЕКС(B$5:B$9;ПОИСКПОЗ($J5&$L5;A$5:A$9&C$5:C$9;))

Автор - sboy
Дата добавления - 08.08.2017 в 14:40
_Boroda_ Дата: Вторник, 08.08.2017, 14:58 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
3 вида немассивных формул (особенно последняя :D )
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСКПОЗ($A$5:$A$99&$C$5:$C$99;$E$5:$E$99&$G$5:$G$99;)/ЕОШИБКА(ПОИСКПОЗ($A$5:$A$99&$C$5:$C$99;$J$4:$J4&$L$4:$L4;))/($A$5:$A$99<>"");A$5:A$99);"")

Код
=ЕСЛИ(J5="";"";СУММЕСЛИМН(B$5:B$99;$A$5:$A$99;$N5;$C$5:$C$99;$P5))

Код
=J5
К сообщению приложен файл: 0316806_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение3 вида немассивных формул (особенно последняя :D )
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСКПОЗ($A$5:$A$99&$C$5:$C$99;$E$5:$E$99&$G$5:$G$99;)/ЕОШИБКА(ПОИСКПОЗ($A$5:$A$99&$C$5:$C$99;$J$4:$J4&$L$4:$L4;))/($A$5:$A$99<>"");A$5:A$99);"")

Код
=ЕСЛИ(J5="";"";СУММЕСЛИМН(B$5:B$99;$A$5:$A$99;$N5;$C$5:$C$99;$P5))

Код
=J5

Автор - _Boroda_
Дата добавления - 08.08.2017 в 14:58
RidShilk Дата: Вторник, 08.08.2017, 15:00 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
sboy, добрый день!
Я имел ввиду, что из искомых данных, эксель выбирает "товар" и "поставщика", которые повторяются в двух таблицах. Далее он выводит их в отдельную таблицу (я ее назвал "искомые данные"), сохраняя при этом ценовые значения.
Формулу массива я использовал, но она не дала нужного результата.

Вот в прикрепленном файле я поясню.
Даны такие таблицы. Эксель ищет одновременные совпадения по столбцам "товар" и "поставщики".
Найдя их (я выделил совпадения разными цветами), эксель их выгружает отдельно.
К сообщению приложен файл: 9421008.xlsx(12Kb)
 
Ответить
Сообщениеsboy, добрый день!
Я имел ввиду, что из искомых данных, эксель выбирает "товар" и "поставщика", которые повторяются в двух таблицах. Далее он выводит их в отдельную таблицу (я ее назвал "искомые данные"), сохраняя при этом ценовые значения.
Формулу массива я использовал, но она не дала нужного результата.

Вот в прикрепленном файле я поясню.
Даны такие таблицы. Эксель ищет одновременные совпадения по столбцам "товар" и "поставщики".
Найдя их (я выделил совпадения разными цветами), эксель их выгружает отдельно.

Автор - RidShilk
Дата добавления - 08.08.2017 в 15:00
RidShilk Дата: Вторник, 08.08.2017, 15:03 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, Спасибо огромное!!!
Это то что было нужно!
 
Ответить
Сообщение_Boroda_, Спасибо огромное!!!
Это то что было нужно!

Автор - RidShilk
Дата добавления - 08.08.2017 в 15:03
Udik Дата: Вторник, 08.08.2017, 15:30 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1588
Репутация: 192 ±
Замечаний: 0% ±

Excel 2016 х 64
хы, а вот с Power Query вариант
К сообщению приложен файл: 2423777.xlsx(23Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениехы, а вот с Power Query вариант

Автор - Udik
Дата добавления - 08.08.2017 в 15:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выгрузить информацию с двух таблиц в третью (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!