Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Упростить формулу с вложениями "ЕСЛИ" - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упростить формулу с вложениями "ЕСЛИ" (Формулы/Formulas)
Упростить формулу с вложениями "ЕСЛИ"
Stormy Дата: Среда, 09.08.2017, 10:21 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 312
Репутация: 12 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Можно и нужно ли упрощать формулу
Код
=ЕСЛИ($D$5="MR";E7;ЕСЛИ($D$5="SB";F7;ЕСЛИ($D$5="FR";G7;ЕСЛИ($D$5="VR";H7;ЕСЛИ($D$5="MF";I7;ЕСЛИ($D$5="YLM";J7;ЕСЛИ($D$5="BY";K7;ЕСЛИ($D$5="";0))))))))

Вложений с ЕСЛИ будет 9, строк содержащих эту формулу 5000, столбцов 2.

Суть формулы, в зависимости от литеры в названии столбца отображать данные из определенного столбца
К сообщению приложен файл: primer.xlsx(10Kb)


Место для рекламы.
 
Ответить
СообщениеДобрый день.
Можно и нужно ли упрощать формулу
Код
=ЕСЛИ($D$5="MR";E7;ЕСЛИ($D$5="SB";F7;ЕСЛИ($D$5="FR";G7;ЕСЛИ($D$5="VR";H7;ЕСЛИ($D$5="MF";I7;ЕСЛИ($D$5="YLM";J7;ЕСЛИ($D$5="BY";K7;ЕСЛИ($D$5="";0))))))))

Вложений с ЕСЛИ будет 9, строк содержащих эту формулу 5000, столбцов 2.

Суть формулы, в зависимости от литеры в названии столбца отображать данные из определенного столбца

Автор - Stormy
Дата добавления - 09.08.2017 в 10:21
_Boroda_ Дата: Среда, 09.08.2017, 10:36 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
По идее куча ЕСЛИ работает достаточно быстро - она в среднем отрабатывает половину условий, сравнение - достаточно быстрая операция. Однако в ней довольно легко накосячить, например, неверно ссылку поставить.

Попробуйте вот так
Код
=ИНДЕКС(E6:K6;ПОИСКПОЗ(D$5;E$4:K$4;))

или так
Код
=СУММЕСЛИ(E$4:K$4;D$5;E6:K6)

5000 строк - немного, возможно, Вы разницы и не заметите


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПо идее куча ЕСЛИ работает достаточно быстро - она в среднем отрабатывает половину условий, сравнение - достаточно быстрая операция. Однако в ней довольно легко накосячить, например, неверно ссылку поставить.

Попробуйте вот так
Код
=ИНДЕКС(E6:K6;ПОИСКПОЗ(D$5;E$4:K$4;))

или так
Код
=СУММЕСЛИ(E$4:K$4;D$5;E6:K6)

5000 строк - немного, возможно, Вы разницы и не заметите

Автор - _Boroda_
Дата добавления - 09.08.2017 в 10:36
Stormy Дата: Среда, 09.08.2017, 10:50 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 312
Репутация: 12 ±
Замечаний: 0% ±

Excel 2010
_Boroda_,
Из-за возможных косяков и были сомнения.
Ваши примеры проще и понятнее, но есть одно НО, которое я не учел.
Названия столбцов в таблице отличаются от выпадающего списка. Получается остается привязка только к буквам?
Нужно брать значения из столбцов выделенные голубым цветом
Добавил часть таблицы с названиями из оригинала
К сообщению приложен файл: 0376839.xlsx(15Kb) · 0473653.jpg(27Kb)


Место для рекламы.

Сообщение отредактировал Stormy - Среда, 09.08.2017, 10:51
 
Ответить
Сообщение_Boroda_,
Из-за возможных косяков и были сомнения.
Ваши примеры проще и понятнее, но есть одно НО, которое я не учел.
Названия столбцов в таблице отличаются от выпадающего списка. Получается остается привязка только к буквам?
Нужно брать значения из столбцов выделенные голубым цветом
Добавил часть таблицы с названиями из оригинала

Автор - Stormy
Дата добавления - 09.08.2017 в 10:50
AndreTM Дата: Среда, 09.08.2017, 11:20 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1762
Репутация: 496 ±
Замечаний: 0% ±

2003 & 2010
Так подпишите нужные вам столбцы, например, ещё выше строчкой, и берите "коды" из неё:
К сообщению приложен файл: 2-34825-1.xlsx(15Kb)


Skype: andre.tm.007
Donate: Qiwi: 9517375010
 
Ответить
СообщениеТак подпишите нужные вам столбцы, например, ещё выше строчкой, и берите "коды" из неё:

Автор - AndreTM
Дата добавления - 09.08.2017 в 11:20
Stormy Дата: Среда, 09.08.2017, 11:51 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 312
Репутация: 12 ±
Замечаний: 0% ±

Excel 2010
AndreTM,
Долго вникал, как работает формула, пока на строку выше не выделил :D
Солнце сильно припекло, голова совсем на варит %)


Место для рекламы.
 
Ответить
СообщениеAndreTM,
Долго вникал, как работает формула, пока на строку выше не выделил :D
Солнце сильно припекло, голова совсем на варит %)

Автор - Stormy
Дата добавления - 09.08.2017 в 11:51
Perfect2You Дата: Среда, 09.08.2017, 15:22 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 234
Репутация: 59 ±
Замечаний: 0% ±

Excel 2010
В Вашем конкретном случае, поскольку поиск идет по первой строке диапазона, можно комбинацию ИНДЕКС-ПОИСКПОЗ заменить ГПРом, получится так:
Код
=ГПР(A$4;$C$2:$AZ$12;СТРОКА()-1;0)
К сообщению приложен файл: _2-34825-1-1.xlsx(15Kb)


Сообщение отредактировал Perfect2You - Среда, 09.08.2017, 15:24
 
Ответить
СообщениеВ Вашем конкретном случае, поскольку поиск идет по первой строке диапазона, можно комбинацию ИНДЕКС-ПОИСКПОЗ заменить ГПРом, получится так:
Код
=ГПР(A$4;$C$2:$AZ$12;СТРОКА()-1;0)

Автор - Perfect2You
Дата добавления - 09.08.2017 в 15:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упростить формулу с вложениями "ЕСЛИ" (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!