Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Удаление строки при условии частичного совпадения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление строки при условии частичного совпадения (Формулы/Formulas)
Удаление строки при условии частичного совпадения
Caryaga Дата: Среда, 09.08.2017, 15:45 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Не могу решить задачу удаление всей строки при частичном совпадении одной определенной ячейки с любой ячейкой из массива данных.

Цитата
например, если в случае искомого текста будет "мясная колбаса рецепт", а в качестве просматриваемого массива слово "рецепт".


Я вынес уроки из прошлой темы и ознакомился с понятием поиска по словарю, но как его создать пока ума не приложу. Спасибо Boroda за помощь в прошлой теме. Формулы здесь тоже могут помочь? Если да, то как?
К сообщению приложен файл: sample_kolbasa.xlsx(10Kb)
 
Ответить
СообщениеНе могу решить задачу удаление всей строки при частичном совпадении одной определенной ячейки с любой ячейкой из массива данных.

Цитата
например, если в случае искомого текста будет "мясная колбаса рецепт", а в качестве просматриваемого массива слово "рецепт".


Я вынес уроки из прошлой темы и ознакомился с понятием поиска по словарю, но как его создать пока ума не приложу. Спасибо Boroda за помощь в прошлой теме. Формулы здесь тоже могут помочь? Если да, то как?

Автор - Caryaga
Дата добавления - 09.08.2017 в 15:45
Perfect2You Дата: Среда, 09.08.2017, 16:09 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 234
Репутация: 59 ±
Замечаний: 0% ±

Excel 2010
Удалить строки формулы не могут. Это либо макрос, либо пользователь.
А вот пометить строки, которые подлежат удалению, формулы вполне способны. Как критерий Вам поможет функция ПОИСК, которая возвращает число, если подстрока найдена и ошибку, если нет.
Конструкция получится примерно такая:
Код
=СУММПРОИЗВ(--НЕ(ЕОШИБКА(ПОИСК('для удаления'!$A$1:$A$8;A4))))

В первом аргументе функции ПОИСК задан не один элемент для поиска, а массив. Соответственно и возвращен будет массив результатов поиска. От формулы массива спасает обработка функцией СУММПРОИЗВ. -- используется для преобразования логических ЛОЖЬ/ИСТИНА в 0/1.
Результат - получится количество частичных совпадений. Останется только отфильтровать ячейки со значениями 1 и больше (или не 0) и удалить только оставленные фильтром видимыми.

P.S.: Если я неверно понял: что где должно быть подстрокой, достаточно поменять аргументы функции ПОИСК местами. Остальное останется без изменений.
К сообщению приложен файл: _sample_kolbasa.xlsx(11Kb)


Сообщение отредактировал Perfect2You - Среда, 09.08.2017, 16:15
 
Ответить
СообщениеУдалить строки формулы не могут. Это либо макрос, либо пользователь.
А вот пометить строки, которые подлежат удалению, формулы вполне способны. Как критерий Вам поможет функция ПОИСК, которая возвращает число, если подстрока найдена и ошибку, если нет.
Конструкция получится примерно такая:
Код
=СУММПРОИЗВ(--НЕ(ЕОШИБКА(ПОИСК('для удаления'!$A$1:$A$8;A4))))

В первом аргументе функции ПОИСК задан не один элемент для поиска, а массив. Соответственно и возвращен будет массив результатов поиска. От формулы массива спасает обработка функцией СУММПРОИЗВ. -- используется для преобразования логических ЛОЖЬ/ИСТИНА в 0/1.
Результат - получится количество частичных совпадений. Останется только отфильтровать ячейки со значениями 1 и больше (или не 0) и удалить только оставленные фильтром видимыми.

P.S.: Если я неверно понял: что где должно быть подстрокой, достаточно поменять аргументы функции ПОИСК местами. Остальное останется без изменений.

Автор - Perfect2You
Дата добавления - 09.08.2017 в 16:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление строки при условии частичного совпадения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!