Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Дата текстом в дату - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дата текстом в дату (Формулы/Formulas)
Дата текстом в дату
IgMaxx Дата: Четверг, 10.08.2017, 09:36 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день уважаемым знатокам Excel!

Прошу помочь с проблемкой: дата в инвойсах приходит текстом, надо преобразовать нормальную в дату Excel. Год не имеет значения, к примеру здесь 2016. Главное как например 02DEC превратить в 02.12.2016 , чтобы это была полноценная дата. Извиняюсь, если где-то уже такое в форуме было, но я к сожалению не нашёл.

Заранее благодарю!
К сообщению приложен файл: Sample.xlsx(9Kb)


Сообщение отредактировал IgMaxx - Четверг, 10.08.2017, 09:39
 
Ответить
СообщениеДобрый день уважаемым знатокам Excel!

Прошу помочь с проблемкой: дата в инвойсах приходит текстом, надо преобразовать нормальную в дату Excel. Год не имеет значения, к примеру здесь 2016. Главное как например 02DEC превратить в 02.12.2016 , чтобы это была полноценная дата. Извиняюсь, если где-то уже такое в форуме было, но я к сожалению не нашёл.

Заранее благодарю!

Автор - IgMaxx
Дата добавления - 10.08.2017 в 09:36
китин Дата: Четверг, 10.08.2017, 09:50 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4278
Репутация: 665 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
И вам не хворать!!! :D
Как то так, наверное
Код
=ДАТА($E$1;ВПР(ПРАВБ(B2;3);{"Jan";1:"Feb";2:"Mar";3:"Apr";4:"May ";5:"Jun";6:"Jul";7:"Aug";8:"Sep ";9:"Oct";10:"Nov";11:"Dec";12};2;0);--ЛЕВБ(B2;2))
К сообщению приложен файл: IgMaxx.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 10.08.2017, 09:51
 
Ответить
СообщениеИ вам не хворать!!! :D
Как то так, наверное
Код
=ДАТА($E$1;ВПР(ПРАВБ(B2;3);{"Jan";1:"Feb";2:"Mar";3:"Apr";4:"May ";5:"Jun";6:"Jul";7:"Aug";8:"Sep ";9:"Oct";10:"Nov";11:"Dec";12};2;0);--ЛЕВБ(B2;2))

Автор - китин
Дата добавления - 10.08.2017 в 09:50
IgMaxx Дата: Четверг, 10.08.2017, 10:11 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Я всегда знал, что здесь лучшие УМЫ! Спасибо, очень помогли!!!
 
Ответить
СообщениеЯ всегда знал, что здесь лучшие УМЫ! Спасибо, очень помогли!!!

Автор - IgMaxx
Дата добавления - 10.08.2017 в 10:11
buchlotnik Дата: Четверг, 10.08.2017, 10:39 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2863
Репутация: 806 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
чутка короче
Код
=ДАТА($E$1;ПОИСК(ПРАВБ(B2;2);" anebarprayunulugepctovec")/2;--ЛЕВБ(B2;2))
К сообщению приложен файл: 7054887.xlsx(9Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениечутка короче
Код
=ДАТА($E$1;ПОИСК(ПРАВБ(B2;2);" anebarprayunulugepctovec")/2;--ЛЕВБ(B2;2))

Автор - buchlotnik
Дата добавления - 10.08.2017 в 10:39
_Boroda_ Дата: Четверг, 10.08.2017, 10:45 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10969
Репутация: 4555 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты по другому принципу
Массивный
Код
=--(ЛЕВБ(B2;2)&-ПОИСКПОЗ(ПРАВБ(B2;3);ТЕКСТ(СТРОКА($1:$12)*28;"[$-6]МММ");)&-E$1)

Обычный
Код
=--(ЛЕВБ(B2;2)&-ПРОСМОТР(;-1/(ПРАВБ(B2;3)=ТЕКСТ(СТРОКА($1:$12)*28;"[$-6]МММ"));СТРОКА($1:$12))&-E$1)

И Михаила без минусов "--"
Код
=ДАТА(E$1;ПОИСК(ПРАВБ(B2;2);" anebarprayunulugepctovec")/2;ЛЕВБ(B2;2))
К сообщению приложен файл: Sample-2-1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты по другому принципу
Массивный
Код
=--(ЛЕВБ(B2;2)&-ПОИСКПОЗ(ПРАВБ(B2;3);ТЕКСТ(СТРОКА($1:$12)*28;"[$-6]МММ");)&-E$1)

Обычный
Код
=--(ЛЕВБ(B2;2)&-ПРОСМОТР(;-1/(ПРАВБ(B2;3)=ТЕКСТ(СТРОКА($1:$12)*28;"[$-6]МММ"));СТРОКА($1:$12))&-E$1)

И Михаила без минусов "--"
Код
=ДАТА(E$1;ПОИСК(ПРАВБ(B2;2);" anebarprayunulugepctovec")/2;ЛЕВБ(B2;2))

Автор - _Boroda_
Дата добавления - 10.08.2017 в 10:45
Nic70y Дата: Четверг, 10.08.2017, 10:46 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4041
Репутация: 861 ±
Замечаний: 0% ±

Excel 2013
короче
два минуса в
--ЛЕВБ(B2;2)
можно убрать


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
короче
два минуса в
--ЛЕВБ(B2;2)
можно убрать

Автор - Nic70y
Дата добавления - 10.08.2017 в 10:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дата текстом в дату (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!